Thread Rating:
  • 0 Vote(s) - 0 Average
AppleTV 2 (black) - Missing Movies in Library
It seems there are several movies missing in my library on ATV.. For example, I added the movie Immortals to my main server (the file source for my atv). The movie is added the the xbmc library on the server without any problem. The atv won't recognized the file.
In the Video/Files menu, I can see the folder but the movie file isn't in there.
Going back to the source on my server, I specifically "shared" the Immortals movie folder with everyone on the network in case the issue was due to sharing but it didn't help. I've tried restarting xbmc but it didn't correct the problem either.
Is this a known issue? I remember coming across an addon that helped find missing movies. Does it work with ATV?
If the file is not named correctly it cannot be scraped and therefore wont be listed. How do you have the file named?
you might be right. This is a mp4 file I made from a bluray and I named it "immortals (2011).bluray". I have an nfo file in the folder too and assumed that would override any file naming issues. Evidently it's not an issue on my Windows server but it is with ATV.
I will try renaming and see if the same issue is the cause of other files to be missing.
I changed the file name to Immortals.mp4 but atv still doesnt recognize it. The file is over 2gigs.Would that affect the scraping process? Is there a problem with MP4s? I normally use MKV files.
I still haven't found a solution to this issue. I would appreciate any help.
What I've learned since is that it isn't an apple issue. The same movie will not show in the xbmc library on my laptop.
Format and size are fine. Try some of the solutions listed at Adding videos to the library/Incorrect and missing content (wiki)
Thanks Ned
I've tried Missing movie scanner and had no luck. I use Ember MM and my NFO files have seemed to always done their job. Under Videos/Files, I can see the movie folder but it is empty (except the extrathumbs folder inside of it). It's like the file itself is invisible to every device in my house with xbmc except the one on the server where the file is stored. Do you think it has anything to do with the fact my sources are connected via Windows SMB? If that is the case, why this movie? There are others missing in my ATV and laptop's library but I attributed the cause of them missing from the fact I scraped my entire library (over 400 movies) all at the same time. This is the first time one movie that I just added won't scrape.
Sounds like sharing permissions aren't being properly inherited. As in, files should inherit the permissions set on the folder (folder set to share, thus file is set to share). I've seen this happen before on my Mac, and I suspect other OSes can have similar issues. See if you can do something like set that specific folder/file to be shared, or go to the parent shared folder and toggle sharing off and on.

Logout Mark Read Team Forum Stats Members Help
Missing Movies in Library00