Thread Rating:
  • 0 Vote(s) - 0 Average
Why is xbmc trying to use PulseAudio?
#1
I installed xbmc Eden release on a fresh ubuntu 12.04 x64 full desktop installation. I realize this is beta software, but I am having other problems with ubuntu 11.10 and this is a test for that.

I forgot to remove PulseAudio before I installed xbmc. I have no audio with music or video. I have since removed Pulse audio and xbmc was still trying to use it. When I attempt to play a video or mp3, the log file has several of these error messages:
Code:
ERROR: PulseAudio: Failed to create context
XBMC is obviously still attempting to use pulse. I decided to remove xbmc with:
Code:
apt-get purge xbmc
apt-get reported that all the xbmc configuration files were removed.

I then re-installed xbmc. The nfs shares, and all other configuration settings were still there. When I tried to play audio, I still get the same pulse audio errors.

Surely there must be some persistent configuration file that tells xbmc to use pulse. Where is this kept, and what should I change it to?
Reply
#2
Just the try pulse if not avail punt to alsa code that triggers those msgs..

Get your alsa working and you will be fine.
Reply



Why is xbmc trying to use PulseAudio?00