My XBMC/NAS & some questions
Hello All.
My XBMC system (based on Asus AT5IONT-I) was recently moved from a standalone configuration on an SSD drive in a Frontier Elf to a 2x2TB system in a Gigabyte T5140.
The reason for this - no more room for my file server (damn kids, taking every available space of the house ;-) )
So I've decided to install XBMCBuntu on one of the drives and share my media from it to the rest of my network, which includes a Win7 desktop & laptop, an Xtreamer, some android phones & tablets and a PS3.

So I've managed to cramp all my movies to one of the 2TB drives on an NTFS filesystem, installed XBMCBuntu on the empty 2TB drive with the following partitions:
10GB as /
4GB as SWAP (my system has 4GB ram, and for my understanding - linux likes the swap partition the same size)
all the rest of the 2TB as /home.
I then used XBMCBuntu's file manager to move the files from the NTFS drive to the /home/user/Movies folder, then reinstalled XBMCBuntu with the same partition configuration but this time formatted my other 2TB to EXT4 and mount it as /storage.

Now I've noticed that using XBMCBuntu's file manager, I can't create folders on /storage due to insufficient permissions.
Going to terminal and using "sudo mkdir" works, but then I had to use "sudo chmod a+rwx" on the folder I've created so I can write files to it.

So here comes my questions (as I'm a linux noob) :
1. How can I mount /storage without security restrictions?
I want full read/write permissions to everyone, locally or remotely (which connects to my next 2 questions).
2. How can I share /storage with full rw anonymous permissions over SMB ?
3. How can I share /storage with full rw anonymous permissions over NFS ?

That's for now.
My future plans include finding a way to install JDownloader (or a different download manager) using a web interface to manage my downloads, running Skype on my TV through XBMCBuntu and learning how to remotely control the active session and opening a "background" session.
But that's just for the weekend :-)
Any help would be appreciated.
sudo chmod 777 /storage

Will give everyone +rwx permissions to /storage
I was sure I've already tried that, but now it worked :-)

So that solves the first question. How about sharing ?
OK, used to define SMB shares.
So far, done everything right before coming here except for "sudo chown nobody.nogroup /srv/samba/share/", which solved my permissions problem for the SMB shares.
Now going for NFS shares :-)

No need for NFS shares, cifs (samba) gives me full speed over 1GB network.
Found that the sharing was successful, but working localy over the XBMC (using ssh) created the files with user/user ownership, instead of nobody/nogroup (preventing managing the files over the network due to permission problems).
a simple "chmod 6777" to the storage folder solved that problem...
The fix above doesn't work...
Instead - at this stage I've followed this guide directing all the shared resources to a specific samba-shared folder i've created for this step.
Installed my HP DeskJet F4283 on my XBMC/NAS as a networked printer/scanner.
sudo apt-get install hplip
sudo hp-setup -i
and follow the wizard Wink
Then a simple
sudo restart smbd
sudo restart nmbd
to share the printer.

That took care of the printing part. Now for the scanning:
sudo nano /etc/default/saned
and change "RUN=no" to "RUN=yes".
sudo nano /etc/sane.d/saned.conf
and add your subnet. (mine was, so every computer in can use it to scan).
fix permissions & test:
sudo adduser saned lp
sudo -s
su -s /bin/bash saned
scanimage -L
if everything went right, you'll see something like
"device `hpaio:/usb/Deskjet_F4200_series?serial=CN87J2W28H05BR' is a Hewlett-Packard Deskjet_F4200_series all-in-one"
Now restarting the service & adding it to the startup:
sudo service saned restart
sudo update-rc.d saned defaults

Used &, with for setting up scanning on my Windows machine.
Update #1:
Installed Webmin for remote administration.

Update #2:
Installed pyload as a download manager instead of trying to make JDownloader work headless. Here's a step-by-step installation guide:

1. install & setup (command line)
sudo apt-get install python python-crypto python-pycurl python-openssl tesseract-ocr unrar
sudo dpkg -i ubuntu-cli
rm ubuntu-cli
if you want to use SSL (optional):
sudo openssl genrsa -out ssl.key 1024
openssl req -new -key ssl.key -out ssl.csr
openssl req -days 36500 -x509 -key ssl.key -in ssl.csr > ssl.crt
and follow the wizard: (note the fix to the autostart problem later, so change your config path now)
sudo python /usr/share/pyload/ -s
2. start pyLoad
/etc/init.d/pyload start

I've configured mine to use web-interface only on a non standard port, so the next step is checking that everything works :-)

Edit: Apparently the process doesn't auto-start after a reboot.
A fix is mentioned here but doesn't work for me. any help would be appreciated...

Update #3:
The autostart doesn't work because of permissions (used my user to install & configure, but apperently xbmc is loading with a different user, that doesn't have RW permissions to my home folder). The fix - at the setup, point pyload's configuration dir to a shared open directory.
You don't really need 4 GB of swap btw. You only do if you will be hibernating; in that case your swap file/partition should be the same size as your RAM.
* D-Link DIR-860L rev B1, LEDE 17.01.4+ :: HP Procurve V1410-8G switch
* LibreELEC:  HTPC Gigabyte Brix GB-BXA8-5545 with CEC adapter, Sony KDL52-NX800 :: Desktop AMD Ryzen 7 1800X / AMD HD6950 / 23" Dell Full HD
* Debian Stretch x86_64: Celeron G1610, NFS/MariaDB/ZFS server
* Blog
Installed Transmission for torrent downloads.
used this guide:
sudo apt-get install transmission-daemon
sudo /etc/init.d/transmission-daemon stop
sudo nano /etc/transmission-daemon/settings.json
"rpc-whitelist": "", to "rpc-whitelist": "*.*.*.*",
"rpc-password": "password",
"rpc-username": "username",
save & exit.
sudo /etc/init.d/transmission-daemon start
and now Transmission available at port 9091...
You might want to look into SABnzb and Sickbeard :-)
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
:-) Installed CouchPotato following this & this:
sudo apt-get install git-core
cd /usr/local/sbin
sudo git clone
sudo mv CouchPotato couchpotato
cd couchpotato
sudo cp initd.ubuntu /etc/init.d/couchpotato
sudo cp default.ubuntu /etc/default/couchpotato
sudo nano /etc/default/couchpotato
sudo chmod a+x /etc/init.d/couchpotato
sudo update-rc.d couchpotato defaults
sudo service couchpotato start
Then - if no errors, restart & try accessing your install at port 5000.
Thread Rating:
  • 1 Vote(s) - 5 Average

Logout Mark Read Team Forum Stats Members Help
My XBMC/NAS & some questions51