Thread Rating:
  • 0 Vote(s) - 0 Average
[ATV2] [solved] Error when compiling XBMC on 10.6.8

I have been unable to successfully compile XBMC upon ffmpeg_0.10.2 being merged in a few days ago (commit 28b186fd4621c0485608657892b7a3abcfe566ff). Since i remember the build processes being very finicky when it was originally set up, I wiped ~/xbmc as well as /Users/Shared/xbmc-depends and started from scratch to rule out any changes made by me. I have been following the instructions found in the README.ios file, line by line (just as i did a few weeks ago on the same system, successfully), but no dice. The build process fails during 'make xcode_depends' as it tries to build libavcodec/arm/ac3dsm_arm.o. I've searched through the forums (and google) but couldn't come up with anything relevent in regards to the unknown pseudo-op .arch. Has anyone seen anything like this?

Pastebin of error --

Information about my setup:

OSX 10.6.8
Xcode 3.2.6 w/ SDK.

Link to commit mentioned above --

Thanks for all your hard work on this project!
your gas-preprocessor needs updating.
MediaInfo :
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
I pulled from and copied to /usr/local/bin/ like you mentioned. Now it's purring like a kitten.

Thanks for the help!
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
[ATV2] [solved] Error when compiling XBMC on 10.6.800