•   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 54
  •   
Linux AudioEngine testers - Linux only
(2012-05-10, 18:32)luna_s Wrote: any clues? I used to have to have custom settings which I believe were plughw:0,7

Custom settings are gone with the AE merge. I'm also not getting any audio, however. I'm investigating.
HTPC: Gentoo linux amd64 w/ xbmc merged with AE
Reply
Think I need alsa 1.0.25 looking at the logs (just got to figure out how to do that!)
Reply
The offending commit in gnif's ae_rebase branch is 01f7fd827a3406e54de6bb4bcbb2d9bef50a93bc. Compiling against f0489b4ce3c6221c1153dde6c453b2e53f040e61 brings audio back.

The same commit in xbmc/master is c51d48331766a14e6ce0a4ce661f9ab1715a73dc. You can probably revert that commit before compiling to see if it restores audio. I have not yet tested that.
HTPC: Gentoo linux amd64 w/ xbmc merged with AE
Reply
Heh - that was the very last commit before the merge. Gnif's asleep right now, but I'm sure he'll see this in a few hrs.
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon  AVR-3808CI  - Denon DVD-5900 Universal Player  - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray  - X-Box 360  - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
Reply
I've had the AE no audio device error for awhile now too. Work fine in eden git - not in master as of this morning.

ATI R6xx audio over HDMI. Kernel 3.3.5 , alsa 1.0.25

[dc905]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 0/1
Subdevice #0: subdevice #0

[dc905]$ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
hdmi:CARD=Generic,DEV=0
HD-Audio Generic, HDMI 0
HDMI Audio Output

Reply
@dc2000, @wingrunr21 - XBMC log please
I am not scared of SVN - Cutting my hands open on the bleeding edge.
Reply
@wingrunr21 - I located the issue, the enumeration code was not releasing the audio device for XBMC to open for playback, I have pushed in a fix for this.
I am not scared of SVN - Cutting my hands open on the bleeding edge.
Reply
@gnif - this is from my latest build -b master (yesterday afternoon) . i built this time WITH --enable-pulse for a change & now get menu/ some sound.. even though i still get "error - no device" in my system menu.

xbmc.log :: http://pastebin.com/C5FJMxNd

xbmc.log.old :: http://pastebin.com/3kC2bMKD

xbmc_crashlog-20120510_174719 :: http://pastebin.com/9sh2jsKC
Reply
@gnif confirmed working at HEAD (6a7404b577db96f2a367c21d25904c37538c16a7)
HTPC: Gentoo linux amd64 w/ xbmc merged with AE
Reply
@dc2000 - Pulse is NOT supported yet, dont use it
I am not scared of SVN - Cutting my hands open on the bleeding edge.
Reply
@gnif - i will recompile without pulse. any --enable / -- disable configure options you would like me to use? also, should i compile gnif or xbmc master ?? let me know and ill re-compile right away.
Reply
@dc2000 you should probably compile xbmc master since gnif is pushing code there now
HTPC: Gentoo linux amd64 w/ xbmc merged with AE
Reply
@dc2000 - Yes, wingrunr21 is correct, don't use my branch any more, what is in master is considered the main AE branch now.

I am interested in the output from people's log files, specifically the audio device enumeration, please post it in here so we can get an idea of what your hardware is capable of as we develop stuff for it
I am not scared of SVN - Cutting my hands open on the bleeding edge.
Reply
@gnif @wingrunr21 - build with any configure flags ?
Reply
@dc2000 - none, just run ./configure
I am not scared of SVN - Cutting my hands open on the bleeding edge.
Reply
  •   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 54
  •   
 
Thread Rating:
  • 4 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
AudioEngine testers - Linux only54
This forum uses Lukasz Tkacz MyBB addons.