Linux AudioEngine testers - Linux only
Hi,
Firstly a great product, however I have a challenge, it is not picking up the ALSA device for my Nvidia. I have an old AMD system I am using with an imbedded Soundblaster card which I do not want to use. I have a NVIDIA GTX460 Card. In normal XBMC (running in parallel) it can see the NVIDIA Card so I know the driver is working (Although the sound is rubbish hence why I want to use this).

I am using Drivers 290.10 (I was using 295 but uninstalled after reading first post), system is ubuntu 11.10

Output from aplay -l
card 0: CA0106 [CA0106], device 0: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 1: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 2: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 3: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

output from xbmc.log
15:24:38 T:3048978192 INFO: CAESinkALSA::EnumerateDevicesEx - Unable to open hw:1 for capability detection
15:24:38 T:3048978192 INFO: Previous line repeats 3 times.
15:24:38 T:3048978192 ERROR: CAESinkOSS::EnumerateDevicesEx - Failed to open mixer: /dev/mixer
15:24:38 T:3048978192 INFO: Enumerated ALSA devices:
15:24:38 T:3048978192 INFO: Device 1
15:24:38 T:3048978192 INFO: m_deviceName : hw:CARD=CA0106,DEV=0
15:24:38 T:3048978192 INFO: m_displayName : CA0106
15:24:38 T:3048978192 INFO: m_displayNameExtra: CA0106
15:24:38 T:3048978192 INFO: m_deviceType : AE_DEVTYPE_PCM
15:24:38 T:3048978192 INFO: m_channels : FL,FR
15:24:38 T:3048978192 INFO: m_sampleRates : 48000,96000,192000
15:24:38 T:3048978192 INFO: m_dataFormats : AE_FMT_S32NE,AE_FMT_S16NE
15:24:38 T:3048978192 INFO: Device 2
15:24:38 T:3048978192 INFO: m_deviceName : hw:CARD=CA0106,DEV=1
15:24:38 T:3048978192 INFO: m_displayName : CA0106
15:24:38 T:3048978192 INFO: m_displayNameExtra: CA0106
15:24:38 T:3048978192 INFO: m_deviceType : AE_DEVTYPE_PCM
15:24:38 T:3048978192 INFO: m_channels : FL,FR
15:24:38 T:3048978192 INFO: m_sampleRates : 48000,96000,192000
15:24:38 T:3048978192 INFO: m_dataFormats : AE_FMT_S32NE,AE_FMT_S16NE
15:24:38 T:3048978192 INFO: Device 3
15:24:38 T:3048978192 INFO: m_deviceName : hw:CARD=CA0106,DEV=2
15:24:38 T:3048978192 INFO: m_displayName : CA0106
15:24:38 T:3048978192 INFO: m_displayNameExtra: CA0106
15:24:38 T:3048978192 INFO: m_deviceType : AE_DEVTYPE_PCM
15:24:38 T:3048978192 INFO: m_channels : FL,FR
15:24:38 T:3048978192 INFO: m_sampleRates : 48000,96000,192000
15:24:38 T:3048978192 INFO: m_dataFormats : AE_FMT_S32NE,AE_FMT_S16NE
15:24:38 T:3048978192 INFO: Device 4
15:24:38 T:3048978192 INFO: m_deviceName : hw:CARD=CA0106,DEV=3
15:24:38 T:3048978192 INFO: m_displayName : CA0106
15:24:38 T:3048978192 INFO: m_displayNameExtra: CA0106
15:24:38 T:3048978192 INFO: m_deviceType : AE_DEVTYPE_PCM
15:24:38 T:3048978192 INFO: m_channels : FL,FR
15:24:38 T:3048978192 INFO: m_sampleRates : 48000,96000,192000
15:24:38 T:3048978192 INFO: m_dataFormats : AE_FMT_S32NE,AE_FMT_S16NE

When I go into XBMC i just see the CA0106 in the Audio Options.

Thanks hope I can assist in the project.

Thanks
Dave
Reply
 
Thread Rating:
  • 4 Vote(s) - 5 Average


Messages In This Thread
Almost there, but still no HD - by OkvOkv - 2012-04-17, 03:54
Not Enumerating ALSA Device - by DaveInBracknell - 2012-05-09, 16:46
AudioEngine testers - Linux only - by Ritzie - 2012-05-12, 18:36


Logout Mark Read Team Forum Stats Members Help
AudioEngine testers - Linux only54
This forum uses Lukasz Tkacz MyBB addons.