Linux AudioEngine testers - Linux only
(2012-05-14, 14:35)wingrunr21 Wrote: No need for the pulse option, ./configure sets it to disabled by default. Also, instead of deleting and recloning you can do:

Code:
make clean
git reset HEAD --hard
git pull origin master
./bootstrap
./configure
make

Based on your log, it looks to me like AE is failing to open the PCM device in raw mode (snd_pcm_open_lconf returned a -16 error code). gnif will have to comment on what the actual cause is.

Thanks for the input Smile
I've noticed that error, too. In Eden I use hdmi:CARD=NVidia,DEV=3 but AE chooses hdmi:CARD=NVidia,DEV=0. For my naive interpretation it looks like AE uses the first device which matches the speaker layout. Since I'm still on alsa 10.0.24 and didn't found a way to update to 1.0.25 I'm stuck here Smile

Music plays fine, btw (OK, different player..).. Anyway. I keep on compiling and testing.

and aplay -L:
Code:
aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=2
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    HDMI Audio Output
dmix:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample mixing device
dmix:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct sample mixing device
dmix:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct sample mixing device
dmix:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Direct sample mixing device
dsnoop:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Direct sample snooping device
hw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
Home AV[/b]: Panasonic TX-P42ST33 Plasma | Onkyo TX-NR636 | Teufel 5.1 THX- Speakers | ATV2 | Wetek Core| DN2820FYK LibreElec | Harmony One Remote

Image
Reply
 
Thread Rating:
  • 4 Vote(s) - 5 Average


Messages In This Thread
Almost there, but still no HD - by OkvOkv - 2012-04-17, 03:54
AudioEngine testers - Linux only - by Ritzie - 2012-05-12, 18:36
RE: AudioEngine testers - Linux only - by ScotchTape - 2012-05-14, 16:00


Logout Mark Read Team Forum Stats Members Help
AudioEngine testers - Linux only54
This forum uses Lukasz Tkacz MyBB addons.