•   
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7(current)
Linux excessive CPU usage on Eden
#91
Hi,
I've read the thread, but I'm not sure if I caught the solution for the CPU usage issue. Does it mean the XBMC with XvBA support should solve it?
I'm running:
  • a minimal Ubuntu 11.10
  • with xserver-xorg-video-radeon
  • and XBMC 2:11.0~git20120321.14feb09-0ubuntu1~ppa1~oneiric from http://ppa.launchpad.net/team-xbmc/ppa/ubuntu/
  • on a DELL Inspiron 8600 with 1,7GHz Centrino
  • and ATI Radeon Mobility 9600.
  • set to 800x600 resolution (because there is still an old television connected via composite, will be probably changed in future)
I observed 50-60% CPU usage in main screen on idle which was dropped to ~25% after disabling RSS feeds, setting <nofliptimeout> to 0 and <algorithmdirtyregions> to 1 in advanedsettings.xml. The vertical blank sync doesn't work for me (almost the whole screen is flickering, if enabled). Maybe it is because of the xserver-xorg-video-radeon. But I didn't found whether the Mobility 9600 is supported by flgrx and I do not want to destroy my current installation just for testing (I even didn't know about the XvBA support up to now).
Additionally some videos are OK but some are very slow, e.g. MOV files from iPhone4 (videos of some friends from last vacation). I'm not sure if the hardware is too weak for the current video compressions and maybe even the 25% usage in main screen is normal for that hardware.

What do you think? Is it worth to give a try and will XvBA improve it?
Reply
#92
there is no xvba support on your hardware, its too old. 25% CPU on xbmc idle seems reasonable for your hardware.
Reply
#93
I've feared. But good to know. It is sufficient for using it as a jukebox and view some diashows. And this was the main purpose for me.
Anyway, thank you for your rating!
Reply
#94
hi
i have excessive cpu usage.
hw: at3iont-i deluxe, 4gb ram.
sw: ubuntu precise netinst + xbmc eden. howto.

maybe i messed up something while installing. dunno.

the cpu usage is quite high.
1278 xbmc 20 0 323m 104m 28m R 45% 3.5 20:45.60 xbmc.bin

i tried to "play" with the vsync cause in debug mode i saw 120fps. after redicing it was only 60. while playing a movie 24-25 based the fps of the movie.
still the same.

after downgrading the nvidia drivers to 173 the cpu runs at 100% Smile

no luck today.

any ideas?

meanwhile i found out that if i use the default confluence skin the cpu usage is only 4-6% which is ok for me.
(but only if i set drityregions to 1)
Reply
#95
Hi,

I have XBMCBuntu Eden on a AMD Quad Core, 8GB RAM, SSD, and I'm experiencing high CPU idle of around 50%, I have tried adding the dirty region fix in my advancedSettings.xml and also enable/disable vsync, but nothing has fixed this.

Does anyone have any idea's what I could do?

Thanks
Reply
#96
I've managed to get it down to 22% on idle by disabling background effect in Aeon skin, is this still high for idle?
Reply
#97
22% is a butterfly fart. I use confluence and I get around 15% on iddle with default hardcoded dirty regions value 3

For AEOn I think that's pretty awesome considering it as been known to hang and even crash xbmc sometimes I dont use Eden or Aeon or any other skin anymore because I rather have a decent skin that doesn't affect xbmc rather than one that looks HOT but fails often.

uNi
Reply
#98
Oh that's good news, I was getting concerned but glad its down to 20% I suppose if I switched to confluence it would be even lower. I just really like the look of the AEOn skin. Do you think I should apply the dirty regions fix or just leave it alone as it doesn't seem to effect the CPU usage, also what should the vsync option be set as?
Reply
#99
You can set dirty regions it will improve things further there's mode 1, 2, or 3 Frodo by default enables 3 with 0 as fliptimeout

See http://wiki.xbmc.org/index.php?title=Dirty_regions

uNi

Reply
Hai,

im at 5% cpu load now,
Ubuntu 12.04.1 , latest kernel, 3.0 ati drivers, minimal install, with sab, head phones, etc etc.
Reply
But what skin are you using ?
Reply
Hi,

new to this fora, but here are my 5 cents on the CPU load issue:
In my case CPU usage drops from 30 to 4-6% when I disable the RSS feed banner (Frodo RC3, Confluence, Intel I3, NVidia). No other mods.

Rgds
/N

Reply
  •   
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7(current)



Logout Mark Read Team Forum Stats Members Help
excessive CPU usage on Eden0
This forum uses Lukasz Tkacz MyBB addons.