MySQL DB deleting library when cannot connect to shares
Hi All,

I have a multi room setup of XBMC spread across two macs running Lion and two AppleTV (1st Gen) running Crystalbuntu. All of these machines are running XBMC Eden.

One of the macs is setup as the server with fixed IP address and all of my content attached on external USB drives. These drives are all shared by afp. MySQL runs on this mac. All of the other machines are correctly configured to look for this MySQL database and they all pick up the library and everything works great...for a while.

On numerous occasions now I have found that my AppleTVs seem to have lost the afp connection to the server, i.e. whenever I select a show from the library it says something along the lines of "file no longer available, would you like to remove it from the library?". I click no and try again just to be sure it wasn't just slow at loading the file and timed out or something, but with the same result. The specifics of why this happens are not part of this post - I am going to ask this in a more appropriate part of the forum. The reason I mention it is because it has set up the situation that I do want to try and solve in this post...if I rescan for content in this state (where I cannot connect to the afp shares) XBMC seems to think that this means there is no content in my library therefore it wipes the library completely. This of course is written to the MySQL database so now none of the other XBMC machines have a library any more - all because the file sharing went down on one machine.

So my question is this... Is there anything that can be done to prevent XBMC removing content that it cannot access? I realise this is a bit of an odd thing to ask since if it can't access the content then it is logical for XBMC to assume that this content does not exist, but if this inability to access content is due to a network error of some kind then it would be better for XBMC to alert the user perhaps? Or maybe set some kind of "ask before removing content" option to a scan.

It is possible that something to fix my problem already exists, if so please help me! I have just deleted my library for the fifth time in a week now and its getting frustrating!

Many thanks

Nothing to do with MYSQL - it will happen with SQLite databases as well.

The simple thing is to ensure you don't have <cleanonupdate> enabled - that way any scan won't remove content.

That still doesn't fix your problem, ofcourse, but at least it won't go and remove stuff during a scan.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

[Image: badge.gif]
Hi jmarshall,

Thanks for the swift reply. I have made the change you recommended.

As you say - it doesn't fix my problem, but it will stop me pulling my hair out until I do resolve it.

I have started a thread for the underlying issue here:


Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
MySQL DB deleting library when cannot connect to shares00