Installed Live to old IBM laptop - Not seeing attached SATA drive
I searched and found nothing. Closest I could find was a thread where they couldn't even install it on an attached SATA drive.

My dilemma is this. Got an old IBM Thinkpad. Fixed it up and installed XBMCLive 10 (I tried XBMCUbuntu, but it was just too slow and had weird issues)

On this laptop there are two bays. One has a DVD drive, and the other has a hotswap "SATA adapter" holding a 500 GB SATA Drive. When installing, it saw the drive just fine (I think it was there as SDA1 I think... I can't remember, but it was there, I recognized the "size" being under 500GB), but I chose the laptop's main 20GB HDD devoting the entire SATA drive for media.

Meanwhile, I take out the SATA drive and by using a USB adapter, attach it to my desktop PC where I copy over the media from my existing XBMC installation, all organized and scraped, folders and all. I attach back to the laptop, aaaaaaaand, I can't seem find it at all when browsing for folders.

The Linux file system is COMPLETELY foreign to me. Any help would be appreciated.
Thought I'd give this a bump as I still haven't found a solution.
I'm not the greatest either at mounting drives

This is what I do, but I'm stuck that they don't auto mount each time, I have to do some more research but should get you started. I have to run the last line of code again on each reboot, I was trawling this forum for help and you have me before I found the answer.

sudo fdisk -l

to find the name of the drive you want to mount and then

sudo mkdir /media/hdd1

sudo /media/hdd1 /dev/sda1

edit or the graphical way which I think I may do now.

david 1977 Wrote:You can install a tool. It´s called "pysdm". That helps me to get my HDD´s automatically mountet.

Log in into XBMCbuntu and search for the package with the package installer. Install it, run it, select sda1 (the drive maybe different, it also might be called sdb or something else) an on the right side in the window there had to be a button called "mount". Klick it, reboot an your drive should be mountet in /media/sda1(or something else)..

This might help you too:

or this:


Edit re read your question you may just need to look in /media folder

Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Installed Live to old IBM laptop - Not seeing attached SATA drive00