Thread Rating:
  • 0 Vote(s) - 0 Average
HDMI Handshake issue fixed
#1
I am not sure if this has been posted on the forums but after a long time battling with HDMI handshake issues, I came across a fix which has so far fixed my issues when switching inputs on my amp and losing signal to my XBMC PC. It aslo solved the issue whereby my resolution would change to what looked like 16bit colour.

Anyway, enough rambling. Here it is

The only thing I would add is to first run the program to get the EDID info from your TV.
Then disconnect the HDMI cable from your TV to the AVR and then run the program again to get the AVR EDID.
Then merge the two INF files together.

Hope this helps
Reply
#2
Good info,
However, it's mentioned in one of the threads that's linked from there that there's no need to merge them. See here.
Reply
#3
(2012-04-15, 21:15)sialivi Wrote: Good info,
However, it's mentioned in one of the threads that's linked from there that there's no need to merge them. See here.

Cool.

For me this find has totally transformed how much more I use XBMC. I found it totally frustrating to the point of abandoning it completely. I was using an NTV550 as my media player, but my HP Microserver with Eden way outperforms the Netgear.

I am now totally stoked.
Reply
#4
Glad that you're sorted Smile
Just wondering if anyone has a solution for XBMCLive ?
Would appreciate some pointers as Im living with this very issue.
Reply
#5
If you're using a Nvidia card you could try the 'CustomEDID' option in xorg.conf (guides can be found on google). If you're using an ATI card there is no solution unfortunately (fglrx doesn't support CustomEDID).
Reply
#6
(2012-04-16, 20:53)Snippo Wrote: If you're using a Nvidia card you could try the 'CustomEDID' option in xorg.conf (guides can be found on google). If you're using an ATI card there is no solution unfortunately (fglrx doesn't support CustomEDID).

Thanks for the tip... I am using a GT210, so Ill check it out.
Cheers!
Reply
#7
Do I want to use the EDID from my TV, or from the Denon AVR? By the looks of the post on AVSForum, I want to use the Denon AVR EDID.
Reply
#8
They are often a combination of the two...
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
Reply
#9
So then I do need to merge the two like instructed in the initial post in the Windows experts forum?
Reply
#10
I just got the HDmi Detective Plus and it fixed all my HDMI Handshake issues I was having with my HTPC.

It's a lillte pricey but well worth it if you want to once and for all fix all the HDMI Handshae isues!

http://www.amazon.com/Gefen-EXT-HDMI-EDI...B001RIMZUW


My HTPC is plugged into a Denon 1610 receiver and then into a Pioneer 5070 HDTV. And when I would leave my HTPC with XBMC running and the turn off my receiver at random times when I would turn the receiver back on there would be no signal coming from the HTPC. So the screen was just blank and the only way to get it back was I had to hard reset the computer. Other issues I had was if I had a video playing either in XBMC or any other media player in full screen and then I turned off the receiver when I would turn it back on the video would crash to the desktop everytime.

Since adding the HDmi Detective Plus it has fixed every issue I was having. I can now turn off and on my receiver and it never messes up the playing video or loses the signal form the HTPC.


HDmi Detective Plus is one awesome little device that wiill save you a lot of headeggs!!

http://www.gefen.com/kvm/dproduct.jsp?prod_id=8005


I highly recommend it!!!
Reply
#11
I managed to find a solution for my problem in xbmcbuntu. The command
Code:
sudo service lightdm restart
restarts the X server and reinitializes the screen. After that it works fine again.

I mapped the command to a button on my remote so I don't have to SSH in to the box everytime I get a black screen:
Find the name of the button you wish to use by typing
Code:
irw
and pressing the button. I used the "media" button on the HP (MCE) Pavillion remote.
Then
Code:
sudo nano /home/<username>/.lircrc
Add the following and save:
Code:
# Start XBMC
begin
prog = irexec
button = <name of the button you wish to use>
config = sudo /home/<username>/scripts/startXBMC.sh
end
Edit rc.local:
Code:
sudo nano /etc/rc.local
Add the following line and save:
Code:
#start IRexec
su -c '/usr/bin/irexec -d /home/<username>/.lircrc' -l xbmc

Create a file startXBMC.sh in /home/<username>/scripts/:
Code:
sudo nano /home/<username>/scripts/startXBMC.sh
And add the following lines:
Code:
#restart lightdm
sudo service lightdm restart
#restart xbmc
#killall -9 xbmc.bin
Make the script executable with:
Code:
sudo chmod +x /home/<username>/scripts/startXBMC.sh
If you want to also use this button to restart xbmc in case it crashes you'll have to remove the # on the last line.
Because the service lightdm restart command needs root access you need to start the script as sudo without having to type a password:
Code:
sudo visudo
Add:
Code:
%sudo ALL=(ALL) NOPASSWD:/home/<username>/scripts/startXBMC.sh
and save.
Edit:
If your username isn't part of the admin group it won't work. You can change '%admin' to '<username>' or:
Code:
adduser <username> sudo

Edit 2: Seems the admin group is replaced by sudo in newer versions of Ubuntu.
Credits go to this post Smile
Reply
#12
Sorry to drag up an old post, does anyone have any information from the original link provided by the OP as it's a dead link.

I have issues with HDMI handshake between both my laptop and PC when switching inputs on my Samsung receiver.
Reply
#13
The following works for me:

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:01:00:0"
Option "ConnectedMonitor" "DFP-0,DFP-1"
Option "UseHotplugEvents" "false"
Option "UseEDID" "true"
Option "IgnoreEDID" "false"
Option "CustomEDID" "DFP-0:/etc/X11/epson.edid.bin;DFP-1:/etc/X11/onkyo.edid.bin"
Reply
#14
I realize this is an old thread. I hope this helps someone that is also experiencing this issue.

I have 3 Kodi Chromeboxes connected to flat screen TV's that were experiencing a HDMI handshaking issue. Two of the TV's are 4K and one is 1080P. I get a message "No Signal" on the TV if I start the Kodi system first and then later start the TV. If I start the TV first and then start Kodi the issue doesn't occur. From what I understand the issue is cause by the TV's EDID info not being read by the Kodi box because the TV is off.

I found a simple, FREE solution which is documented in the Wiki. It basically allows you to read the EDID info from the TV and permanently load it into Kodi. It fixed the problem on one of my 4K systems.

See the following link. Go down the "Custom EDID" section.

http://wiki.openelec.tv/index.php/Config...#tab=Intel

I used Putty to ssh into my Kodi box. I copied\pasted each command into the Putty terminal screen.

I am trying to figure out why it doesn't work on two of my systems. If someone has some advice I would appreciate any info. I will update if I make any progress.

Regards
Larry
Reply



HDMI Handshake issue fixed00