The TVDB scraper is currently broken due to upgrade works at TheTVDB site. We hope this issue will be resolved quickly.

  •   
  • 1
  • 349
  • 350
  • 351(current)
  • 352
  • 353
  • 356
  •   
Media Companion 3 beta's - Now with Music Video support
(2019-07-07, 05:34)Karellen Wrote: @vbat99

In case you are not aware of changes at TVDB from 15 July. New v3 API followed by v4 API a few months later.

https://beta.thetvdb.com/blog/something_new

The endpoints are...
V1: https://beta.thetvdb.com/api
V2: https://api.beta.thetvdb.com

The new frontend is located at https://beta.thetvdb.com.

Odd, although they mention V3 API on their blog of June 13, 2019, there is no info on API V3 on their API documentation page. Only mentioning V 2.2.0
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
Quote:Our plan is to launch both the new API and website on July 15. Please note that the V2 API will include an endpoint for movies, but support for all of the other new site functionality will be coming in future API updates
This is what TVDB state. Not sure how it is all working. Maybe "v3" and "v2 updates" phrases are being used interchangeably?
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
Hi everyone !

I have one stupid question : how to scrap movie set please ?
I have seen the Tab MovieSet, but when I want to scrap one set, I have an error message for the setup of Fanart.tv. But I haven’t any problem for scrapping movies...

Can anyone help me please ?
Reply
(2019-07-10, 20:39)Nicodeme Wrote: Hi everyone !

I have one stupid question : how to scrap movie set please ?
I have seen the Tab MovieSet, but when I want to scrap one set, I have an error message for the setup of Fanart.tv. But I haven’t any problem for scrapping movies...

Can anyone help me please ?
Thanks for the repost
For scraping of Movie sets you only have to enable that under movie preferences, scraper settings . to get the artwork you can choose to get that from fanart.tv or from tmdb . if you're just wanted to test I would disable getting fanart.tv artwork for Movie sets and just give it a try. It works I use it all the time
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
(2019-07-10, 21:10)vbat99 Wrote:
(2019-07-10, 20:39)Nicodeme Wrote: Hi everyone !

I have one stupid question : how to scrap movie set please ?
I have seen the Tab MovieSet, but when I want to scrap one set, I have an error message for the setup of Fanart.tv. But I haven’t any problem for scrapping movies...

Can anyone help me please ?
Thanks for the repost
For scraping of Movie sets you only have to enable that under movie preferences, scraper settings . to get the artwork you can choose to get that from fanart.tv or from tmdb . if you're just wanted to test I would disable getting fanart.tv artwork for Movie sets and just give it a try. It works I use it all the time 

I think i don"t understand...

Here's my setup in one picture. My folder tree, then the error message i have when i scrape fanart or poster for a movie set, and the scraper and artwork setup i have in media companion. Where is my mistake please ?

Image
Reply
(2019-07-11, 11:55)Nicodeme Wrote: I think i don"t understand...

Here's my setup in one picture. My folder tree, then the error message i have when i scrape fanart or poster for a movie set, and the scraper and artwork setup i have in media companion. Where is my mistake please ?

Ok, I found an error when the collection folder does not match the Collection name.
EG you have Ironman Saga, where MC was looking for IronMan Collection.

I have a fix for this, for the next release of Media Companion.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
I’m not mad !!! Thank you Wink
Reply
Hi !

I have another problem. I don't think it come from the software but i can't found what mistake i made in the naming or the hierarchical order.

I must say i have the problem only with this movie. I use the same process with all and only "48 hours" bug...

Here's a screenshot. When i search for new movie, the soft see "48 hours", use "48 hours 1982" and scrape "48 hours 1982 (1901)". Normal at this point, i have the same result with other movie. Then i use the 'Change movie' tab, find the right movie and click the Go button. Then i have this message (in red on the screenshot) but nothing happend. I must kill the process, 30 minutes waiting but nothing.

Have you an idea please ?

EDIT: Finally, i have the problem with all movies... Must be a parameter but cant see it... Sad

Image
Reply
(2019-07-18, 17:31)Nicodeme Wrote: Hi !

I have another problem. I don't think it come from the software but i can't found what mistake i made in the naming or the hierarchical order.

I must say i have the problem only with this movie. I use the same process with all and only "48 hours" bug...

Here's a screenshot. When i search for new movie, the soft see "48 hours", use "48 hours 1982" and scrape "48 hours 1982 (1901)". Normal at this point, i have the same result with other movie. Then i use the 'Change movie' tab, find the right movie and click the Go button. Then i have this message (in red on the screenshot) but nothing happend. I must kill the process, 30 minutes waiting but nothing.

Have you an idea please ?

EDIT: Finally, i have the problem with all movies... Must be a parameter but cant see it... Sad

Tested at my end, but no issue. Could be a language issue as IMDb is GeoIp enables, so I do not get the same results as you as mine is always english.

Although I highly recommend using TMDb as primary scraper not IMDb.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
(2019-07-19, 09:41)vbat99 Wrote:
(2019-07-18, 17:31)Nicodeme Wrote: Hi !

I have another problem. I don't think it come from the software but i can't found what mistake i made in the naming or the hierarchical order.

I must say i have the problem only with this movie. I use the same process with all and only "48 hours" bug...

Here's a screenshot. When i search for new movie, the soft see "48 hours", use "48 hours 1982" and scrape "48 hours 1982 (1901)". Normal at this point, i have the same result with other movie. Then i use the 'Change movie' tab, find the right movie and click the Go button. Then i have this message (in red on the screenshot) but nothing happend. I must kill the process, 30 minutes waiting but nothing.

Have you an idea please ?

EDIT: Finally, i have the problem with all movies... Must be a parameter but cant see it... Sad

Tested at my end, but no issue. Could be a language issue as IMDb is GeoIp enables, so I do not get the same results as you as mine is always english.

Although I highly recommend using TMDb as primary scraper not IMDb. 

OK. I have reset configuration and after some parameters, it works again, sorry.

Another problem i have : some movie are scraped but dont appear in list. In log, everything seems OK :

Scraping Title: Constantine - City of Demons
Movie Body Scraped OK
HD Tags Added OK
TMDb Actors scraped:- 9
Extra Frodo Poster thumbs: 6
Extra Frodo Fanart thumbs: 4
Pre-Frodo poster URLs scraping not enabled
Poster(s) scraped OK
Fanart URL Scraped OK
Scraping from Fanart.Tv, not selected
Scraping Extra Fanart-Thumbs not selected

What happend please ?
Reply
(2019-07-19, 23:44)Nicodeme Wrote:
(2019-07-19, 09:41)vbat99 Wrote:
(2019-07-18, 17:31)Nicodeme Wrote: Hi !

I have another problem. I don't think it come from the software but i can't found what mistake i made in the naming or the hierarchical order.

I must say i have the problem only with this movie. I use the same process with all and only "48 hours" bug...

Here's a screenshot. When i search for new movie, the soft see "48 hours", use "48 hours 1982" and scrape "48 hours 1982 (1901)". Normal at this point, i have the same result with other movie. Then i use the 'Change movie' tab, find the right movie and click the Go button. Then i have this message (in red on the screenshot) but nothing happend. I must kill the process, 30 minutes waiting but nothing.

Have you an idea please ?

EDIT: Finally, i have the problem with all movies... Must be a parameter but cant see it... Sad

Tested at my end, but no issue. Could be a language issue as IMDb is GeoIp enables, so I do not get the same results as you as mine is always english.

Although I highly recommend using TMDb as primary scraper not IMDb. 

OK. I have reset configuration and after some parameters, it works again, sorry.

Another problem i have : some movie are scraped but dont appear in list. In log, everything seems OK :

Scraping Title: Constantine - City of Demons
Movie Body Scraped OK
HD Tags Added OK
TMDb Actors scraped:- 9
Extra Frodo Poster thumbs: 6
Extra Frodo Fanart thumbs: 4
Pre-Frodo poster URLs scraping not enabled
Poster(s) scraped OK
Fanart URL Scraped OK
Scraping from Fanart.Tv, not selected
Scraping Extra Fanart-Thumbs not selected

What happend please ?

Try disable all movie filters (right click on movie filters, select configure Movie Filters, and disable all.)
Then do a refresh all, see if it appears int he list.
If not, upload somewhere and attach to a pm to me please.
Alternatively, open a discussion on sourceforge https://sourceforge.net/p/mediacompanion...n/general/
and attach the nfo for this movie to the discussion.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
@vbat99 Do you think there is a chance that you have desire to implement the new KyraDB API artwork types? It's just for movies. 
ArtworkBeef implemented it in early July.
Image
Kodi artwork type wikipedia also updated:

https://kodi.wiki/view/Artwork_types#characterart.23
https://kodi.wiki/view/Artwork_types#Animated_Artwork

It's just simple:
single artwork type: "animatedposter.gif"
both possible, single and multi: "animatedfanart(x).gif", "characterart(x).png"

animatedposter.gif

animatedfanart.gif
animatedfanart1.gif
animatedfanart2.gif
...
characterart.png
characterart1.png
characterart2.png
...

I really like the new features very much in ArtworkBeef, but i have to admit i always prefer MC for Artwork managing.
Would be really nice.
Reply
(2019-07-19, 23:55)vbat99 Wrote:
(2019-07-19, 23:44)Nicodeme Wrote:
(2019-07-19, 09:41)vbat99 Wrote:  
 

Try disable all movie filters (right click on movie filters, select configure Movie Filters, and disable all.)
Then do a refresh all, see if it appears int he list.
If not, upload somewhere and attach to a pm to me please.
Alternatively, open a discussion on sourceforge https://sourceforge.net/p/mediacompanion...n/general/
and attach the nfo for this movie to the discussion. 

This ! I'm a noob... Thanks for yours responses and your patience ! Great software Wink
Reply
(2019-07-20, 13:57)chrissix Wrote: @vbat99 Do you think there is a chance that you have desire to implement the new KyraDB API artwork types? It's just for movies. 
ArtworkBeef implemented it in early July.
Image
Kodi artwork type wikipedia also updated:

https://kodi.wiki/view/Artwork_types#characterart.23
https://kodi.wiki/view/Artwork_types#Animated_Artwork

It's just simple:
single artwork type: "animatedposter.gif"
both possible, single and multi: "animatedfanart(x).gif", "characterart(x).png"

animatedposter.gif

animatedfanart.gif
animatedfanart1.gif
animatedfanart2.gif
...
characterart.png
characterart1.png
characterart2.png
...

I really like the new features very much in ArtworkBeef, but i have to admit i always prefer MC for Artwork managing.
Would be really nice.
Not something I can whip up at this time. But I will add this at a later stage.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
(2019-07-23, 10:31)vbat99 Wrote: Not something I can whip up at this time. But I will add this at a later stage.
a great pity atm  Confused
looking forward to this implementation.
Reply
  •   
  • 1
  • 349
  • 350
  • 351(current)
  • 352
  • 353
  • 356
  •   
 
Thread Rating:
  • 10 Vote(s) - 4.7 Average



Logout Mark Read Team Forum Stats Members Help
Media Companion 3 beta's - Now with Music Video support4.710