•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 386
  •   
Media Companion 3 beta's - Now with Music Video support
#61
(2012-04-18, 21:54)HueyHq Wrote:
(2012-04-18, 15:44)trpltongue Wrote: As I mentioned in the other thread, I think MC is a great program. I've only been testing for a couple days but I've been very impressed. I'm curious about the trailer download comment. I saw the checkbox for downloading trailers, but MC didn't seem to download any for my test setup of about 30 movies (all new releases so trailers are definitely available). I'm also going to enter a "bug" in codeplex around automatically monitoring media folders and scraping when a new folder is added.
Yeah, I'm a bit vague about trailers because I have never used that feature - there has always been someone else around to handle those questions!
As far as I'm aware, by checking the box for trailers, I think it makes a button appear on the main page that says 'Download Trailer'(?), tucked away in the middle there somewhere. I'm afraid it is a manual thing, but it does give you precise control over what trailers you want!
There is also something about adding a link to trailers in the .nfo file, but I'm not sure if XBMC does anything with that or not.
Post back your findings 'cos I'd be interested in how it works. If it doesn't work, then I will finally need to familiarise myself with trailers!

(Oops, there were other posts!)
(2012-04-18, 15:50)IAmNotAUser Wrote: There isn't a download trailer option in MC, only a "Add movie trailer URL to nfo" option, as far as I'm aware. That does exactly what it says on the tin, it puts something similar to
Quote:<trailer>http://pdl.stream.aol.com/pdlext/aol/brightcove/us/moviefone/trailers/2011/missionimpossibleghostprotocol_10037190/missionimpossibleghostprotocol_trlr_01_720p_dl.mov</trailer>
inside the NFO file. Some skins (at least Neon for sure, it may be all skins now or baked into XBMC core) give you the option to press down inside the Movie library and it will stream that file.
@IAmNotAUser: Thanks for that, I thought that was the case somehow!

Huey,

Sorry forgot to reply back with my trailer experience. I understand that Media Companion is suppossed to add a trailer URL to the nfo file and then you can manually push a button on each movie to download the trailer. However, what is happening for me is that it does NOT download the trailer URL on the initial scrape. However, if I do a batch scrape for just the trailer, then it adds the URL. I have to admit I haven't tested this on the latest Alpha release yet so I don't know if the behaviour has changed. The trailer URL is good enough for me.

Oh, and again, kudos to you guys. I wish I had the skills to do what you guys do.
Reply
#62
(2012-05-30, 07:37)trpltongue Wrote: vbat99,

Thanks for posting my question in the new thread. The google search for an IMDB id makes a lot of sense because everytime I scraped the nfo file would have an IMDB id (it was bogus, but it was there). So then, what is the purpose of the "Use XBMC scraper" option in the movie preferences? I thought if I selected this option, along with "TMDB", Media Companion would try to scrape the movie using the xbmc engine from tmdb?

I'm not too sure the sequence, maybe Hueyhq can confirm how best you can proceed.

Other option if not too many DVD s is to copy and nfo and manually edit it to your DVD. Then refresh it in media companion to scrape posters etc. Just b thought.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
#63
(2012-05-30, 08:47)vbat99 Wrote: I'm not too sure the sequence, maybe Hueyhq can confirm how best you can proceed.

Other option if not too many DVD s is to copy and nfo and manually edit it to your DVD. Then refresh it in media companion to scrape posters etc. Just b thought.

I have 10 discs in this particular set. I did the following workaround:
1) Let MC scrape the info using IMDB (even though I had tmdb selected) and it generated the bogus nfo files.
2) Opened each movie's nfo file and cleared out everything except the title and the IMDB ID.
3) Replaced the bogus movie title with the actual movie title
4) Replaced the IMDB ID with the TMDB ID and saved the nfo file. I did this for all 10 discs.
5) Launched MC and selected each movie individually and clicked the "re-scrape movie" button (or whatever it's actually called).

This pulled the proper metadata info but not the cover art or fan art.

6) Tried to use the auto cover art and fanart puller but they didn't work.
7) Manually added the fan art and cover art using the "URL" buttons and the images from TMDB

Overall a very tedious process but it worked.

I just don't think that TMDB scraping is working quite right. Even when MC pulled the metadata from TMDB properly, it couldn't find the posters or fanart (which were on the TMDB page).
Reply
#64
There has got to be a look up on the movie DB. Using the IMDB id. You've done almost all of it so maybe download the posters and fan art manually and name them as per the nfo.

Stormy, Huey or another dev will have to advised if there's an easier way. Sorry, at my limit to help at this point.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
#65
(2012-05-30, 10:34)vbat99 Wrote: There has got to be a look up on the movie DB. Using the IMDB id. You've done almost all of it so maybe download the posters and fan art manually and name them as per the nfo.

Stormy, Huey or another dev will have to advised if there's an easier way. Sorry, at my limit to help at this point.

That's exactly what I did. I used the "URL" button to add fanart and poster for each disc. So now everything is complete Smile In all honesty, I doubt I'll have this problem again as I don't usually buy workout DVD's so they are usually listed on IMDB Wink This was just one of those rare occurences that leads to the realization that MC might not be working properly.

It is nice to have TMDB as a fallback to IMDB as there are some films that IMDB doesn't have listed that TMDB does and vice versa so it would be good to have it working.

I should mention if anyone wants to re-create the issue, the particular DVD set is the "Insanity" workout DVD's. The first of which is titled "Insanity - 1. Dig Deeper & Fit Test". The TMDB link is here: http://www.themoviedb.org/movie/49655-in...r-fit-test
Reply
#66
Well, I did a quick test, and setting MC to use XBMC's TMDB scraper, caused a crash.

Definitely MC's own scrapers are searching for IMDB ID and using that, which when I tried to scrape Insanity - 1. Dig Deeper & Fit Test (2009).avi it gave me Ugly Betty. Er, Na!

So I set up a second instance of XBMC in portable mode, and scraped in Insanity - 1. Dig Deeper & Fit Test (2009).avi correctly.

Then I exported separate files including nfo, tbn and fanart, and XBMC put them with Insanity - 1. Dig Deeper & Fit Test (2009).avi

Opened MC and that video was added to the list. But no option to change poster or fanart. It couldn't find it on TheMovieDB.

This is definitely something that will need to be worked on for MC.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
#67
Hi guys,
I had a quick look at this last night (until the missus caught me at it instead of doing proper jobs!) and I see that the tmdb.xml scraper tool is different or outdated from the one in my XBMC Eden installation.
I'm thinking, (altho' I haven't tested that theory) that the TMDb scrape failed over to the IMDb scrape...maybe.
Regardless, looking at the two files, the TMDb URL used is different so it may mean that MC needs to update its XBMC scrapers. You can do it yourself by copying it from your XBMC install (under 'addons') into the Assets folder, I think.
Probably not necessary now that trpltongue has sorted his issue but would be interesting to see if there is a difference.
Reply
#68
Just tested this out, and MC complained about the addon.xml

Looking at the xml and noted a few description changes, so edited till MC didn't complain and tried with XBMC TMDB scraper.

MC still crashed just saying "Sorry for the inconvenience..." etc.

So just a recap, can't copy TMDB addon.xml directly to MC, Even tried with tmdb.xml, still no joy.

Edit: Noticed there were two folders in MC and XBMC regarding Themoviedb.org metadata.common.themoviedb.org & metadata.themoviedb.org

So copied all from metadata.themoviedb.org and still issues. Removed one line regarding youtube and now get crash message
[code]ERROR: The remote server returned an error (404) Not Found.
URL:
http://api.themoviedb.org/3/search/movie...anguage=en[code]

So still no luck.
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
#69
Guys,

Thanks soooo much for looking into this. I've been out of town for work the last couple days so I wasn't able to respond. It got me to thinking about my movie collection and I went back through and realized that I actually have quite a few documentaries that are not listed in IMDB, but are captured on tmdb, so it may be more useful than I originally thought.
Reply
#70
Just wondering if it would be possible to add the ability to save movie posters as posters.jpg as well as folder.jpg? Thanks.
YOYIZDERZOMENEMOHOZEZAZEZDENDERIZHOZEZ
Reply
#71
MC 3.503B Released

Media Companion 3.503b
Quote:Release Notes
It has been a while, so it's about time we release another build!

Major effort has been for fixing trailer downloads, plus a little bit of work for episode guide tag in TV show NFOs.

Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply
#72
(2012-06-01, 21:38)bobrap Wrote: Just wondering if it would be possible to add the ability to save movie posters as posters.jpg as well as folder.jpg? Thanks.

Maybe?
YOYIZDERZOMENEMOHOZEZAZEZDENDERIZHOZEZ
Reply
#73
Hi.

I've just recently discovered MC and love it. My whole movie collection is tagged correctly now forever. Thanks for that.

However, I can't seem to get MC to scrape my tv shows. I'm using MC 3.5. My file structure is tvshows/show title (year)/show title - s00e00 episode title.ext . I've tried adding a season folder, but it didn't work. The MC scraper finds nothing. It shows a whole bunch of red x with no text behind it, and after scraping is done it clears everything and says 0 tv shows. So there is no way to add them manually.

Anyone know what I can try next?
Reply
#74
(2012-07-15, 13:04)a11813087 Wrote: Hi.

I've just recently discovered MC and love it. My whole movie collection is tagged correctly now forever. Thanks for that.

However, I can't seem to get MC to scrape my tv shows. I'm using MC 3.5. My file structure is tvshows/show title (year)/show title - s00e00 episode title.ext . I've tried adding a season folder, but it didn't work. The MC scraper finds nothing. It shows a whole bunch of red x with no text behind it, and after scraping is done it clears everything and says 0 tv shows. So there is no way to add them manually.

Anyone know what I can try next?
Without knowing exactly what is happening, I will hazard a guess that your episodes are already scraped, and you are attempting to put them in season folders?
In theory, MC shouldn't care about whether there are season folders or not - only the episodes below the show folder. Unfortunately, the cache file remembers where everything is, and any movement of files confuses things. It certainly needs fixing up, but for now, I suggest trying TV Shows -> Refresh all TV Shows to rebuild the cache file. I recommend this is the first thing to try if there are any problems with MC; let us know if there are any further problems! Big Grin
Reply
#75
Thanks for your reply.

There are no episodes scraped though, and I didn't change the folders to fuck with MC during the scraping or after Wink. Just tried that after it failed without them (clearing everything first), because it was the only thing that was different in the MC help guide. I thought the problem was not having season folders, but that didn't fix it (and I'm glad to hear they are not mandatory).

I'll try to explain the problem more clearly. After adding the tv show folders it starts scraping. Then it shows a whole bunch of red x's with no text behind them, and after scraping is done it clears everything and says 0 tv shows and 0 episodes. I think it is the fact that it doesn't recognize any of my shows, makes the red x and (for some reason I don't know) it doesn't put text after that (like the help guide says it should). Then after scraping is done the scraper script clears all it's own errors automatically (like those x's without text behind them). Which leaves my tv show list emty with 0 tvshows and 0 episodes.

I've played around with it and the problem is the 'year' in my foldername. XBMC couldn't find my tv shows either because of that (fixed that by having .nfo's with the tvdb-link in each folder). I would hate it if I had to delete all the years for it to work with MC. I can get it working for shows that have a year in there tvdb-name like 'Archer (2009)'. All the other tv shows are gone after scraping. Is this a bug? Or am I going to have to except not having the year in my foldernames?

I made screenshots, one during scraping, and one after. http://i45.tinypic.com/xlz491.jpg
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 386
  •   



Logout Mark Read Team Forum Stats Members Help
Media Companion 3 beta's - Now with Music Video support10
This forum uses Lukasz Tkacz MyBB addons.