Not detecting second monitor
#1
Hi just installed lates xbmcbuntu. I have a laptop with ati radeon 5470, it has hdmi and VGA output. But can't get xbmc to recognize that there is a second monitor. It just says screen 1 or windowed. Hdmi does nothing and VGA basically just duplicates the 1366x768 resolution which is no help as I want full hd and the laptop screen to be off.

In xorg.conf file it is just showing screen. Any help on this would be good.

Thanks

Dan
Reply
#2
(2012-04-17, 21:58)Wallpaper_01 Wrote: Hi just installed lates xbmcbuntu. I have a laptop with ati radeon 5470, it has hdmi and VGA output. But can't get xbmc to recognize that there is a second monitor. It just says screen 1 or windowed. Hdmi does nothing and VGA basically just duplicates the 1366x768 resolution which is no help as I want full hd and the laptop screen to be off.

In xorg.conf file it is just showing screen. Any help on this would be good.

Thanks

Dan

I,m having the same problem along with audio problems.

| Cooler Master MasterCase Maker 5 | Gigabyte Aorus X299 Ultra Gaming Motherboard | Intel Core i7 [email protected] | Corsair Vengence 16GB x 2 Ram | Samsung SSD 960 PRO 512GB M.2 |
| Western Digital 1TB HDD | HGST Ultrastar 4TB HDD | Gigabyte GeForce GTX 950 Extreme | Ubuntu 20.04 x86_64 | Windows 10 Pro 1909 |
Reply
#3
Same problem here, can't detect any second monitor.

Anyone found a solution to this yet?
Reply
#4
You guys have to go into Ubuntu itself to set up multi-monitor desktops. In XBMC click "Exit" under the power button. From there you should get to a log in prompt. Change the log in to XBMCbuntu (or Ubuntu, I forget), from XBMC. This will get you to the desktop (underlying OS). Not sure from there for ATI, but under nVidia, you go to your settings and enable TwinView. On my computer I had to actually modify xorg.conf to enable TwinView. From there I disabled my laptop screen and enabled the TV. You should be able to mess around with ATI settings in there.

I hope this helps. Don't get me started on Audio problems - this has been a nightmare. I still can't recognize HDMI as an audio hardware in XBMCbuntu (so no chance in hell it will work in XBMC from what I gather).

This has turned into quite a little project.
Looking more into your issue it looks like AMD may just not have drivers that support this at the moment for Linux. I guess this is the price we pay for leaving the comfortable world of Windows/Mac?
Reply
#5
(2012-07-04, 01:01)keep_pabst_blue Wrote: You guys have to go into Ubuntu itself to set up multi-monitor desktops. In XBMC click "Exit" under the power button. From there you should get to a log in prompt. Change the log in to XBMCbuntu (or Ubuntu, I forget), from XBMC. This will get you to the desktop (underlying OS). Not sure from there for ATI, but under nVidia, you go to your settings and enable TwinView. On my computer I had to actually modify xorg.conf to enable TwinView. From there I disabled my laptop screen and enabled the TV. You should be able to mess around with ATI settings in there.

I hope this helps. Don't get me started on Audio problems - this has been a nightmare. I still can't recognize HDMI as an audio hardware in XBMCbuntu (so no chance in hell it will work in XBMC from what I gather).

This has turned into quite a little project.
Looking more into your issue it looks like AMD may just not have drivers that support this at the moment for Linux. I guess this is the price we pay for leaving the comfortable world of Windows/Mac?

Did you just set TwinView to "True"?

Reply
#6
# TwinView Options:
Option “TwinView” “True”
Option “TwinViewOrientation” “Clone”
#”Clone” for two identical screens, “LeftOf” or “RightOf” for one long,
# fused screen.
Option “UseEdidFreqs” “True”
Option “MetaModes” “1280×1024,1280×1024; 1024×768,1024×768″
Option “UseDisplayDevice” “CRT, TV”
# End of TwinView Options

nvm, this is how I solved it.
Reply
#7
Hi Kongkopa,

Do you have two "Monitor" and two "Screen" sections in your xorg.conf file or just one of each?

Been able to enable twinview using the nvidia gui and apply the change but when I reboot the second screen is disabled.

Thanks

Paul

Reply
#8
(2012-07-04, 01:01)keep_pabst_blue Wrote: You guys have to go into Ubuntu itself to set up multi-monitor desktops. In XBMC click "Exit" under the power button. From there you should get to a log in prompt. Change the log in to XBMCbuntu (or Ubuntu, I forget), from XBMC. This will get you to the desktop (underlying OS). Not sure from there for ATI, but under nVidia, you go to your settings and enable TwinView. On my computer I had to actually modify xorg.conf to enable TwinView. From there I disabled my laptop screen and enabled the TV. You should be able to mess around with ATI settings in there.

I hope this helps. Don't get me started on Audio problems - this has been a nightmare. I still can't recognize HDMI as an audio hardware in XBMCbuntu (so no chance in hell it will work in XBMC from what I gather).

This has turned into quite a little project.
Looking more into your issue it looks like AMD may just not have drivers that support this at the moment for Linux. I guess this is the price we pay for leaving the comfortable world of Windows/Mac?

THANK YOU!!! That worked for me... Never thought of that...
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Not detecting second monitor00