Linux - "Failed to Initialise Audio Device" with VOB file
XBMC Eden 11.0 - installed from PPA
Ubuntu 11.10
Zotac Zbox mini (i686)

Problem: When I play .VOB video files, I get an error message "Failed to Initialise Audio Device, Check Audio Settings". The video itself plays ok but with no audio.

All other video file formats play fine, as do audio files & internet streams.

VOB files previously played ok with audio on Dharma and when I first upgraded to Eden.

Video Settings:

Audio Output: HDMI
Audio Output Device: DEFAULTS (ALSA)
Passthrough Output Device: HDMI (ALSA)

I have the xmbc.log but I'm not sure how to attach it. I believe the relevant lines are:

15:36:08 T:6473520 NOTICE: DVDPlayer: Opening: /home/zbox/smb4k/QNAPTS-112/home/Videos/Home videos/1997/VTS_01_1.VOB
15:36:08 T:6473520 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
15:36:08 T:2958027632 NOTICE: Creating InputStream
15:36:08 T:2958027632 NOTICE: Creating Demuxer
15:36:09 T:2958027632 NOTICE: Opening video stream: 0 source: 256
15:36:09 T:2958027632 NOTICE: Creating video codec with codec id: 2
15:36:09 T:2958027632 NOTICE: CDVDVideoCodecFFmpeg::Open() Creating VDPAU(720x480, 2)
15:36:09 T:2958027632 NOTICE: vdp_device = 0xffffffff vdp_st = 0x00000001
15:36:09 T:2958027632 ERROR: (VDPAU) unable to init VDPAU - vdp_st = 0x1. Falling back.
15:36:09 T:2958027632 NOTICE: CDVDVideoCodecFFmpeg::Open() Failed to get VDPAU device
15:36:09 T:2958027632 NOTICE: (VDPAU) Close
15:36:09 T:2958027632 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: MPEG-2 video
15:36:09 T:2958027632 NOTICE: Creating video thread
15:36:09 T:2958027632 NOTICE: Opening audio stream: 1 source: 256
15:36:09 T:2958027632 NOTICE: Finding audio codec for: 86019
15:36:09 T:3006532464 NOTICE: running thread: video_thread
15:36:09 T:2958027632 NOTICE: Creating audio thread
15:36:09 T:2998139760 NOTICE: running thread: CDVDPlayerAudio:Tonguerocess()
15:36:09 T:2998139760 NOTICE: Creating audio device with codec id: 86019, channels: 2, sample rate: 48000, pass-through
15:36:09 T:3006532464 NOTICE: fps: 29.970030, pwidth: 720, pheight: 480, dwidth: 640, dheight: 480
15:36:09 T:3006532464 NOTICE: Display resolution ADJUST : DFP2: 1920x1080 @ 59.94Hz (14) (weight: 0.000)
15:36:09 T:2998139760 ERROR: Initialize - device hdmi:AES0=0x6,AES1=0x82,AES2=0x0,AES3=0x2 busy retrying...
15:36:10 T:2998139760 ERROR: Initialize - failed to open custom device hdmi:AES0=0x6,AES1=0x82,AES2=0x0,AES3=0x2 (errorBig Grinevice or resource busy), retry with default hdmi
15:36:10 T:2998139760 ERROR: Initialize - pcm_open_lconf, alsa error: -16 - Device or resource busy
15:36:10 T:2998139760 ERROR: Creating a Null Audio Renderer, Check your audio settings as this should not happen

Thanks for any help.
I had the same problem with some movies. This is how I solved it:

1. Installed ATI/AMD fglrx driver.
2. Made changes to advancedsettings.xml according to

gedit ~/.xbmc/userdata/advancedsettings.xml

insert the following:

<loglevel hide="false">0</loglevel>
<cputempcommand>sensors|sed -ne "s/temp1: \+[-+]\([0-9]\+\).*/\1 C/p"</cputempcommand>
<gputempcommand>/usr/bin/aticonfig --od-gettemperature | grep Temperature | cut -f 2 -d "-" | cut -f 1 -d "." | sed -e "s, ,," | sed 's/$/ C/'</gputempcommand>

3. Deinstalled fglrx driver (on my system XBMC is constantly having CPU on 25-30% with that driver)

I do not know why is 1. and 3. necessary, but it worked that way. Now all movies play as expected, no XBMC crashes.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
"Failed to Initialise Audio Device" with VOB file00