ATV2 not plating MKV files
Hi All,

I have a problem whereby certain MKV files work on my windows XBMC install but not ATV2. Both are using a shared library via MySQL and both are using the same login to the samba share. In the logs I get a permission denied error but this can't be right.

Does anyone know of any debugs I can run on the NAS (QNAP) to see XBMC trying to log in/stream the file? Or is there a way of testing a connection to the NAS from the ATV CLI?

22:41:03 T:125456384 DEBUG: DoWork - trying to extract filestream details from video file smb:// Series/Derek/Season 1/derek.S01E01.720p.hdtv.x264-tla.mkv
22:41:03 T:125456384 DEBUG: OpenDir - Using authentication url smb://<removed>@192%2e168%2e1%2e82/Qmultimedia
22:41:03 T:124399616 DEBUG: Thread Background Loader 124399616 terminating
22:41:04 T:125456384 DEBUG: CFileSMB::Open - opened Qmultimedia/Video/TV Series/Derek/Season 1/derek.S01E01.720p.hdtv.x264-tla.mkv, fd=-1
22:41:04 T:125456384 INFO: FileSmb->Open: Unable to open file : 'smb://<removed>@192%2e168%2e1%2e82/Qmultimedia/Video/TV%20Series/Derek/Season%201/derek%2eS01E01%2e720p%2ehdtv%2ex264%2dtla%2emkv'
unix_err:'d' error : 'Permission denied'

I have an admin user on the NAS who is effectivily the root user. I also have user 'xbox' who has read only access to everything. All my files are owned by admin but xbox can play them.

This setup has worked for all my files but not this one. However, when I change the owner of this problem file to xbox, it works!! Is there some advanced permissions somewhere that I can't find.

-rw-rw----    1 xbox     administ484102201 Apr 12 16:00 derek.S01E01.720p.mkv

Any ideasHuh[/quote]
The -rw-rw---- means is can be read and written do by the owner and the group members. Since I doubt the xbox user is in the administrator group that user couldn't read this file unless it was, either in that group, or the owner

I would bet if you looked at other files that work they would have -rw-rw-r--- or -rw-rw-rw-
You are right, xbox is not a member of the administrators group but all other files definately have -rw-rw---- and work. I've just rebuilt the permissions so that every file and folder is owned by admin and has rw-rw---- and everything is working now, xbox is able to play the files from the ATV2...even the problem file now I've changed the owner to admin!

The admin user is part of the 'everyone' group and so is xbox, could the group permissions be being applied because of this, or is the everyone group a special case?

...And the strange thing is that my windows xbmc uses the xbox username and never had a problem, only xbox being sourced from the ATV2 had a problem.
Any ideas anyone? Another example, a file I moved from sabnzbd completed directory doesn't work but the existing ones do:

-rwxrwx---    1 admin    administ366235704 Feb  7 11:27 Glee.S03E12.HDTV.XviD-LOL.avi*  <-- Works
-rwxrwx---    1 admin    administ1438620479 Apr 11 11:30 Glee.S03E15.Big.Brother.720p.WEB-DL.DD5.1.H.264-ECI.mkv*  <-- Does not work

What is the difference between the above two files?
At this point I'd assume your NAS box uses some sort of permission overlay and not the native file permissions to serve files so I don't think these permissions have any relevence
I had a similar problem with my QNAP and ATV2. I switched to AFP (Apple Filing Protocol) and it mainly went away, but then I upgraded to a new QNAP and it cropped back up, even on AFP. I fixed it on the QNAP by going into the Web Gui, Access Rights Management > Advanced Options > Enable Advanced Folder Permissions.
Then I went into Share Folders > QMultimedia > TV and explicitly gave the user permission. Make sure "Apply and replace all existing permissions of this folder, files, and subfolders" is checked.

It might take a little bit. Once it's done, your permission issues should be fixed.

I have noticed that ocassionally when sabnzbd/sickbeard saves it it doesn't have permission sometime and I have to play with new files, but this should at least make existing files work.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
ATV2 not plating MKV files00