• 1
  • 2
  • 3(current)
  • 4
  • 5
  • 7
Linux - HOW-TO The Complete Linux N00bs' Guide To Installing ZSNES on XMBCbuntu
(2012-05-28, 12:25)SKIBBE Wrote: or i will just make a shortcut to zsnes and browse from there Smile

Just remember to leave out the -m part of the arguments:

-m -s -v 22 %rom%

or you wont have access to the GUI in ZSNES.
Media Centre: Atom Dual-Core - Nvidia ION - 4GB RAM - 250GB HDD - Blu-Ray - XBMCbuntu 11.0 - ReFocus
Server: FreeNAS 8 - 8x 1TB Seagate Baracuda RAID-Z - SABnzbd - SickBeard - CouchPotato
(2012-05-28, 12:19)TehCrucible Wrote:
(2012-05-22, 06:37)bulkymicrowav Wrote: I have run into one issue with my setup. It seems as though my controller is still controlling XBMC under the emulator

Hmm, not sure about this one. Doesnt do it for me. Do you use the same controller as a remote normally or are you using a seperate remote to control XBMC? What kind of remote/controller are you using? And have you made any changes to your XML files or LIRC settings previously?

Thanks for the update Angelscry. Brilliant work with Advanced Laucher, by the way! Big Grin

I am using a Logitech F710. I did not make any changes to the LIRC setting. I ended up reverting back to a previous state and I don't seem to have the same issues now.
Thank you for the tutorial. I personally wont use it but must say, looks very easy and im sure has helped loads of people.
Keep it up mate Smile
Left you some rep.
That last step makes me very happy that I don't use LIRC! If you have a remote that emulates key presses (Tivo Slide like me, or use FLIRC with any IR remote) then that whole complicated mess to exit simply becomes "map a remote key to the ESC button", and you're done Smile
Thanks for the tutorial. I have a bunch of retroports from retrousb.com that have been begging me to set up some emulators!
I signed up to this site just to thankyou for your tutorial i am a linux noob and i found this tutorial very easy to understand and i am using the zsnes emulator on XMBCbuntu now
ohh and any chance you want to do a megadrive, NES, sega master system and playstation 1 & 2 tutorial as well? lol just kidding but i would use them Smile
Running "Eden" here, on an Acer Revo 6310.

I too have to no sound issue, sadly your guide did not help for me. When i change the .asoundrc my xbmc video playback crashes on start (known issue on these forums)

So i'm kinda stuck Sad

If anyone has some recommendations or wants to point me in the right direction, i'd be very happy!

i wonder if you have heard of the hyperspin project .? http://www.youtube.com/watch?v=_KCcfMstxSI you may be interested to get this running Smile
(2012-06-22, 04:55)fakie Wrote: i wonder if you have heard of the hyperspin project .? http://www.youtube.com/watch?v=_KCcfMstxSI you may be interested to get this running Smile
Hyperspin is only for Windows.

Hey guys, semi-n00b to linux and definitely to xbmc.

I got zsnes running in my desktop just fine but when I start the advanced launcher through xbmc the title screen of my game will come up and then it goes dark but I still hear audio. It will take inputs from my controller because I can hear the confirmation sounds but just no video whatsoever.

I've tried changing the filters and everything but to no avail. The only thing I can do at that point is ssh in from another box and kill the xbmc-standalone process.

My video drivers (ati/amd) are up to date and like I said, it works just fine from the desktop, so I've been wracking my brain about what might be interfering. Thanks in advance!
So I think I figured out a little the black screen issue I'm having. What happens is that when I hit the A button (I'm using an xbox wireless controller with a dongle attached to server) the screen blacks out.

Is it possible it's taking this input as an xbmc command and swapping video sources or some such? If I use a keyboard I can hit \ to go out of fullscreen and then esc to back out and that puts me back in the program menu but that doesn't really fix the underlying issue. Any ideas/directions? Thanks guys.

Thanks for the guide!
Wanted to give my info here as to how i got sound working (fully functioning.. menu navigation sounds + video playback audio + snes audio).

I run xbmcbuntu eden on an asus eee eb1012.I have audio on my TV directly connected through HDMI.

I followed the guide but still could not get sound to work, what finally solved my problems was using the following settings in XBMC:
Audio output: HDMI
Speaker configuration: 2.0
Boost volume level on downmix: Enabled
- Dolby Digital (AC3) capable receiver: Disabled
- DTS capable receiver: Disabled
Audio output device: Custom
Custom Audio device: plughw:0,3
Passthrough output device: Custom
Custom passthrough device: plughw:0,3

I deleted my .asoundrc file (might want to make a backup) and then created a new onw with the following configuration:
defaults.pcm.!card NVidia
defaults.ctl.!card NVidia
defaults.pcm.!device 3
defaults.ctl.!device 3

Also make sure to run zsnes with the
-ad sdl
command line as descirbed in this guide.

Remember to REBOOT after making those changes!

Hope this helps someone.
Awesome tutorial.

I managed to get ZSNES working through Rom Collection Browser on my XBMCBuntu install. It worked perfectly (with sound!) with zero fiddling. The only problem is this:

When I started up ZSNES for the first time, it was in a tiny (I'm guessing 640x480) screen in the top-left corner. A quick search revealed that ALT+ENTER makes it run full screen, which is awesome. I played a round of F-Zero, and closed the emulator which brought me back to XBMC. I picked a different game and it blipped to a black screen for a second, but came right back to XBMC without loading the emulator. I thought maybe it was a bad ROM, so I tried F-Zero again, and same result. I couldn't get into any of the ROMs. However, each time I try, the "times played" counter goes up, so something is happening.

I thought it might have something to do with the fullscreen, so I manually changed ZSNES' config file and set the resolution back to it's default and I was able to get back into ZSNES once again. If I exit while in the tiny, windowed mode, I can go back in fine. But if I exit ZSNES while in a fullscreen mode, it won't allow me back in until I manually set the resolution back.

Any thoughts?
Hey guys, sorry for late replies. I've been working on other projects. To the guys having issues with fullscreen and blackscreen etc, I didn't have these issues when setting up mine so I can't really give you a quick fix answer. I can only suggest playing around with the -v 22 toggle in the command line parameters. This controls the resolution and display settings on lauch. More details on the various available modes are found here:

Media Centre: Atom Dual-Core - Nvidia ION - 4GB RAM - 250GB HDD - Blu-Ray - XBMCbuntu 11.0 - ReFocus
Server: FreeNAS 8 - 8x 1TB Seagate Baracuda RAID-Z - SABnzbd - SickBeard - CouchPotato
hopefully working on some new emulators....hint hint
Thanks for this, I bit the bullet and installed Eden. All seems good after a bit of fiddling around.

Sound took a long while to resolve but now that it's sorted out it works for MAME and PCSX-Reloaded as well as ZSNES. I imagine it will also work for other emulators.

FWIW the process of installing MAME and PCSXR is pretty similar to ZSNES.

Create the folders, put in a few ROMs, and run "sudo apt-get install sdlmame" or "sudo apt-get install pcsxr".

PCSX-R appears in the games folder of the XBMCBUNTU gui like ZSNES and can be configured in much the same way. Main thing for me was to switch to opengl plugin for the video then set the video size, fullscreen etc. Sound *should* work if your preferred output is the default sound device on your system. There seem to be several different ways to do this and it seems like the best one varies from case to case.

MAME needs to be run from xterm instead (no shortcut gets created in the games folder) and before you run it you need to configure mame.ini

To make them shutdown with the remote script from the tutorial I just added "killall mame" and "killall pcsx" after "killall zsnes" in the shutdown.sh script.

btw the advanced launcher wiki (eg http://www.gwenael.org/xbmc/index.php?ti..._/_SDLMAME ) has good info on the correct switches etc to use with each emulator. Note that some of the file locations aren't right though; for example PCSX is in /usr/games

I am trying to work out if it's worth adding any other emulators besides these three. Any thoughts?

I've got to be honest I installed these on a whim but these old school games are a lot of fun.
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 7
Thread Rating:
  • 4 Vote(s) - 4.75 Average

Logout Mark Read Team Forum Stats Members Help
HOW-TO The Complete Linux N00bs' Guide To Installing ZSNES on XMBCbuntu4.754