Thread Rating:
  • 0 Vote(s) - 0 Average
Add-on script errors
#1
I'm new to XBMC and I'm having a problem with add-on script errors. No matter what video add-on I install, when I select it I get a script error.
I enabled logging and all errors are import errors of this kind.

16:03:12 T:2904 NOTICE: -->Python Interpreter Initialized<--
16:03:12 T:2904 ERROR: Error Type: <type 'exceptions.ImportError'>
16:03:12 T:2904 ERROR: Error Contents: No module named os
16:03:14 T:4808 ERROR: CRemoteControl::Connect - failed to connect
16:03:24 T:4608 NOTICE: -->Python Interpreter Initialized<--
16:03:24 T:4608 ERROR: Error Type: <type 'exceptions.ImportError'>
16:03:24 T:4608 ERROR: Error Contents: No module named urllib2
16:03:24 T:3712 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.espn.video
16:03:24 T:3712 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.espn.video) failed

all are similar, I only included one for space reasons. I also get a similar error when program is starting for the weather app.
Reply
#2
Hi,

I am getting a similar error, No module named urllib2.

Were you able to resolve this issue Huh

Could anyone please tell how to fix this issue Huh
Reply
#3
Could you post as full debug log. It's usually the only way to solve problems...
Image
For troubleshooting and bug reporting please make sure you read this first you can also use XBMC Log Uploader Script.
Cinema Experience
Cinema Experience Wiki
cdART Manager
fanart.tv


Reply
#4
Hi Giftie,

I tried xbmc twice, I see different errors in log files

Here is the log file from my first run . XBMC hung on this run.
http://pastebin.com/XZJDMwVx

These are the errors to be resolved from the first run
[email protected]:~$ cat /media/Angstrom/home/root/.xbmc/temp/xbmc.old.log | grep ERROR
01:00:02 T:1109606928 ERROR: special://masterprofile/guisettings.xml, Line 0
01:00:02 T:1109606928 ERROR: Unable to load special://masterprofile/guisettings.xml, creating new special://masterprofile/guisettings.xml with default values
01:00:02 T:1109606928 ERROR: DeleteFile - cant delete file </home/root/.xbmc/userdata/guisettings.xml>. trying lower case </home/root/.xbmc/userdata/guisettings.xml>
01:00:19 T:1109606928 ERROR: Unable to open audio mixer
01:00:20 T:1256322144 ERROR: Error Type: <type 'exceptions.ImportError'>
01:00:20 T:1256322144 ERROR: Error Contents: No module named urllib2
01:00:20 T:1256322144 ERROR: Traceback (most recent call last):
01:00:58 T:1198240864 ERROR: convert_checked iconv_open() failed from UTF-8 to CP1252, errno=22(Invalid argument)
01:00:58 T:1198240864 ERROR: convert_checked iconv_open() failed from UTF-8 to CP1252, errno=22(Invalid argument)
01:00:58 T:1198240864 ERROR: convert_checked iconv_open() failed from UTF-8 to CP1252, errno=22(Invalid argument)


Here is the onle from the second run. It gave some python errors in the lower bottom screen but kept working.
http://pastebin.com/nALaENgs

These are the errors essentially to be resolved from the 2nd run
[email protected]:~$ cat /media/Angstrom/home/root/.xbmc/temp/xbmc.log | grep ERROR
01:17:34 T:1074782736 ERROR: Unable to open audio mixer
01:17:36 T:1269355616 ERROR: Error Type: <type 'exceptions.ImportError'>
01:17:36 T:1269355616 ERROR: Error Contents: No module named urllib2
01:17:36 T:1269355616 ERROR: Traceback (most recent call last):

I am surprised why this error "ERROR: convert_checked iconv_open() failed from UTF-8 to CP1252, errno=22(Invalid argument)" was reported in the first run and not the second one. Any ideasHuh

thanks
Chahat

Reply
#5
(2012-08-04, 10:13)chahat Wrote: Hi Giftie,

I tried xbmc twice, I see different errors in log files

Here is the log file from my first run . XBMC hung on this run.
http://pastebin.com/XZJDMwVx

These are the errors to be resolved from the first run
[email protected]:~$ cat /media/Angstrom/home/root/.xbmc/temp/xbmc.old.log | grep ERROR
01:00:02 T:1109606928 ERROR: special://masterprofile/guisettings.xml, Line 0
01:00:02 T:1109606928 ERROR: Unable to load special://masterprofile/guisettings.xml, creating new special://masterprofile/guisettings.xml with default values
01:00:02 T:1109606928 ERROR: DeleteFile - cant delete file </home/root/.xbmc/userdata/guisettings.xml>. trying lower case </home/root/.xbmc/userdata/guisettings.xml>
01:00:19 T:1109606928 ERROR: Unable to open audio mixer
01:00:20 T:1256322144 ERROR: Error Type: <type 'exceptions.ImportError'>
01:00:20 T:1256322144 ERROR: Error Contents: No module named urllib2
01:00:20 T:1256322144 ERROR: Traceback (most recent call last):
01:00:58 T:1198240864 ERROR: convert_checked iconv_open() failed from UTF-8 to CP1252, errno=22(Invalid argument)
01:00:58 T:1198240864 ERROR: convert_checked iconv_open() failed from UTF-8 to CP1252, errno=22(Invalid argument)
01:00:58 T:1198240864 ERROR: convert_checked iconv_open() failed from UTF-8 to CP1252, errno=22(Invalid argument)


Here is the onle from the second run. It gave some python errors in the lower bottom screen but kept working.
http://pastebin.com/nALaENgs

These are the errors essentially to be resolved from the 2nd run
[email protected]:~$ cat /media/Angstrom/home/root/.xbmc/temp/xbmc.log | grep ERROR
01:17:34 T:1074782736 ERROR: Unable to open audio mixer
01:17:36 T:1269355616 ERROR: Error Type: <type 'exceptions.ImportError'>
01:17:36 T:1269355616 ERROR: Error Contents: No module named urllib2
01:17:36 T:1269355616 ERROR: Traceback (most recent call last):

I am surprised why this error "ERROR: convert_checked iconv_open() failed from UTF-8 to CP1252, errno=22(Invalid argument)" was reported in the first run and not the second one. Any ideasHuh

thanks
Chahat

XBMC uses system Python, which on your system shows as version 2.7 which has the urllib2 module installed by default. Not sure why it is missing on your system...
Image
For troubleshooting and bug reporting please make sure you read this first you can also use XBMC Log Uploader Script.
Cinema Experience
Cinema Experience Wiki
cdART Manager
fanart.tv


Reply
#6
Hi Giftie,

Thanks for looking through the logs. I am trying to make xbmc run on beagleboard, am running the Angstrom distro. I used the bitbake command to build it. Could you please tell me if i could do something to reinstall/rebuild python while creating the image ??

I am new to this, any help would be highly appreciable.

thanks
Chahat
Reply
#7
Try putting this file into your /usr/lib/python2.7 folder -> https://github.com/downloads/Giftie/xbmc/urllib2.py

Not sure if you are going to need to re-compile XBMC or not..
Image
For troubleshooting and bug reporting please make sure you read this first you can also use XBMC Log Uploader Script.
Cinema Experience
Cinema Experience Wiki
cdART Manager
fanart.tv


Reply
#8
Hi Giftie,

This is a html page. Are you sure this is what you wanted ??

thanks
Chahat
Reply
#9
it's a link to the module file that you seem to be missing.. Download it and store it in your /usr/lib/python2.7
Image
For troubleshooting and bug reporting please make sure you read this first you can also use XBMC Log Uploader Script.
Cinema Experience
Cinema Experience Wiki
cdART Manager
fanart.tv


Reply



Add-on script errors00