•   
  • 1
  • 101
  • 102
  • 103(current)
  • 104
  • 105
  • 128
  •   
[Release] Backup (formerly XBMC Backup)
I had been using this addon for a while and doing manual backups with it.

Today it stopped work and will not even run , i also see i got a few updates today, googleapi 1.6.4, and oauth2client 4.1.2
maybe the update broke it

this is the error i get in the log when i try and run it


06:58:10.764 T:6812   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ImportError'>
                                            Error Contents: No module named apiclient.discovery
                                            Traceback (most recent call last):
                                              File "C:\Kodi\portable_data\addons\script.xbmcbackup\scheduler.py", line 9, in <module>
                                                from resources.lib.backup import XbmcBackup
                                              File "C:\Kodi\portable_data\addons\script.xbmcbackup\resources\lib\backup.py", line 7, in <module>
                                                from vfs import XBMCFileSystem,DropboxFileSystem,ZipFileSystem,GoogleDriveFilesystem
                                              File "C:\Kodi\portable_data\addons\script.xbmcbackup\resources\lib\vfs.py", line 9, in <module>
                                                from pydrive.auth import GoogleAuth
                                              File "C:\Kodi\portable_data\addons\script.xbmcbackup\resources\lib\pydrive\auth.py", line 6, in <module>
                                                from apiclient.discovery import build
                                            ImportError: No module named apiclient.discovery
                                            -->End of Python script error report<--
0
Reply
Hi, same issue here, plugin stopped working today, all I get is: "Backup error, check the log for more information".
So here's my debug log after a reboot and tried to start a backup: https://pastebin.com/2HUww7pY
Reply
also have that issue

so nothing specific with you guy

i have try multiple devices "to confirm it is kodi backup app and not anyone setup in particular)

i hope kodi devs look at this forum .... lol
Reply
(2017-12-02, 16:48)duboisbrian Wrote: also have that issue

so nothing specific with you guy

i have try multiple devices "to confirm it is kodi backup app and not anyone setup in particular)

i hope kodi devs look at this forum .... lol


He does and I also posted it on github.
Reply
Glad to see I'm not the only one all of a sudden getting the error.
Reply
I started getting the “backup error check log” message today. Strange thing is I’m not actually using the addon for anything and don’t have any backups running or scheduled. I get the error message every time I start Kodi. Only way to stop it is to disable the addon. Strange.
Reply
.....
Reply
I’m also having the same problem on 3 out of 4 of my boxes. Interestingly the only box it’s not playing up on is the one that is running Android 6 (not sure of exact version number), the others are all 5 or 4
Reply
(2017-12-02, 22:17)PAULAAJ2601 Wrote: I’m also having the same problem on 3 out of 4 of my boxes. Interestingly the only box it’s not playing up on is the one that is running Android 6 (not sure of exact version number), the others are all 5 or 4

The box that didn’t have a problem has now started getting the backup error after installing updates

Googleapi
IMDb scraper
Oauth2client
Reply
(2017-11-18, 22:03)Karellen Wrote: @tetsuo00

You have not enabled debug mode in Settings>System Settings>Logging. Please try again. Make sure you capture your problem in the log, if you don't then there is nothing to see.
Perhaps I can help.  I have a similar problem with Backup failing.  My last successful backup with v1.0.9 was 0400 CDT today.  All failures since then with 1.0.5 and 1.0.6 as well. The latest version of Backup that still works for me is 1.0.2.  At the bottom of the log file look for Python error referring to a missing "apiclient.discovery module.  This does not appear in the log with v1.0.2.   My Kodi is running on two Win 10 platforms at my home and both exhibit the same problem and log file entries.  Here is your debug link:  https://paste.ubuntu.com/26098524/
Reply
(2017-12-02, 20:19)wags1 Wrote: I started getting the “backup error check log” message today. Strange thing is I’m not actually using the addon for anything and don’t have any backups running or scheduled. I get the error message every time I start Kodi. Only way to stop it is to disable the addon. Strange.
Yep... Same exact thing happens to me.
Reply
(2017-12-02, 20:26)Blurayx Wrote:  I'm using the latest git release. It's working for me: https://github.com/robweber/xbmcbackup/ 

How do you install it from github?
Reply
UPDATE:
@Karellen-Link removed
Reply
@jeffshead

Be aware of our forum rules. Please do not link to tutorials that use Piracy repositories as examples.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
same for libreelec and windows 10 for me (both Kodi 17.6 ).
some log: https://paste.ubuntu.com/26101596/
Reply
  •   
  • 1
  • 101
  • 102
  • 103(current)
  • 104
  • 105
  • 128
  •   



Logout Mark Read Team Forum Stats Members Help
[Release] Backup (formerly XBMC Backup)10
This forum uses Lukasz Tkacz MyBB addons.