auto-mount dvd/cd
#1
Hi,

I have just upgraded to XBMCbuntu Eden. I have problems with the DVD/CDs not auto mounting, nothing happens when i put in a disc. If i reboot the machine with the CD/DVD inside it will mount and display in the menu. How can i solve this?
Reply
#2
Hi, I have the same problem. Can you check if your findings are similar to mine?

Boot with Audio-CD or Movie DVD inside: DVD gets mounted in /media/CDROM (or Volumename)
xbmc has the "Play DVD" menue item, you can play the disc, eject it.

Boot without disk, insert after boot:
Nothing gets mounted, sometimes the "Play DVD" menu appears, DVD can be played.
This is not really reproducible, sometimes yes, sometimes not.

Boot without disk, exit XBMC and start a desktop session. Insert disk: Everything fine. Disk gest mounted, and a file manager appears. This works with data disks, movie DVDs, and audio CDs.

Ciao
Tom
Reply
#3
I too have this problem and have the same symptoms as thd042.

Edit: Using a fresh install of XBMCbuntu 11.0.
Reply
#4
Looks like we found a bug.

Does anyone have a system where automount works? We are talking in my case about
xbmc 2:11.0~git20120321.14feb09-0ubuntu1~ppa1~oneiric
and
Linux xbmc 3.0.0-17-generic #30-Ubuntu SMP Thu Mar 8 17:34:21 UTC 2012 i686 i686 i386 GNU/Linux
Reply
#5
I have done some testing and mounting appears to work for usb media(SD, and Thumb drive). So, this problem appears to be effecting the optical drive only.

Also, dmesg gives no new output after an optical disk is inserted.
Reply
#6
I tried all of the scenarios but added one more. All of the ones mentioned by thd042 gives me the same output, although my dvd never mounts.

I logged into an XbmcBuntu session and in there everything mounts ok. I then logged out and entered my password for a new session of Xbmc and now the DVD mounts every time. I thought this might be a permissions issue so I changed owner of /media to my user xbmc and gave full permissions on that folder but it's not working anyway.




Reply
#7
@jawsdas: Yeah right, USB-Sticks and alike work. That seems to rule out dbus errors, but makes it even more puzzling.
Reply
#8
Hi all, has anyone been able to fix this little problem? (obviously i've ran into the same issue).
Reply
#9
I just tried a fresh install of Ubuntu 12.04 with Eden to see if that would solve the problem, but i doesn't. The same problem occurs. I have no idea how to solve this and frankly the system is just useless without being able to mount the cd/dvd drive.

I think i will have to go back to Dharma, if i can find it somewhere.

My settup:
Asrock ion 3d 125d
Reply
#10
Yes, what I would like to see confirmed from someone is, if it works on any system and robbanl and I do something stupid, or if this is a bug.
Reply
#11
Hello,

I have been using XBMC for a while now and I really like it (thanks guys for developing it!)

However, I encountered a similar problem. I'm running XBMC 11 on Ubuntu 12.04 on a 64bit x86 machine. Everything runs well, except I don't see a menu allowing for DVD Playback. I never tried it before today, where I now mounted a DVD drive via iSCSI. It appears as /dev/sdb and is accessible without problems from the operating system. Also, it can be mounted and I was able to playback a vob file through the file browser.

So how is the XBMC way to allow DVD playback? Should there be a menu? Should it playback automatically when the device becomes available? Do I have to specify the block device somewhere?

Kind Regards,
David
Hardware: ZOTAC ZBOX ID41, 4GB RAM, 1TB local 2,5" HDD, DVD Playback via iSCSI
Software: Archlinux with XBMC from repository
TV Set: LG 50PV350, Onkyo A-5VL + Nubert nuVero10
Reply
#12
I would classify this as a bug, installed it on a ION chipset HTPC and a laptop. In both cases the mount doesn't work. When I reboot (both systems) with the DVD in place sometimes I can play it, sometimes it just shows the system partition.
Reply
#13
OK, clumsy work-around:
Install "Advanced Launcher" from the xbmc Repository.
Shell into your box and do

mkdir bin
cd bin
echo 'udisks --mount /dev/sr0' > mntcd
echo 'udisks --unmount /dev/sr0' > umntcd
chmod 755 mntcd umntcd

The name of your optical disk device may vary. /dev/scd0 exists as symlink on my system.

Create a new launcher that starts the mntcd-script above, and one that creates the unmnt-script.
Launch one after inserting the disk, the other before ejecting. Ugly, probably unreliable, but what can you do? Not yet fully tested, so you have been warned :-)
Reply
#14
Ok i think i found a solution by editing the mount policy, i got the cd/dvd to automount. Try to see if it works for you too.

From terminal:

#create new group storage and add your user to it
sudo addgroup storage
sudo useradd -G storage <username here>

#create a file in /etc/polkit-1/localauthority/50-local.d named mount.pkla
sudo touch /etc/polkit-1/localauthority/50-local.d/mount.pkla

#Open the file with editor of choice
sudo nano /etc/polkit-1/localauthority/50-local.d/mount.pkla

#copy and paste the following in the file
[Mount system internal media for group storage]
Identity=unix-groupConfusedtorage
Action=org.freedesktop.udisks.filesystem-*
ResultAny=yes
ResultInactive=yes
ResultActive=yes


If i understand correctly the policykit should accept the changes as soon as you save the file but i had to do a reboot for it to work.





Reply
#15
Using the udisks command instead of the usual mount command I got XBMC to display a popup indicating that a media has been mounted.

However, how to I get XBMC to play back the DVD, short of going to the files menu and clicking on the VOBs?
Hardware: ZOTAC ZBOX ID41, 4GB RAM, 1TB local 2,5" HDD, DVD Playback via iSCSI
Software: Archlinux with XBMC from repository
TV Set: LG 50PV350, Onkyo A-5VL + Nubert nuVero10
Reply
 
Thread Rating:
  • 3 Vote(s) - 4.33 Average



Logout Mark Read Team Forum Stats Members Help
auto-mount dvd/cd4.333