•   
  • 1
  • 147
  • 148
  • 149(current)
  • 150
  • 151
  •   
Release Universal Movie Scraper
Gotcha. That is too bad. Thanks for the explanation.
Reply
I noticed that since a while, the scraper doesn't return genres for some of my non-US films. For all American / English language films the genres turn out OK.

For example: https://www.imdb.com/title/tt9911196
This is a Dutch movie. On the IMDb web page it shows Comedy and Drama as genres. When Kodi scrapes the movie, I get no genres. (I have set the scraper to use IMDb for genres.)

Here is a log: https://pastebin.com/7jisJbzy
I refreshed the movie info at 11:13.40

Is this a bug? Did I make a mistake in the setup?
Reply
(2022-03-20, 12:28)willemd Wrote: Is this a bug? Did I make a mistake in the setup?

A bug, probably due to a change on IMDb. I was trying to address this in metadata.common.imdb.com v3.2.5. 
Please test once it gets available in the repo.
Reply
(2022-03-21, 09:56)olympia Wrote:
(2022-03-20, 12:28)willemd Wrote: Is this a bug? Did I make a mistake in the setup?

A bug, probably due to a change on IMDb. I was trying to address this in metadata.common.imdb.com v3.2.5. 
Please test once it gets available in the repo.

Thanks, that fixed it!
Reply
Hi olympia,

Thanks for keeping this scraper up to date.
It seems that, since last Saturday, it no longer scrapes the plot from IMDB.
Can you please confirm and (even better) fix this? Or is it something I can fix myself through the settings?

Thanks!
Reply
Hello.
For the past few days the Universal Movie Scraper no longer enters the Plot Summary/Description for any movie added or refreshed. The Plot Outline is ok.

Windows 10 pro x64
Kodi 19.4.0
TMDB v 5.2.6
TMDB python v 1.6.2+matrix.1 (system installed python 3.10.1)
Universal v 5.5.8
debug log: mamusazebi.kodi (paste)

Thank you for any help.
Reply
Possible fix to metadata.common.imdb.com/imdb.xml
I coudn't figure out how to show & lt; and & gt; without a space. There shouldn't be a spaces, but this post kept chainging them to < and > which would be incorrect.

<ParseIMDBPlot dest="5">
        <RegExp input="$$2" output="<details>\1</details>" dest="5">
            <RegExp input="$$1" output="<plot>\1</plot>" dest="2">
                <expression fixchars="1" trim="1">storyline-plot-summary&quot;& gt;& lt;div class=&quot;ipc-html-content ipc-html-content--base&quot;& gt;& lt;div class=&quot;ipc-html-content-inner-div&quot;& gt;(.*)?& lt;span style=</expression>
            </RegExp>
            <RegExp input="$$1" output="<plot>\1</plot>" dest="2">
                <expression fixchars="1" trim="1"><h2>Storyline</h2>\s+<div\sclass=&quot;inline\scanwrap&quot;>\s+<p>\s+<span>(.*?)</span></expression>
            </RegExp>
            <expression noclean="1" />
        </RegExp>
    </ParseIMDBPlot>
Reply
Expression fix for the previous possible fix. Includes the case where the author of the plot may or may not be present.

<expression fixchars="1" trim="1">storyline-plot-summary&quot;&gt;&lt;div class=&quot;ipc-html-content ipc-html-content--base&quot;&gt;&lt;div class=&quot;ipc-html-content-inner-div&quot;&gt;(.*?)(?:&lt;span style=.*?)?&lt;/div&gt;&lt;/div&gt;&lt;div class=&quot;ipc-overflowText-overlay&quot;</expression>
Reply
Is a fix for this current issue going to be pushed through?
Reply
(2022-04-29, 03:19)Sunflux Wrote: Is a fix for this current issue going to be pushed through?
You need to wait for @olympia to look at the issue. He hasn't been around for a few days.

Why not test the change kindly provided by @At2010 and confirm that it works?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
Okay, okay, putting me to work here. It seems to work (both with and without plot author names), but to match prior formatting I would probably do the following:

<expression fixchars="1" trim="1">storyline-plot-summary&quot;&gt;&lt;div\sclass=&quot;ipc-html-content\sipc-html-content--base&quot;&gt;&lt;div\sclass=&quot;ipc-html-content-inner-div&quot;&gt;(.*?)(?:&lt;span.*?)?&lt;/div&gt;&lt;/div&gt;&lt;div\sclass=&quot;ipc-overflowText-overlay&quot;</expression>
Reply
Many thanks guys for looking and even fixing the issue. Makes my life much easier Smile
Sunflux suggested fix has been pushed to the repo at v3.2.6
Reply
(2022-04-29, 13:32)olympia Wrote: Many thanks guys for looking and even fixing the issue. Makes my life much easier Smile
Sunflux suggested fix has been pushed to the repo at v3.2.6

Not sure if it's just me but I'm still not getting the Plot, using the updated IMDB Scraper Library 3.2.6.
Tried with new movies and refreshing the existing.
Reply
The 3.2.6 did not work for me either.  I edited the same expression but truncated some off the end and it works ok now.

<expression fixchars="1" trim="1">storyline-plot-summary&quot;&gt;&lt;div\sclass=&quot;ipc-html-content\sipc-html-content--base&quot;&gt;&lt;div\sclass=&quot;ipc-html-content-inner-div&quot;&gt;(.*?)(?:&lt;span.*?)?&lt;/div&gt;&lt;/div&gt;&lt;div</expression>
Reply
Thanks, At2010,
Your fix works for me as well.
Refreshing existing movies doesn't show the plot, but removing them from the library and rescraping does.
Reply
  •   
  • 1
  • 147
  • 148
  • 149(current)
  • 150
  • 151
  •   



Logout Mark Read Team Forum Stats Members Help
Universal Movie Scraper9
This forum uses Lukasz Tkacz MyBB addons.