Linux - Slow/Un-useable after upgrade to 12.04
Hi All,

I have upgraded from Ubuntu 11.10 to 12.04, and since the upgrade XBMC has stopped working. It loads up but the interface is slow and the mouse and menu reactions are delayed and jerky. It's so un-unseable I cannot navigate the menus properly to use it at all!

I am using unity 2d interface, so there shouldnt be any desktop effects. Can anyone help me out with this one? Otherwise I'll have to go back to 11.10 Sad
install graphical drivers? disable composite?
Hi all
I have similar problem after upgrading Xubuntu 11.10 to 12.04 today.
The difference is that I can not see interface at all, just black screen.
Nvidia drivers are installed, system could be accessed via SSH or X-server could be rebooted via ctrl+alt+F11

P.S. why in the world I decide to upgrade? Confused
Quote:Nvidia drivers are installed
Are installed? I assume if you upgrade you need to re-install. Is this what you have done?
Thanks for your reply Vikjon0.

The graphic drivers should already be installed anyway. XBMC was working fine until I decided to upgrade. What do you mean when you say disable composite? The computer is connected to my TV via a DVI out from the video card.

I have two theories so far, either its the desktop effects causing the problem (even though I am using unity 2d) or its the propietry drivers.

I have already un-installed and re-installed xbmc and no changes there, I'm considering a fresh install, but I'm hoping one of the wise guru's on the forums can suggest a better solution Smile

Edit: Also I've noticed that the dodge effect is still working in the unity dock even though it should of been removed in 12.04. Probably not relevant but thought id mention it for what it worth! seems odd.
I too have this slowness happening, luckily on only 1 of my 3 boxes. To clarify, there is at least 10 seconds pause between navigating each keypress. It happens with the keyboard as well as the remote, and it happens this slowly in VNC also. I run MythTV on this box, and the menus there present perfectly. The graphics card is a Geforce 6150 integrated card.

I have uninstalled/reinstalled xbmc, disabled composite in compiz, launched unity 2D, launched as XBMC only, tried XFCE, and disabled VDPAU. Nothing seems to help.

I did notice that in 12.04, the nvidia driver is 295 whereas I was on 280 in 11.10. I did uninstall the nvidia drivers (forcing it to use the open source variant) and the menus were much quicker, although still not up to par. Video with the opensource variant was useless. I suspect it has something to do with the 295 drivers not working right with this particular video card.

I tried to load an earlier Nvidia driver, but Ubuntu doesn't seem to want me to (synaptic flags earlier versions as broken and will not let me install them.) I feel like if I could figure out how to backport Nvidia to 280, all would be well.
After i've upgraded when i try to start something within XBMC i get the EDEN 11 logo and then it restarts xbmc.
at the moment it cannot play anything forced to reinstall
Well, I had this experience after doing upgrade to 11.04, and learned that its NOT a good idea to do a system upgrade before it has been 'cleared' in here before. Back then I had to go back to 10.10 and since it was working flawlessly (and it was my HTPC build anyways, so the main purpouse is XBMC nothing else) decided to stick with it untill I had to upgrade (if I really had to).

Some days ago I got a msg from Updates that said that 10.10 will no longer be supported (which was expected) but as it keeps working and works flawlessly for XBMC HTPC usage I dont think I really need to change.

But, I was wondering if 12.04 was supported already then I would try and move with a different hard drive, and basically you guys have reinforced my idea of staying with the prior to current version (should I decide to get into a more recent Ubuntu).

I suggest that, go back to 11.10, and wait untill 12.04 has been given the OK for XBMC.

BTW, for the powers that be, the wiki still lists Ubuntu versions that are already WAAAAAAY out of support cycles (perhaps only 8.04 has because of being the LTS), and it would be a logical place for Ubuntu users to see which versions are OK for XBMC.
Acer something AMD A8-3800K with Trinity Radeon HD6650 (512MB), 10GB DDR3, Ubuntu 15.04, NO KODI HELP Audio: Working great Analog 5.1 (with Infinity Reference Sub and Center).
(2012-04-30, 05:42)elpirata Wrote: I suggest that, go back to 11.10, and wait untill 12.04 has been given the OK for XBMC.

I'd just like to point out that I have virtually two identical HTPC boxes running XBMC on 12.04 (acer L100 and acer L320), the L320 works fine and, the one with L100 has the issue I am currently having. So it must have nothing to do with which version your running!

The main difference between the two is the graphics cards. So I firmly believe the problem must lie with the drivers, especially since nobody has had any resolve by turning off desktop effects.

I have decided to do a CLEAN install of 12.04 64bit and see if that gives me the resolution I'm after. I'll keep this post updated
The problem seems to be in the new Nvidia driver which does not work correctly. Just google for something like "ubuntu 12.04 nvidia problem". So you can try previous version of the driver, or just rollback to ubunut 11.10 as I did Smile
Thanks mgx259, can you tell me how I would roll back the installation to 11.10? I didn't think you could roll back the upgrade.

I'll take a look at google about the nvidia problem, there's bound to be someone with the same problem.

EDIT: This link proved insightful for me
There is not roll back of the upgrade on my knowledge, sorry for wrong phrasing. I just install completely new Xubuntu 11.10 configure it from the scratch (forgot to backup configs Blush ) and put XBMC on top in about 3 hours.

I wanted to try and revert back to drivers that work for my graphics card Nvidia GeForce 6150 LE

I have downloaded from the nvidia website, made it executable as a program. Gone into terminal mode Ctrl+F1

stopped xserver
sudo service light dm stop

removed current driver
sudo apt-get --purge remove nvidia-*

became root
sudo -s

then ran downloaded driver
cd /home/user/downloads/

unfortunately the installer gives me an error message saying that its not compatible with Linux Kernel 2.4 so I've had to restore the original for now
sudo apt-get install nvidia-current

Which brings us back to the begging. Can anyone please point out which driver I can download which will be compatible with my graphics card and Ubuntu 12.04 64bit. I'd rather not have to do a fresh install!

I did manage to install version 295.33, XBMC menus did get quicker but only marginally. So although it didnt solve my problem I thought it be worth noting just incase :-)
Why do I bother? For anyone who cares I resorted to re-installing 11.10

Another weekend of my life wasted, case solved Sad
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Slow/Un-useable after upgrade to 12.0400