Linux -  Bug: XBMC logs me off [gnome3, ubuntu]

The moment I open XBMC using Gnome3 in Ubuntu it logs me off immediately. I manage to see the "XBMC V11.0 Eden" screen, but next up is the system login screen.

In Unity I can start up XBMC without problems.

Using the latest versions of Gnome 3 and Precise Pangolin.

Can you guys look into the issue?

You will need to provide more information:
Ok, here we go.

XBMC Version: 11.0, Git unknown, compiled April 24

Ubuntu Precise Pangolin. Terminal output of lsb_release -a:
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

uyname -a output:
Linux xXx 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Installed using the official sudo apt-get update && sudo apt-get install xbmc

SVN: I can't find it

Being logged into Gnome3, try to open XBMC will get you instantly logged off

crash log:

Reproducing it logs me out. Not sure how I can document this using terminal

I think it compiles beautifully. As I stated before, ithin Unity I can use it without problems (well, alt-f4 to close does not work but that may be due to something in my system).
Can you turn on Debugging in XBMC, make it crash and then repost xbmc.log

You may want to try disabling any compositing manager like compiz or mutter if possible
I tried replacing compiz with metacity but the pc would not reposnd very well after that, necessitating an old fashioned alt-sysrq-b.

I crashed it three more times total. Here follow all the logs. After turning on the debugger, it gave me an Xorg error as well in normal Unity, up until that moment I haven't had a singe error in Unity.
The only thing I see of interest is this (grasping here):

18:30:51 T:139900129486592   DEBUG: Thread XBMC Peripherals 139900129486592 terminating

And then XBMC starts shutting down.

What USB devices do you have plugged in?
A USB Hum, to which I have MS Keyboard, Razer Deathadder 3500, 8GB Kingston stick, and that's it really.
(2012-05-09, 01:16)d123 Wrote: A USB Hum, to which I have MS Keyboard, Razer Deathadder 3500, 8GB Kingston stick, and that's it really.
Try unplugging what you can. I may be way off but it's worth a try. Maybe just leave the keyboard plugged in.

BTW I may be way off in left field.
Hmm, it's still strange., The same exact config works like a charm using Unity, just not Gnome3. But anyway, I borked my Unity by trying to install conky (so now when I boot into Unity I only get a mouse), so I'm thinking about reinstalling everything (should only take an hour or so).

I'll try again after I do if the same thing happens and will report on results.
I am able to reproduce this problem with XBMC 11.0 on Ubuntu 12.04 (Precise) with Gnome 3. I normally use Gnome 2 (Classic), so I never encountered this before. I can also confirm that this problem doesn't occur with Unity.

For me, the problem occurs consistently (under Gnome 3) if there is a DVD in the optical drive when I launch XBMC. Even if I remove the DVD, log-in again and then launch XBMC, it will crash again and return me to the log-in screen. If I reboot (without DVD), I can then launch XBMC successfully.

Here's my log.
Hello Guys,

I can account for the exact problems in here except the fact that the only thing plugged in are some earplugs. So nothing.

I got some differences though, first of all, I simply can't open XBMC, it logs me off immediatly.

I hope I can help with this, don't hesitate asking for further informations.

Debug informations :
Hi all,

This worked out for me and my girlfriend.

Had the same problem as You , this also fixes the Broken pipes at the shutdown

1. Boot into recovery mode
2. Repair broken packages
3. Hit the continue boot button
4. Log in to the desktop
5. Reboot
6. Log in normally
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Bug: XBMC logs me off [gnome3, ubuntu]00