Thread Rating:
  • 0 Vote(s) - 0 Average
"Script Error" on all addons after XBMC Preferances restored from backup
#1
Hi guys, I'm stuck.

I spent 3 days trying to figure out this one. I have 3 ATVs and I spent a lot of time to setup one of them perfect. I have them all installed the same way, fresh from Jailbreak.

I tried cloning XBMC preferances folder in order to clone all addons and setting to other two devices but I'm getting script error on every addon. They all say "Script failed" when I, for example, click on any movie name. Basically, every addon that access the Internet will fail. They are all there, I'm able to open all addons, but once I get to the point where I need to open movie I get script error.

I tried everything:
  • Rebooting
  • chown -R mobile:mobile /private/var/mobile/Library/Preferences/XBMC/
  • urlresolver, I haven't found it but I see that is not relevant anymore
  • tried "XBMC backup" plugin with same results

If I uninstall addon that gives me error, and install again from repository manually, everything works great but I don't want to go through all those plugins, that's not the point of backup.

Any idea what else I could try? Is it possible that I can't use backup from different device?

Here is the link to log file where just before closing XMBC I tried to open 3 movies from 1channel. All 3 failed.
Google Drive XBMC Log file

Thanks in advance!
Reply
#2
I am having the exact same problem. What was your resolve, Klikerko? Thank you.
Reply
#3
I haven't resolved this one. Apparently it is not possible to clone one device on another on 4.4.4 firmware. You can only clone XBMC backup on same device.
Reply



"Script Error" on all addons after XBMC Preferances restored from backup00