Touch screen in full screen mode

I'm testing a setup of XBMC on Ubuntu 12.04 running on an old ASUS EeeTop with touchscreen.

The resistive touch screen natively installed on the PC works well with ubuntu 12.04 without installing any driver.
When I launch XBMC in full screen mode the touch screen stop working.
It seems to be not calibrated.
Exiting XBMC the touch screen works again.

If I start XBMC in windowed mode (no full screen) the touch screen works.

Someone can help me to solve this issue?
Have you enabled the touchscreen support in the XBMC settings menus? I believe it's under the input area where you would add additional info about how your remote control works...
Hi boblablah,

yes, the touchscreen / mouse support is enabled.
If I disable this setting also the mouse stop working then it has to be enabled.

In the settings menu there is no other parameter related to the touchscreen.

What do you mean with remote control?
I'm not using any remote control right now, I only need to control XBMC (in full screen) with the builtin touchscreen of the eeeTop.

hi there - wondered if you have solved this as i am facing same...
I had setup XMBC in ArchLinux, see
Touch support is fine after calibrating and configuring it in Xorg.conf. But one-finger scrolling in the file or playlist browsers won't work. Any hint for that?
I saw someone did this in XBMC using Ubuntu but I cannot tell iyet f this is driver-, theme- or config-related.
Same Problem for me, too
Any solution ?
No idea ?
I cannot believe that nobody can answer this question ...
try to set in /etc/environment the following parameter and restart the windowmanager

+1 on a solution here. Nothing is working. Multitouch working great in Ubuntu 12.04, as soon as I start XBMC-Frodo, No more touchscreen!

Any other solutions out there?
Skin = ReTouched
Hey all... I was having this problem, and I found this:

It appears the problem is related to the non-system mouse cursor in xbmc... As per comment 1, I added the line "export SDL_MOUSE_RELATIVE=0" (without quotes) to my /usr/bin/xbmc script, and it worked like a charm... Hope it helps you guys. :-) Long live Tux!
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Touch screen in full screen mode00