Thread Rating:
  • 0 Vote(s) - 0 Average
No audio on ogg video files, but there is a weird part to it...
Now I have a few tv shows that are in ogg format, when I play them on xbmc 11 (windows), I get no audio, I have it set to output via optical or SPDIF and have it set to 5.1 surround. But here is the weird part, using that same system, running the video in VLC gets audio. Although thats not the weirdest part, I have an XBMC box on linux which outputs audio direct to the TV through HDMI (dharma) and the exact same video files output audio just fine. Its not like audio in XBMC cuts off, I can still hear navigation sounds. Its just not playing the audio in the video files, any idea on how to find out whats causing this?
What audio codec is being used in the ogg container?

There is a chance that the XBMC you are using was not compiled with the proper support, are you using the official release or a 3rd party build?

Also try setting the speaker configuration in XBMC from 5.1 to 2 and testing it.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
I tried changing the speaker configuration from 5.1 to 2 and it didn't help.

The XBMC I use is official release, but whats weird is it works fine on my xbmc linux box thats running Dharma (also official release)

The audio codec according to VLC is Vorbis Audio (vorb).

Edit: according to the ticket you posted (second one) sho it has something to do with Vorb and how XBMC handles it, but whats bugging me is why is it fine on Dharma on Linux but not fine on Windows with Eden.

Also, do you guys think that converting the video could fix this?
get us a sample, i'll take it upstream if there is a regression.
Here is a sample, well not really a sample its a complete episode since I don't know how to cut it.

Hope this helps.

No audio on ogg video files, but there is a weird part to it...00