Thread Rating:
  • 0 Vote(s) - 0 Average
Linux - [SOLVED] XBMCbuntu : no auto refresh rate
#1
Hello.

I have upgrade my HTPC : Atom N330 -> core i3 2120T and OpenELEC Beta 3 -> XBMCbuntu.

But I can't get auto refresh work when playing videos.

Here is my setup :

[Image: 1336715730-screenshot004.png]

VAAPI is for ATI/Intel and VDPAU is for NVidia, right ?

Mais quand je lance la vidéo, ma TV ne m'affiche pas le changement de résolution et avec la touche O lors de la lecture, cela se confirme :
But when I play videos, ma TV didn't show me the refresh rate switch (whith OpenELEC, TV's OSD display 1080p/24) and by pressing O touch during play, I get this informations :

[Image: 1336715511-screenshot002.png]

So my video FrameRate is 23.976 but my TV is still at 60 fps Sad

What is wrong with my setup ? Any ideas ?

Thanks.
Sorry for my english, but, you know, I'm French so ...

Main HTPC : Core i3 2120T running OpenELEC with Aeon Nox 5 and my mod
Secondary HTPC : Freebox Mini 4K running Android TV with Aeon Nox 5 and my mod
Reply
#2
It's like VAAPI is not installed by default with XBMCbuntu.
Command vainfo is unknown, so I installed it by apt-get but after I get libav errors Sad

So back to OpenELEC and everything is fine : VAAPI is OK, CPU are very low when playing HD videos.
Sorry for my english, but, you know, I'm French so ...

Main HTPC : Core i3 2120T running OpenELEC with Aeon Nox 5 and my mod
Secondary HTPC : Freebox Mini 4K running Android TV with Aeon Nox 5 and my mod
Reply
#3
Please turn on debug logging in XBMC and post a debug log on pastebin.

Most likely cause is that the 24 hertz refreshrate is not available.
Reply
#4
Too late, OpenELEC is back on my HTPC but I will give a seconde chance to XBMCbuntu.

Next week, I will receive my e-SATA <-> SATA cable so I will put a second HDD for XBMCbuntu.
And I will post log.

Thanks.
Sorry for my english, but, you know, I'm French so ...

Main HTPC : Core i3 2120T running OpenELEC with Aeon Nox 5 and my mod
Secondary HTPC : Freebox Mini 4K running Android TV with Aeon Nox 5 and my mod
Reply
#5
I had to install some additional software, X drivers with VAAPI support, IIRC, from a stock XBMCbuntu install to get hardware acceleration working.
Reply
#6
I was thinking that when installing XBMCbuntu, I will not have to install more stuff manually because XBMCbuntu setup have detected my materials and installed necessary softwares and drivers like VAAPI and so on.

I think I should have make a mixed with this subject to install needed parts : http://forum.xbmc.org/showthread.php?tid=86581
Sorry for my english, but, you know, I'm French so ...

Main HTPC : Core i3 2120T running OpenELEC with Aeon Nox 5 and my mod
Secondary HTPC : Freebox Mini 4K running Android TV with Aeon Nox 5 and my mod
Reply
#7
Check my post here. I started with a fresh XBMCBuntu install and just performed an apt-get for three things to get VAAPI working properly on my Sandy Bridge i3.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[SOLVED] XBMCbuntu : no auto refresh rate00