•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 65
  •   
Android Music Pump Kodi Remote
#61
I'll try to pull out a log next time a get a chance. I don't think the network is dropping because wouldn't that cause the media to stop playing all together?

Now that you mention it, last time something was playing, the time on the left showed the play time of the entire playlist, while the time on the right showed the play time on the track it was on.. perhaps that is related? That seems to be how I remember it, I'm at work now or else I'd double check for you.

At any rate, I'll try to get a log for you right from a fresh boot.. Thanks again!
Reply
#62
Hi there,

one (curious) thing:

If i play an album with the Official XBMC Remote there are not gaps between the racks. Important on continous tracks.
If i play the same album with Music Pump there are always gaps between the single tracks.

Could this be changed ?

Waldo
Reply
#63
(2012-07-19, 12:47)xbmcwaldo Wrote: Hi there,

one (curious) thing:

If i play an album with the Official XBMC Remote there are not gaps between the racks. Important on continous tracks.
If i play the same album with Music Pump there are always gaps between the single tracks.

Could this be changed ?

Waldo

It has to do with the playlist being managed on the android device and playing the next song once I receive a notification from xbmc that the song playback is complete. This results in a gap between tracks.

This could be fixed if I add more than one song to the play queue on xbmc so that it plays the next track directly. I had some issues when I tried this so you have to live with the gaps for the moments until I find a workaround.
Reply
#64
Hey just wanted to give a small update.. Was using your app earlier and it was working fine, but I switched to a different album to play, and noticed this in the "now playing' section

http://i.imgur.com/OuRK0.png

I tried a few different songs, and all of them would start about 8-12 seconds in (at least this is what your app was indicating, everything seemed to play fine when i selected it as far as xbmc goes) and noticed it failed to go to the next track while I was still using the phone.. I checked the now playing section and it basically had fallen out of sync/stopped indicating where along in the play time the track actually was.. The track had ended and the slider/time was stuck at about a minute in.. So perhaps this is an issue with the play times not syncing correctly between the two? Sorry no log yet, but figured this was relevant info.
Reply
#65
Hi there,

still having some issues around album art - I've now got XBMC (and the official app) showing, but not for Music Pump.
I'm still playing around, trying embedded vs 'folder.jpg' vs 'cover.jpg' vs [album name].jpg etc - I'll let you know how I get on.

Did find a bug though I think;
In the album view, if you have more than one album with the same name, it seems to bundle them together.
For example, I have two albums named 'MTV Unplugged'; one for 10,000 Maniacs and one for Bryan Adams (don't judge me Cool )
In album view, it shows MTV Unplugged: 10,000 Maniacs, but contains both sets of tracks. They're in very different folders, and displayed correctly in XBMC & official app.

Get the same thing with albums named 'the Hits','ultimate collection','greatest hits' etc

Edit:
think I worked out the album art - doesn't like me using [album name].jpg, or using png (xbmc rather than app I suspect).
Embedded or cover.jpg mostly works fine - few still not showing, but I'll work on them later!
Reply
#66
(2012-07-20, 06:38)skabyss Wrote: Hey just wanted to give a small update.. Was using your app earlier and it was working fine, but I switched to a different album to play, and noticed this in the "now playing' section

http://i.imgur.com/OuRK0.png

I tried a few different songs, and all of them would start about 8-12 seconds in (at least this is what your app was indicating, everything seemed to play fine when i selected it as far as xbmc goes) and noticed it failed to go to the next track while I was still using the phone.. I checked the now playing section and it basically had fallen out of sync/stopped indicating where along in the play time the track actually was.. The track had ended and the slider/time was stuck at about a minute in.. So perhaps this is an issue with the play times not syncing correctly between the two? Sorry no log yet, but figured this was relevant info.

It looks to me like the json-rpc interface on port 9090 is not responding/crashed since you don't get any notifications about playback status => invalid numbers are displayed. If restarting music pump does not help you may have to restart xbmc for it to work again properly.

Please note that you are using a xbmc development build which is not as stable as an official build.
Reply
#67
(2012-07-20, 07:37)aldredd Wrote: Hi there,

still having some issues around album art - I've now got XBMC (and the official app) showing, but not for Music Pump.
I'm still playing around, trying embedded vs 'folder.jpg' vs 'cover.jpg' vs [album name].jpg etc - I'll let you know how I get on.

Did find a bug though I think;
In the album view, if you have more than one album with the same name, it seems to bundle them together.
For example, I have two albums named 'MTV Unplugged'; one for 10,000 Maniacs and one for Bryan Adams (don't judge me Cool )
In album view, it shows MTV Unplugged: 10,000 Maniacs, but contains both sets of tracks. They're in very different folders, and displayed correctly in XBMC & official app.

Get the same thing with albums named 'the Hits','ultimate collection','greatest hits' etc

Edit:
think I worked out the album art - doesn't like me using [album name].jpg, or using png (xbmc rather than app I suspect).
Embedded or cover.jpg mostly works fine - few still not showing, but I'll work on them later!

Yes I know about the issue with albums. By the way there is a similar problem with albums that have more than one artist. It picks a random artist from that album and not the "album artist" as xbmc would do if it is specified.
This issues have to do with the codebase I took over from Music Pump DAAP Player where it was not possible to do this differently since the daap protocol did not provide something like an albumid or album artist.

I will see if I can fix this without having to change too much code.
Reply
#68
I encountered a small bug regarding downloading aac-files. They are saved with the file extention .mp3 instead of .m4a. Surprisingly, the files are being played back by the app, however no idtag info is available (no title, artist, cover etc.)

When streaming from xbmc, there is no problem. So its just the wrong file extention when saving to the sd-card.
Reply
#69
(2012-07-08, 11:14)Millencolin007 Wrote:
Quote:-Have a music album view sorted by album artist (currently only sorted by album name, the artist view on the other side is useless for me as I have many various artists albums, so many artists with only one track). XBMC itself can also do that.
This feature is already there. Under settings you can change the "Album sort order" by artist or by album

True, I did not see this setting. But it does not work correctly, two bugs:
1. It does use the artist of the last track on the album, not the album artist (like XBMC itself does). For example on a soundtrack album all tracks have different artists, but they all have the album artist "Various" (and only for that reason they are grouped to one album by any MP3 player).

2. I have many mixed CDs with a CUE file. XBMC uses the first PERFORMER entry, which is the artist of this CD, while you take the last track entry (like in the first situation).
Here is an example of such a CUE file:
Code:
PERFORMER "Sasha"
TITLE "Invol2ver"
FILE "Invol2ver.mp3" MP3
  TRACK 01 AUDIO
    TITLE "Intro"
    PERFORMER "Badger"
    INDEX 01 00:00:00
  TRACK 02 AUDIO
    TITLE "You Are The Worst Thing In The World (Invol2ver Remix)"
    PERFORMER "Telefon Tel Aviv"
    INDEX 01 01:57:29
  TRACK 03 AUDIO
    TITLE "Flesh (Invol2ver Remix)"
    PERFORMER "Rone"
    INDEX 01 09:06:17
  TRACK 04 AUDIO
    TITLE "Eclipse (Ray LaMontagne Vocal Version)"
    PERFORMER "Sasha Vs Ray LaMontagne"
    INDEX 01 14:13:02
  TRACK 05 AUDIO
    TITLE "Lowlife (Adam Parker Vocal Sample)"
    PERFORMER "Sasha Vs Adam Parker"
    INDEX 01 20:06:26
  TRACK 06 AUDIO
    TITLE "Midnight (Adam Parker Vocal Sample)"
    PERFORMER "Charlie May"
    INDEX 01 23:59:38
  TRACK 07 AUDIO
    TITLE "Arcadia (Invol2ver Remix)"
    PERFORMER "Apparat"
    INDEX 01 26:45:29
  TRACK 08 AUDIO
    TITLE "That You Might (Invol2ver Remix)"
    PERFORMER "Home Video"
    INDEX 01 33:25:74
  TRACK 09 AUDIO
    TITLE "Destroy Everything You Touch (Invol2ver Remix)"
    PERFORMER "Ladytron"
    INDEX 01 40:59:00
  TRACK 10 AUDIO
    TITLE "Couleurs (Invol2ver Remix)"
    PERFORMER "M83"
    INDEX 01 48:17:46
  TRACK 11 AUDIO
    TITLE "The Eraser (Invol2ver Remix)"
    PERFORMER "Thom Yorke"
    INDEX 01 53:32:45
  TRACK 12 AUDIO
    TITLE "3 Little Piggys"
    PERFORMER "Sasha"
    INDEX 01 57:03:03
  TRACK 13 AUDIO
    TITLE "Sometimes I Realise (Invol2ver Remix)"
    PERFORMER "Engineers"
    INDEX 01 64:14:67

This album should be listed under artist "Sasha", but currently it uses artist "Engineers".
Reply
#70
It's the same problem as I described two or three posts before. Currently I just take a random artist from an album and use it as artist for the whole album which probably is the last one I added to the database. Will try to change this in a future release
Reply
#71
Hey I love this app, it's looking great already, and it's nice to have a remote app that doesn't look horrible on my tablet. Although on the nexus 7 it doesn't use the tablet interface, which is annoying.

I also noticed that the TV show image never sows up on the now playing.

One more thing, you should include an option to stream a particular video to my android device. This would be much better than having to deal with upnp browsers...
Reply
#72
I will add an option to force the tablet layout in the settings and try to find out why the nexus 7 does not get recognized as tablet. Does it actually still force close on android 4.1?

Tv show album art is not yet implemented in the now playing screen that is why you never see it ;-)

Streaming movies to the android device is currently not possible because the files sent by the xbmc webserver are not seekeable and thus fail to play on almost all android videoplayer I tried. Guess we have to wait until xbmc provides a seekeable url like the one returned for upnp.
Reply
#73
Feature Request...

Can you add a browse function, or set alternative folders, so we can use the external AD which android does not index?

I love your app but it is a pita to use for local music... all other apps i have tried have the above feature but i would like to just use yours.

Thx
I'm not an expert but I play one at work.
Reply
#74
(2012-07-29, 22:44)Millencolin007 Wrote: I will add an option to force the tablet layout in the settings and try to find out why the nexus 7 does not get recognized as tablet.

I think the answer is that the Nexus 7 also uses the mobile frontend, so from a technical perspective it is no tablet but a large phone without phone functionality.

Reply
#75
(2012-07-31, 08:27)pigeldi Wrote:
(2012-07-29, 22:44)Millencolin007 Wrote: I will add an option to force the tablet layout in the settings and try to find out why the nexus 7 does not get recognized as tablet.

I think the answer is that the Nexus 7 also uses the mobile frontend, so from a technical perspective it is no tablet but a large phone without phone functionality.

Every phone/tablet can be mapped into a generalized screen size (small, normal, large and xlarge). Normally devices >= 7 inch use xlarge but the nexus 7 seems to use large (devices <= 7 inch). That is the reason it does not pick up the tablet layout by default.
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 65
  •   



Logout Mark Read Team Forum Stats Members Help
Music Pump Kodi Remote7
This forum uses Lukasz Tkacz MyBB addons.