Thread Rating:
  • 0 Vote(s) - 0 Average
Can't permanently disable music library mode
#1
I don't want to use library mode for my music but every time I go into the music button it switches to library mode. If i put it back to file mode it returns library mode when I back to the music button.

Any ideas`?
Reply
#2
Hello,

I can help you, then I have the self problem.

Its not the best way, but its a way Smile

In File-Mode, go to your Music Folder and in the Submenu mark it as Favorite.

Go into userdata and open the Favorites.xml, search the entry with your Music Folder. You need only this part.

Example (from me):

Code:
ActivateWindow(10501,"/multimedia/Musik/")

Now go into the skin.metropolis/720p/ folder and search the Includes_Home.xml or Includes_Home2.xml (The first file is for Original View and second file is for Layout Symbols). Open your File and search the entry:

Code:
                <item id="3">
                    <description>Music</description>
                    <label>$LOCALIZE[2]</label>
                    <icon>special://skin/extras/home2/icon_music.png</icon>
                    <onclick>ActivateWindow(MyMusicLibrary,Artists,return)</onclick>
                    <visible>!Skin.HasSetting(NoMusic)</visible>
                </item>

Now edit the <onclick> entry with the code from your favourites.xml entry:

Example from me:

Code:
<onclick>ActivateWindow(10501,&quot;/multimedia/Musik/&quot;)</onclick>

Now save your Includes_Home File and reboot XBMC.

Now you have Filemode!

I hope you understand my poor Englisch.

greetings from Germany!
Reply
#3
Thanks for the workaround! I will try it out.
Reply



Can't permanently disable music library mode00