IOError: (10, 'No child processes')
#1
Question 
I'm running XBMCUbuntu and I'm trying to develop a plugin that uses the deluge python api's. My problem is that I get IOError: (10, 'No child processes') as soon as I try to create a deluge client. The deluge client is using os.popen and I've managed to reproduce the same error with the below code snippet.

Code:
import os

f = os.popen('ls')
output = f.read()
rc = f.close()
print output


The script will run fine if invoked as a stand alone python script but when invoked inside xbmc I get the below error message.

Code:
23:40:27 T:3013217136    INFO: -->Python script returned the following error<--
23:40:27 T:3013217136   ERROR: Error Type: <type 'exceptions.IOError'>
23:40:27 T:3013217136   ERROR: Error Contents: (10, 'No child processes')
23:40:27 T:3013217136   ERROR: Traceback (most recent call last):
                                              File "/home/martin/.xbmc/addons/deluge.xbmc.client/default.py", line 5, in <module>
                                                rc = f.close()
                                            IOError: (10, 'No child processes')
23:40:27 T:3013217136    INFO: -->End of Python script error report<--

Since I'm calling a library that is doing a popen I can't just replace popen with something else. Is there any thing else I can do to avoid the above error when invoking the deluge python lib from within xbmc?
Reply
#2
Found a ticket for this, though it doesn't seem to get much love

http://trac.xbmc.org/ticket/12098
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
IOError: (10, 'No child processes')00