Thread Rating:
  • 0 Vote(s) - 0 Average
Installing drivers
I'm not very familiar with Linux, but I'm determined to get my XBMCbuntu installation to work the way I want it to. Basically what I need to do currently is install a driver for my ASUS USB-N53 wireless adapter.

I downloaded the Linux driver and put the files in /home/xbmc/driver. I then opened XTerm and did "make" within that folder. It proceeded to do a lot of stuff but there's still no WiFi access. Help?
What driver did you download? According to wikidevi your device has Ralink's rt3572 chip.

Please post output of:


I am also using a rt3572 device. But I used compat-wireless. The version I am using is 3.4-rc3-1.

If wikidevi is correct I can probably get it to work... It is very easy to compile and install compat-wireless.

If you want I can show you how to install it.

I downloaded this one - select Linux as the operating system and it'll show you the link.

I'm testing this on a work laptop and strangely enough, ifconfig does show a wlan1 interface with the MAC of the ASUS adapter. It doesn't show up as a usable Wireless device though.

lsusb posts "Bus 002 Device 002: ID 0b05:179d ASUSTek Computer, Inc." on the last line.

So it's definitely recognised, but I can't actually make use of it.

Linux is so strange to me. It really shouldn't be this difficult to install a driver for a well-known chipset.

EDIT: Tried to get compat wireless installed but it throws "access denied: error 126" on make install.
How did you compile it? Also which version are you using? Iam am using compat-wireless-3.4-rc3-1.

tar -xf compat-wireless-3.4-rc3-1.tar.bz2
cd compat-wireless-3.4-rc3-1
sudo make install

The above comands work for me.

Please copy and paste output in pastebin.

Edit: you may have to install build essential and linux before compiling the above.

sudo apt-get install build-essential linux-headers-generic

I extracted the archive contents on my Windows 7 computer using WinRAR and then moved a folder with the contents to the XBMC box. Tried running make install from that folder.

Did it your way now, which seems to be working - it's currently processing a huge list of chipsets. Is there anything I need to do afterwards?
The best thing to do after install drivers, is to turn off power management.

sudo nano /etc/pm/power.d/wireless

and add these lines:


/sbin/iwconfig wlan0 power off

Note change "wlan0" to whatever your wireless device is.

You sir are a genius. Did sudo make unload after installing compat and then did modprobe rt2800usb. Plugged the stick back in and it's fine!

Those power management lines - are they permanent or do I need to modify something like rc.config?

Great. It seems I celebrated a bit early though - when I try to connect to my phone's mobile hotspot, it just sits spinning for a while and then asks me for the WPA2 password again.

EDIT: It works if I don't use any security on the wireless at all. Soon as I select WPA2 though, it just won't connect.

EDIT2: Strike my last, it's working. Just a temporary hiccup I suppose. Thanks so much for your help!
How come I never see any of the guides mentioning drivers for the wifi? I just assumed it would work automatically.

I'm getting a bit worried about installing XBMC onto my 3700 later this week, it's sounding more complex the more I read.
hello i posted in the wrong forum... i can't delete this post so here goes.

Installing drivers00