Linux XBMCbuntu AMD HDMI Audio
#1
Hey,
I cant get HDMI audio to work with XBMCbuntu.
Iam using a A6-3500.

It is working with openelc (generic build) and Ubuntu 12.04 (Just had to install the Catalyst drivers).

So what can I do to get HDMI Audio with XBMCbuntu to work.
Reply
#2
Did you install the latest Catalyst drivers? Unmute all digital outputs? Did XBMCbuntu install a ".asoundrc" file in the XBMC user's home directory?
HTPC 1 - Zotac ZBOX ID80U | 4GB RAM | 64GB SSD | Openelec | Confluence
HTPC 2 - Zotac ZBOX ID41U | 4GB RAM | 60GB SSD | Openelec | Confluence
Server - unRAID Server | 3 x 2TB WD Green HDD, 1TB WD Black HDD (Cache) | Sabnzbd | CouchPotato | Sickbeard
Reply
#3
Ok so I am at a fresh install now.
What exactly should I do?

EDIT: Ok got it working still with I think Catalyst 11.X whats the best way to update to the latest driver.

I think Audio is working for Video only (no XBMC menu sounds or Chrome sounds like youtube)
Reply
#4
I don't have any AMD hardware, but these instructions should get you started:

In a terminal:
Code:
# see if the AMD driver loaded (should give you a driver date, which can be used to match with a catalyst version
$ dmesg | grep fglrx

# check if XBMCbuntu "sees" your HDMI audio device
$ aplay -l

# check to make sure that all digital outputs (PCM, S/PDIF, HDMI...) are unmuted (00 rather than (MM)
$ alsamixer

# check some basic analog output (CTRL+C quits)
$ speaker-test -D plug:hdmi

If the speaker test worked, then go into XBMC > Settings > System > Audio and choose "HDMI" if the PC is connected to a receiver. Choose "Analog" if the PC is connected directly to the TV. Then choose "hdmi (ALSA)" for the Audio Device (also for the Passthrough Audio Device if you picked "HDMI" at the top).

If it didn't work, post the output from the "aplay -l" command.

This page mentions that users with ATI cards may need to set the "radeon.audio=1" parameter either in GRUB or in the modprobe configuration.

EDIT: Good.

For desktop sound and menu sounds you will either need an ALSA configuration file or you can just configure pulse correctly. To configure pulse, try installing padevchooser. It should install the device chooser and a mixer (mixer should be all unmuted, device chooser should allow you to pick the HDMI output).
HTPC 1 - Zotac ZBOX ID80U | 4GB RAM | 64GB SSD | Openelec | Confluence
HTPC 2 - Zotac ZBOX ID41U | 4GB RAM | 60GB SSD | Openelec | Confluence
Server - unRAID Server | 3 x 2TB WD Green HDD, 1TB WD Black HDD (Cache) | Sabnzbd | CouchPotato | Sickbeard
Reply
#5
Hmm looks like padevchooser got removed from Ubuntu 11.10.
What should I use instead?
Reply
#6
Ah, try the utlities near the top of this page. pavucontrol and paprefs.
HTPC 1 - Zotac ZBOX ID80U | 4GB RAM | 64GB SSD | Openelec | Confluence
HTPC 2 - Zotac ZBOX ID41U | 4GB RAM | 60GB SSD | Openelec | Confluence
Server - unRAID Server | 3 x 2TB WD Green HDD, 1TB WD Black HDD (Cache) | Sabnzbd | CouchPotato | Sickbeard
Reply
#7
Thanks alot, I have sound now but with a strange echo but for now better than now sound Wink
Reply
#8

TeKo,
Do you still have sound issue? I setup a .asoundrc and set audio device to "alsa" and that seems to work with menu sound.
Reply
#9
i have sno sound coming out my system is an oks pentium d (dual core ) and i have a gt430 GPU.
I would love nothing better than to run XBMCbuntu. The problem is i am a complete noob I read the post but when you guys start talking code im completely lost. i have windows 7 running right now and evrything plays fine just the navigation is sluggish. Is there some reading i can do to slowly introduce me into this world of XBMCbuntu. Maybe XBMCbuntu for dummies and retards such as myself. I would like to mention i tried openelec with the same results no sound. As far as drivers and catylist unsure of how to even aproche it. thanks for your help
My HTPC AMD A8-3870K CPU/ SilverStone ML03B/ASRock MB-A75M /Seasonic SS-400ET/Corsair XMS3 4GB
Reply
#10
(2012-05-19, 20:53)Plaguester Wrote: I don't have any AMD hardware, but these instructions should get you started:

*snip*

Thanks, these instruction helped a lot!
Main pc: P3-333 daimond viper
Reply
#11
http://forum.xbmc.org/showthread.php?tid=134252
Reply



Logout Mark Read Team Forum Stats Members Help
XBMCbuntu AMD HDMI Audio0
This forum uses Lukasz Tkacz MyBB addons.