Thread Rating:
  • 0 Vote(s) - 0 Average
How to update AMD drivers on XBMCbuntu?
I have an Acer Revo RL70 (AMD E450 with Radeon HD 6320), with XBMCbuntu installed.

I have tried to follow many posts advising on how to upgrade to the latest AMD proprietary graphics drivers (Catalyst 12.4), but all seem to be subtly different and don't seem to work for XBMCbuntu. I either have trouble uninstalling the current fglrx stuff preventing the machine from rebooting or the installation routine claims that the previous fglrx is still installed.

Can anyone offer an idiot-proof guide of how to upgrade to the latest AMD proprietary Catalyst suite successfully when running XBMCbuntu?

I am used to windows and a complete linux novice, hence the need for idiot-proof instructions! Big Grin

I follow this tip :
Then, I was able to install the newest catalyst from xorg-edgers PPA.
Thanks for your reply, nonorider360. I'm sure I've tried those instructions previously and the uninstall failed. Maybe I did something wrong - I'll have another go and report back.
Did you guys find a definitive guide to updating the AMD drivers for RL70 ?

I'm getting some odd artefacts and tearing.. and wanted to update the drivers..

Or alternativley, how are you guys finding video playback on the RL70 ?
I've spent weeks trying to update Catalyst without success, even following the instructions above, or variants of them. Either the installer claims that fglrx still exists and is in use, or once I successfully remove it after a reboot, the machine refuses to restart, or through Putty I get errors installing the new drivers such as:

[Error] Kernel Module : Failed to build fglrx-8.961 with DKMS
[Error] Kernel Module : Removing fglrx-8.961 from DKMS

or DKMS part of installation failed. As I'm a complete linux novice I have no idea how to proceed.

On a more positive note, through tweaking other settings I've managed to get rid of all signs of artefacts and tearing, with the exception of one .mkv which I've been forced to ditch. From memory, in Catalyst I have anti tear turned on, GPU acceleration on and maintain aspect ratio. In xbmc I have enabled vsync. The main issue with xbmc was trying to sync the display to the framerate of the video. This caused major problems even though my display (Samsung 46C6530 and Samsung receiver) is perfectly capable of displaying all of the refresh rates. As long as I don't sync the framerate and stick to 60hz everythings plays ok. And these are full HD 1080p .mkv files and some m2ts files too. Obviously VAAPI is enabled. Let me know if you need a full rundown of my settings...

So, I still haven't worked out how to upgrade my version of catalyst in xbmcbuntu - if anyone can offer advice I'd be very grateful. Cheers.
sudo service lightdm stop
sudo apt-get remove --purge fglrx*
[ -d /etc/ati ] && sudo rm /etc/ati/*
mkdir ~/catalyst && cd ~/catalyst
sudo sh --buildandinstallpkg
sudo amdconfig --initial -f
sudo reboot

Note: this installs catalyst 12.6 beta, recommended over 12.4 because of a couple annoying bugs fixed.

alternatively follow this guide:
Hey guys,

thanks for the guide above wsnipex, that seems to have installed it, as i now have a "AMD Testing Use Only" in the lower corner!

Playback for me seems much smother.. altho i had been playing with other settings... so not sure which made it better.

Couple of questions,

1) Can the "testing use only" be removed? lol
2) I can't for the life of me get sound working on the RL70, the sounds in Ubuntu work, and the sounds on the menus in XBMC, but when playing a video its not having it. what did you guys have to set up to get sound working on the RL70...

Im using HDMI into a Onkyo SR508..

Cheers guys,

sorted the Sound!

i had to remove pulse audio...

Now, if i can remove the "AMD Testing Use Only", all is good!

@willuk2010: ah forgot about the signature Wink

try this:
sudo echo -n d164ca3e4bda6f7683e01cdf18df15c3:e94afc067af75f4fb2d12eeb79f225fae351fa0608f72e22cac029ed28ed21f7:b45dfe5f2db95f40b4817ae82db921a5b356ae0f79bf0a14b4d97aed2aea73a2b457ff0f2dbb5f40b3d87ae82aba27f1b205a90e79e30a12b1d879bb2aee73f4 > /etc/ati/signature

This is one single line.
wicked, ill give that a try when i get home.

are you a RL70 user wsnipex? or were you just able to help due to the reinstallation of the catalyst drivers?

Rusky, do you want to share all your settings mate,

I'm having a real issue with xbmc.bin idling at 100%, causing the fan to go wild, and the unit to get hot!

i have dirty regions on, but thats not helping...

does your RL70 idle at 100%?
if you are willing to try another xbmc version you can take a look here:
Mine wasn't idling at anywhere near 100% CPU...I haven't even got round to trying the dirty regions mod yet.

Are you running xbmcbuntu? The reason I ask is that when I go through wsnipex's instructions to update the driver, I still have problems. I'm using Putty to connect to the RL70, and have pasted the commands into the terminal window to make sure I get them right!

When I execute the line 'sudo sh --buildandinstallpkg' it aborts with the strange message:

This APT has Super Cow Powers.
Unable to install dpkg-dev. Please manually install and try again.

I have removed the --buildandinstallpkg and it then appears to work and I can proceed through the other steps, but following a reboot the machine hangs at the xbmc Media Centre splash screen. I can still connect to it using Putty, but don't know what to do from there...

I'm obviously doing something wrong...The RL70 is at the ubuntu desktop when I connect to it via Putty - is that correct? I've reinstalled xbmcbuntu twice and tried this with the same results by the way.

Can you and/or wsnipex offer any further advice? Sorry to be a pain...

WillUK2010, I'll post my settings when I can get in to the menu, I've got a pretty good idea what they were and have scribbled a few down but I'd like to confirm them first on a working system.

Cheers... (apologies for the slow response, Euro 2012 keeps getting in the way Smile )
im willing to give anything a go Wink

would you go for the git sources option?

Also, i don't need PVR support, does it matter?
pvr doesn't matter, you just disable it. As for which ppa to use: matter of taste, choose your poison =)
If you prefer a "officially marked stable" xbmc then go for Eden.
@Rusky: seems the driver didn't install correctly. can you post the output of:
dpkg -l | grep fglrx

and maybe pastebin a debug.log

Logout Mark Read Team Forum Stats Members Help
How to update AMD drivers on XBMCbuntu?00