FTP stream not working
#1
I have majority of my FTP streams working but some are not working. I know FTP is not the best for streaming but this is my only option as I want to access my media anywhere. here is the log if anyone can take a look.

http://pastebin.com/TWjK5tpY

I am using openelec
Reply
#2
Try this in a terminal (I'm assuming that Openelec has the ftp command):
Code:
$ ftp 192.168.1.1
# enter "test" as the username
# enter "test" as the password
# use "ls" and "cd" to list and change directories... e.g.:
ftp> ls
drwxr-xr-x    1 0        0            4584  Apr 27 09:40  books
drwxr-xr-x    1 0        0            4496  May 18 09:47  movies
drwxr-xr-x    1 0        0           18560  Apr 26 09:40  music
drwx------    1 0        0             552  May 14 09:40  share
drwxr-xr-x    1 0        0              80  May 21 02:51  tv

# note that the "share" folder is not accessible to this user (permissions on the left)
ftp> cd movies
ftp> cd Movie\ Title
ftp> get movie.mkv /dev/null

That should spit out some file transfer statistics at the end.
HTPC 1 - Zotac ZBOX ID80U | 4GB RAM | 64GB SSD | Openelec | Confluence
HTPC 2 - Zotac ZBOX ID41U | 4GB RAM | 60GB SSD | Openelec | Confluence
Server - unRAID Server | 3 x 2TB WD Green HDD, 1TB WD Black HDD (Cache) | Sabnzbd | CouchPotato | Sickbeard
Reply
#3
Thanks for the reply as this is getting fustrating

openelec uses curl for transfers, i manually started the transfer like you suggested and it all works fine...heres the log


root ~/.xbmc/userdata # curl http://ftp.192.168.1.11/Movies/40YOVirgi...u-720p.avi --user test:test -o /dev/null
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
1 3304M 1 52.3M 0 0 2556k 0 0:22:03 0:00:20 0:21:43 3120k

seems to be ok?

Any other suggestions?
Reply
#4
3120k is very slow for a local network. Mine is up around 51000k/s. Are you using a wireless network connection? Here's the result of a transfer on a gigabit network:

Code:
100 4469M  100 4469M    0     0  66.7M      0  0:01:06  0:01:06 --:--:-- 83.5M
HTPC 1 - Zotac ZBOX ID80U | 4GB RAM | 64GB SSD | Openelec | Confluence
HTPC 2 - Zotac ZBOX ID41U | 4GB RAM | 60GB SSD | Openelec | Confluence
Server - unRAID Server | 3 x 2TB WD Green HDD, 1TB WD Black HDD (Cache) | Sabnzbd | CouchPotato | Sickbeard
Reply
#5
Im not using LAN in my setup atm im using WAN I just put dummy info for the IP, port, and login details. I will be accessing this content on the go as I travel alot and do not have the room to carry around an external drive for my media.
Reply
#6
Then you may need to install something that can transcode and stream video on the fly. FTP was not designed as a streaming protocol and only works well on local networks. The only way it will work in your situation is to download the movie completely to /tmp and play it locally.
HTPC 1 - Zotac ZBOX ID80U | 4GB RAM | 64GB SSD | Openelec | Confluence
HTPC 2 - Zotac ZBOX ID41U | 4GB RAM | 60GB SSD | Openelec | Confluence
Server - unRAID Server | 3 x 2TB WD Green HDD, 1TB WD Black HDD (Cache) | Sabnzbd | CouchPotato | Sickbeard
Reply
#7
TVersity and subsonic can transcode and stream content remotely. They wont link to your XBMC library though.
Openelec on ASRock ION 330 / Kodi on Win 7 PC
Reply
#8
some movies work some dont..could it be a filename issue or directory issue? I want my movies to show in my library
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
FTP stream not working00
This forum uses Lukasz Tkacz MyBB addons.