19 Nov 2019 - TVDB are still in the process of fixing a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are still working to rectify the problems.

Updated to nightlies but no options for HD Audio
#16
Same errors, though this was added, looks to be just the recreation of the guisettings.xml

Code:
09:59:50 T:3017635600   ERROR: special://masterprofile/guisettings.xml, Line 0
                                            Failed to open file
09:59:50 T:3017635600   ERROR: Unable to load special://masterprofile/guisettings.xml, creating new special://masterprofile/guisettings.xml with default values
09:59:50 T:3017635600   ERROR: DeleteFile - cant delete file </home/xbmc/.xbmc/userdata/guisettings.xml>. trying lower case </home/xbmc/.xbmc/userdata/guisettings.xml>

Thanks for all the help.
Reply
#17
Nghtly is Nightly and not stable. Switch back to stable.
Reply
#18
(2012-05-22, 14:11)dandirk Wrote: Found the crash log

Code:
################ SYSTEM INFO ################
Date: Tue May 22 06:52:38 CDT 2012
XBMC Options:
Arch: i686
Kernel: Linux 3.0.0-19-generic-pae #33-Ubuntu SMP Thu Apr 19 20:59:10 UTC 2012
Release:
    Distributor ID:     Ubuntu
    Description:        Ubuntu 11.10 - XBMCbuntu
    Release:    11.10
    Codename:   oneiric
############## END SYSTEM INFO ##############

############### STACK TRACE #################
gdb not installed, can't get stack trace.
############# END STACK TRACE ###############

################# LOG FILE ##################

06:52:37 T:3018381072  NOTICE: -----------------------------------------------------------------------
06:52:37 T:3018381072  NOTICE: Starting XBMC (12.0-ALPHA2 Git:Unknown), Platform: Linux (Ubuntu 11.10 - XBMCbuntu, 3.0.0-19-generic-pae i686). Built on May 21 2012
06:52:37 T:3018381072  NOTICE: special://xbmc/ is mapped to: /usr/share/xbmc
06:52:37 T:3018381072  NOTICE: special://xbmcbin/ is mapped to: /usr/lib/xbmc
06:52:37 T:3018381072  NOTICE: special://masterprofile/ is mapped to: /home/xbmc/.xbmc/userdata
06:52:37 T:3018381072  NOTICE: special://home/ is mapped to: /home/xbmc/.xbmc
06:52:37 T:3018381072  NOTICE: special://temp/ is mapped to: /home/xbmc/.xbmc/temp
06:52:37 T:3018381072  NOTICE: The executable running is: /usr/lib/xbmc/xbmc.bin
06:52:37 T:3018381072  NOTICE: Local hostname: xbmc
06:52:37 T:3018381072  NOTICE: Log File is located: /home/xbmc/.xbmc/temp/xbmc.log
06:52:37 T:3018381072  NOTICE: -----------------------------------------------------------------------
06:52:37 T:3018381072  NOTICE: Setup SDL
06:52:38 T:3018381072  NOTICE: load settings...
06:52:38 T:3018381072  NOTICE: special://profile/ is mapped to: special://masterprofile/
06:52:38 T:3018381072  NOTICE: loading special://masterprofile/guisettings.xml
06:52:38 T:3018381072  NOTICE: Getting hardware information now...
06:52:38 T:3018381072  NOTICE: Checking resolution 12
06:52:38 T:3018381072  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
06:52:38 T:3018381072  NOTICE: Loaded playercorefactory configuration
06:52:38 T:3018381072  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
06:52:38 T:3018381072  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
06:52:38 T:3018381072  NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
06:52:38 T:3018381072  NOTICE: Loaded settings file from special://profile/advancedsettings.xml
06:52:38 T:3018381072  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <advancedsettings>
                                              <useddsfanart>true</useddsfanart>
                                              <cputempcommand>cputemp</cputempcommand>
                                              <gputempcommand>gputemp</gputempcommand>
                                              <samba>
                                                <clienttimeout>30</clienttimeout>
                                              </samba>
                                              <network>
                                                <disableipv6>true</disableipv6>
                                              </network>
                                            </advancedsettings>
06:52:38 T:3018381072  NOTICE: Getting hardware information now...
06:52:38 T:3018381072  NOTICE: Checking resolution 12
06:52:38 T:3018381072  NOTICE: Default DVD Player: dvdplayer
06:52:38 T:3018381072  NOTICE: Default Video Player: dvdplayer
06:52:38 T:3018381072  NOTICE: Default Audio Player: paplayer
06:52:38 T:3018381072  NOTICE: Disabled debug logging due to GUI setting. Level 0.
06:52:38 T:3018381072  NOTICE: Log level changed to 0
06:52:38 T:3018381072  NOTICE: Loading media sources from special://masterprofile/sources.xml
06:52:38 T:3018381072   ERROR: PulseAudio: Failed to connect context
06:52:38 T:3018381072   FATAL: CApplication::Create: Failed to start the AudioEngine


############### END LOG FILE ################

Looks like pulse and AE have issues... thought pulse was not supposed to be usedHuh

oh well nature of the nightly beast lol

I've tried the nathan-renniewaldock nightly ppa on three different machines now, and the binary crashes on every one of them with the same PulseAudio error and failure of AE. The first is my older laptop with an AMD/ATI chipset. I just tried a fresh install today on my i5 2500k with an nVidia 460GTX and it failed for the same reason. I'd like to know what people are doing to get this build to work.
Reply
#19
ALSA is better supported than PulseAudio right now. You'll probably get a bit more help via the AE - Linux thread in the development section.
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon  AVR-3808CI  - Denon DVD-5900 Universal Player  - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray  - X-Box 360  - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
Reply
#20
Not sure why the maintainer of that ppa doesn't disable pulse during compilation, but I compiled my own build with --disable-pulse, and it worked just fine.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Updated to nightlies but no options for HD Audio00