Thread Rating:
  • 0 Vote(s) - 0 Average
VDR and XBMC - How to install VNSI server
#16
I think it starts with decryption problems. vnsi plugin does not detect signal lost because there is still one steam delivering data, teletext. Audio and video stall but recover a couple of times. Then audio thread dies. This are the last messages of audio thread:

Code:
17:39:59 T:140108101285632   ERROR: ffmpeg[759B7700]: [ac3] frame CRC mismatch
17:39:59 T:140108101285632 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
17:39:59 T:140108101285632   DEBUG: CDVDAudio::Drain - adding 3480 bytes of silence, buffer size: 360, chunk size: 3840

After this there are no audio packets coming from demuxer:
Code:
17:40:05 T:140108382447360   DEBUG: set caching from pvr to done. audio (1) = 0. video (1) = 100

So maybe audio is hanging waiting for data.

I admit, none of those problems should happen, the question is where to look first. I see you use pulse audio. Quite a few functions related to pulse audio were implemented just before Eden release and were not tested much with pvr streams.

I can think of those options:

- fixing the problem which causing the stream cut off
- try ALSA sound which might be more stable than pa
- update to unstable pvr with new audio engine

EDIT: might be an vnsi problem, will look into this.



Reply
#17
davy39, do you have installed gdb and could you create a back trace when it has dead locked? That would help a lot.
Reply
#18
Thanks for the explainations.
Concerning pulse-audio, I've observed the same problem since ~january, so maybe it was before the function implementation you mentionned... However, I'll try with alsa tomorow.

I don't know gdb but I'm interested in and would really help to debug this issue...
Is there simple gdb commands for me to do before launching xbmc ?

How can I install unstable xbmc ? Is there a ppa or need I compile it ? What repository from ?

PS : Actually I run xbmc from P8 ppa on Ubuntu 12.04
Reply
#19
I think the best approach is to keep you current setup and we try to find the problem.

Install gdb, on Ubuntu this is apt-get install gdb
When it hangs, open a terminal via ssh and:
gdb attach $PID ($PID is the process is of xbmc.bin, find out with ps -ef)
on the gdb command prompt:
set logging on debug.txt (this writes output in debug.txt)
thread apply all bt (generates the back trace)

Reply
#20
I'm not sure to have well understood :
When shoud I have to generate the back trace, before or after xbmc crash ?
When I attach PID, xbmc is not responding anymore. Is it normal ?

Reply
#21
As soon as you attach gdb to xbmc.bin you pause execution. Hence attach when xbmc hangs, then generate the back trace.
Reply
#22
I tried to play a bit with that this afternoon but... XBMC doesn't crash anymore.
I could be because I've switched to alsa. If it's confirmed, you are amazingly efficient !
Reply
#23
Conclusion : no more bug with alsa instead of pulse-audio !
Now I can stop the streaming if there is no signal without crashing xbmc.
Thank you very much for your answer that resolve several months of problems.
Reply
#24
For information, Yavdr have released the vnsi plugin for vdr 1.7.27 in their testing & unstable ppa.
So the Ubuntu users don't need to build it anymore.
I've asked to e-tobi to do the same for debian.
Reply
#25
I would like to know if anyone works for vnsiserver plugin has done is correct .. because I make a mistake with pvrinput xvdr to see, and it would be nice to try VNSI server, and if it is still there to see - but I get the same ezechiel1917 mentioned.
web løsninger
Reply
#26
Could you please be more specific about your operating system, vdr version, and the way you've tryed to install it ?

If you're using Ubuntu Precise system, this way should work :

Code:
sudo add-apt-repository ppa:yavdr/testing-vdr
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install vdr vdr-plugin-vnsiserver


If you have previous release of Ubuntu, you can :

- compile it this way : http://forum.xbmc.org/showthread.php?tid...pid1120127

or

- use this repository being sure you've removed other yavdr sources (testing & unstable):
deb http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu natty main
Reply



VDR and XBMC - How to install VNSI server00