Thread Rating:
  • 0 Vote(s) - 0 Average
Slow performance on my Windows 7 Desktop but not my laptop
#1
Setup:
Linux Mint 12 KDE with XBMC and mysql - Gigabit lan card
Windows 7 desktop (Ulitimate) pointing to mysql for movies and music library - Gigabit lan card
Windows 7 laptop (Home Premium) pointing to mysql for movies and music library - Wireless (300 Mbps)

All the files are on the Linux machine and shared with SAMBA. The laptop access and displays just fine. When I start up XBMC on the desktop it takes about a minute to go from splash screen to home screen. When I click on Movies its another wait before anything happens. And finally when I exit another minute before it closes. I removed the advancedsettings.xml file and added a video via SAMBA path and it was fine. Replace the advancedsettings.xml file and back to slow/no performance.

Desktop specs:
AMD X2 4200+ dual core CPU
Asus A8N-SLI Premium Mobo
3 GB of DDR (400 MHz)
2 nvidia 7600 cards in SLI config

Router is a netgear N600 gigabit

Laptop is a HP dv-7

I was going to post my debug log but pastebin says its too big (~1.5 MB)

advancedsettings.xml (same on desktop and laptop):

Code:
<advancedsettings>
    <videodatabase>
        <type>mysql</type>
        <host>10.25.1.120</host>
        <port>3306</port>
        <user>xbmc</user>
        <pass>xbmc</pass>
    </videodatabase>

    <musicdatabase>
        <type>mysql</type>
        <host>10.25.1.120</host>
        <port>3306</port>
        <user>xbmc</user>
        <pass>xbmc</pass>
    </musicdatabase>
    
    <pathsubstitution>
        <substitute>
            <from>/home/johnny/Movies</from>
            <to>Z:\Movies</to>
            <from>/home/johnny/Music</from>
            <to>Z:\Music</to>
        </substitute>
    </pathsubstitution>
</advancedsettings>
Reply
#2
Can anyone help me with this?
Reply
#3
I had a similar problem with my bedroom HTPC. All the other PC's in the house were quite fast to access the MySQL database except that one.
I ended changing my skin from Cirrus Extended to Aeon Nox and now it's fine. I was expecting it to be slower running Aeon but not so.
Reply
#4
I'll try it, but both machines have the default install so I don't think it will help. There must be something with the connection to mySQL because playing movies is perfect, it's only starting XMBC, loading libraries and shutting down XBMC.
Reply
#5
I have one in the bedroom that i don't use very much. So it always has much new info to get, update, get fanart ect. And that also makes it slow on saving and shutting down. But if i use it more often or nothing has changed it's just as fast. Could that be it?
Image [RELEASE] Metroid
Image [RELEASE] IrcChat
Reply
#6
Probably not as he is using a shared database.
Reply
#7
Well I must apologize profusely for this thread. It turns out using the skip_name_resolve in the my.cnf fixed it and I didn't bother with that since one machine was working I didn't think that could possibly be the issue. Thanks all.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Slow performance on my Windows 7 Desktop but not my laptop00