• 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 58
xbmc minified as a server?
(2012-11-01, 17:02)Bootlegninja Wrote: just compiled and tried. no joy. But thank you none the less.

Code:
root@server:/opt/xbmc# ./xbmcVideoLibraryScan
Can't open display
XBMC Media Center 12.0-ALPHA7 Git:20121101-30ef98c
Copyright (C) 2005-2011 Team XBMC - http://www.xbmc.org

Starting Video Library Scan

Segmentation fault
root@server:/opt/xbmc#

I'm taking a break from this. been at it all morning compiling a fresh XBMC. Got errands to run.

Hmmm... That is really odd. Here is the output from mine (running against HEAD from this morning).

Code:
XBMC Media Center 12.0-ALPHA7 Git:20121101-0be99e9
Copyright (C) 2005-2011 Team XBMC - http://www.xbmc.org

Starting Video Library Scan

..................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Finished Video Library Scan...

Not quite sure what to suggest as a next step...
Reply
Question. Could you try installing that OpenMediaVault ISO I linked in a VM and try to install the headless xbmc? You may see something I am missing.
Reply
Just to chime in here, experienced the same as Bootlegninja (same issue with xbmc-xrandr as well). In a VM running a clean 12.04 install

Quote:xbmc@mable:/opt/xbmc$ ./xbmcVideoLibraryScan
Can't open display
XBMC Media Center 12.0-ALPHA7 Git:20121101-d24ccbd
Copyright © 2005-2011 Team XBMC - http://www.xbmc.org

Starting Video Library Scan

Segmentation fault (core dumped)
Reply
Found a bit of info on the segmentation fault.
http://wiki.xbmc.org/index.php?title=HOW...tu#Install

I've created the symbolic link but still no joy. But it was worth a shot.
Reply
(2012-11-02, 02:38)joelones Wrote: Just to chime in here, experienced the same as Bootlegninja (same issue with xbmc-xrandr as well). In a VM running a clean 12.04 install

Quote:xbmc@mable:/opt/xbmc$ ./xbmcVideoLibraryScan
Can't open display
XBMC Media Center 12.0-ALPHA7 Git:20121101-d24ccbd
Copyright © 2005-2011 Team XBMC - http://www.xbmc.org

Starting Video Library Scan

Segmentation fault (core dumped)

try : ldd xbmcVideoLibraryScan

Install all missing libraries

Reply
(2012-11-02, 09:25)Odon Wrote:
(2012-11-02, 02:38)joelones Wrote: Just to chime in here, experienced the same as Bootlegninja (same issue with xbmc-xrandr as well). In a VM running a clean 12.04 install

Quote:xbmc@mable:/opt/xbmc$ ./xbmcVideoLibraryScan
Can't open display
XBMC Media Center 12.0-ALPHA7 Git:20121101-d24ccbd
Copyright © 2005-2011 Team XBMC - http://www.xbmc.org

Starting Video Library Scan

Segmentation fault (core dumped)

try : ldd xbmcVideoLibraryScan

Install all missing libraries


I seem to have them all, none are listed as not found. http://pastebin.com/A0JdvbG5. Does one need xorg installed? I wouldn't think so
Reply
try adding

<backgroundupdate>true</backgroundupdate>

to the <videolibrary> section of advancedsettings.xml

I started having segfaults too not long ago and traced it back to things trying to happen with the gui if that setting wasn't there
Reply
a headless server is what most people want from this: a way to have access to the media library, to update it, to be able to send notifications to it via sickbeard, couchpotato, and so on. it's for people who have multiple xbmc clients around a home network, and want some way to centralise that library. by necessity, that involves a mysql back-end database. that necessitates the database library updates, and the functionality of searching, scraping, updating and otherwise manipulating the media library, as well as the code to access this functionality e.g. the json interface, the http communications layer, and so on. in actuality, that's a massive chunk of the functionality of xbmc - pretty much everything except the gui front-end.

it's probably also worth pointing out that frodo is currently in active development, so you're complaining about something not working when one of its dependencies is being actively worked on at the moment. to use your car analogy, they're still building the wiring loom, and you're complaining that you can't listen to the radio. i don't think that's a fair criticism.

having personally dealt with the developers over an extended period of time - particularly with reference to this actual piece of code - and having been involved with this particular server mode discussion from the beginning (given that i *started* it: http://forum.xbmc.org/showthread.php?tid=105449 and later http://forum.xbmc.org/showthread.php?tid=114612 with some actual code as an alternative solution) i won't stay silent in the face of that because they've been helpful, responsive, and actually given us what we've asked for at each and every step of the way, and even built something that wasn't in their priorities into the mainline code for us. all it took was some effort from a bunch of us to put together a working patch to give us what we wanted.

fyi, robotica's 'method' is the same as vajonam's eden patch (890) - which is a rebased version of my initial code (542) (including plenty of helpful fixes from Odon who i've noticed in this thread too - hi again!) that he pulled together and cleaned up while i was dealing with some stuff offline. for the record, that's got even more of the xbmc application gubbins in there than the library solution because it's nothing more than a couple of inline code switches to disable elements of the gui based on a startup parameter. as it stands, there are some elements of the gui still enabled in the eden-server codebase because the xbmc scanners were relying on the gui being present. it's nothing more than a very nasty hack to the eden codebase - albeit one that i'm proud of, as it was my first effort at contributing to xbmc, and many people out there have found it useful. what it is not is an elegant, viable long term solution to a headless xbmc server.

as an aside: my point in mentioning my two kids was not to lessen your own situation or denigrate your experiences, but to point out that we had something in common. i'm not getting into one-upmanship contests online because it's a pointless waste of time, but while i appreciate being a single dad is tough, you're not the only one with difficult personal circumstances.

anyways, i'm done. i've said all that i think needed to be said, and hopefully it's been at least a little bit helpful.
Reply
(2012-11-02, 05:31)Bootlegninja Wrote: Found a bit of info on the segmentation fault.
http://wiki.xbmc.org/index.php?title=HOW...tu#Install

I've created the symbolic link but still no joy. But it was worth a shot.

start it under gdb (gdb ./xbmcVideoLibraryScan)
r [enter]
once it crashes, enter bt full and paste it here
Reply
(2012-11-02, 17:56)frals Wrote:
(2012-11-02, 05:31)Bootlegninja Wrote: Found a bit of info on the segmentation fault.
http://wiki.xbmc.org/index.php?title=HOW...tu#Install

I've created the symbolic link but still no joy. But it was worth a shot.

start it under gdb (gdb ./xbmcVideoLibraryScan)
r [enter]
once it crashes, enter bt full and paste it here

I'm struggling with the same issue, posted the gdb output

http://pastebin.com/rPXpDQmS

Also tried adding the "<backgroundupdate>true</backgroundupdate>" in advancesettings.xml under /opt/xbmc/userdata
Reply
That backtrace shows

Code:
in VIDEO::CVideoInfoScanner::Process (this=0x808abe8) at VideoInfoScanner.cpp:89

and that line of code is in block

Code:
if (m_showDialog && !g_guiSettings.GetBool("videolibrary.backgroundupdate"))
      {
        CGUIDialogExtendedProgressBar* dialog =
          (CGUIDialogExtendedProgressBar*)g_windowManager.GetWindow(WINDOW_DIALOG_EXT_PROGRESS);
        m_handle = dialog->GetHandle(g_localizeStrings.Get(314));
      }

which means that backgroundupdate is still false. Have you put it within <videolibrary> ? eg
Code:
<advancedsettings>
  <videolibrary>
      <backgroundupdate>true</backgroundupdate>
  </videolibrary>
</advancedsettings>

If so then it may need to be added to the user version, which is ~/.xbmc/userdata/advancedsettings.xml
Reply
(2012-11-02, 18:22)Tom. Wrote: That backtrace shows

Code:
in VIDEO::CVideoInfoScanner::Process (this=0x808abe8) at VideoInfoScanner.cpp:89

and that line of code is in block

Code:
if (m_showDialog && !g_guiSettings.GetBool("videolibrary.backgroundupdate"))
      {
        CGUIDialogExtendedProgressBar* dialog =
          (CGUIDialogExtendedProgressBar*)g_windowManager.GetWindow(WINDOW_DIALOG_EXT_PROGRESS);
        m_handle = dialog->GetHandle(g_localizeStrings.Get(314));
      }

which means that backgroundupdate is still false. Have you put it within <videolibrary> ? eg
Code:
<advancedsettings>
  <videolibrary>
      <backgroundupdate>true</backgroundupdate>
  </videolibrary>
</advancedsettings>

If so then it may need to be added to the user version, which is ~/.xbmc/userdata/advancedsettings.xml

Ok thanks, a couple of errors (don't like the leaking memory output) but generally working, so adding it to ~/.xbmc did the trick, so I guess I'm missing a step, I didn't do the xbmc-server.cpp portion. Will recompile

Code:
Copyright (C) 2005-2011 Team XBMC - http://www.xbmc.org

Starting Video Library Scan

Can't open display

.................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Finished Video Library Scan...
no talloc stackframe around, leaking memory

Another thing, my clients are on MyVideos68 by running it's been upgraded MyVideos72, how did you manage this without upgrading clients to match the db schema with the <name></name> tage in the appropriate section?
Reply
You'll need to checkout the git revision that your clients are using and rebuild libxbmc.so
Eg, my clients are on git 28ca9a4 so for that you'd do

Code:
make clean
git checkout 28ca9a4
./bootstrap
./configure --enable-shared-lib
make


Then rebuild the scanner against that.

Reply
I'm currently recompiling since I deleted evrerything to start fresh. (side note, I completely forgot about the xbmc-server.cpp) I will report back once done and I dump the logs.
edit-
(2012-11-02, 19:31)Tom. Wrote: You'll need to checkout the git revision that your clients are using and rebuild libxbmc.so
Eg, my clients are on git 28ca9a4 so for that you'd do

Code:
make clean
git checkout 28ca9a4
./bootstrap
./configure --enable-shared-lib
make


Then rebuild the scanner against that.

may be a bit longer now since I need 68 like joelones
Reply
Oh yeh, you'll probably want to delete the newer database version so when you do update your clients, the database will be updated again with the latest info, like play counts etc
Reply
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 58

Logout Mark Read Team Forum Stats Members Help
xbmc minified as a server?9
This forum uses Lukasz Tkacz MyBB addons.