• 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 58
xbmc minified as a server?
(2012-11-03, 09:57)frals Wrote: Should be same error as here: http://forum.xbmc.org/showthread.php?tid...pid1228776 Smile

With this jacked up OS, I'm surprised I even get the same error at all instead of random ones.

(2012-11-03, 12:32)vicbitter Wrote: Have you tried the re-worked sample from post #164?

Yes.
Reply
Hey Vic, with your recent changes what would have to be commented out in order to keep it running as a server? I had thought just the "if videoisscanning..." down to the "..printf(.)"

Keeping your frame time code as it looked like a replacement for your sleep in the previous code but I think I'm wrong. (oh, and commenting the subsequent } following that) While it compiles without errors or warnings it scans my library then faults Smile

Any suggestions?

Thanks for your help!
Reply
(2012-11-04, 18:53)manxam Wrote: Hey Vic, with your recent changes what would have to be commented out in order to keep it running as a server? I had thought just the "if videoisscanning..." down to the "..printf(.)"

Keeping your frame time code as it looked like a replacement for your sleep in the previous code but I think I'm wrong. (oh, and commenting the subsequent } following that) While it compiles without errors or warnings it scans my library then faults Smile

Any suggestions?

Thanks for your help!

You would also need to comment out the following line...

Code:
g_application.StartVideoScan("");
Reply
Thanks. Looks as thought I did that as well. Odd. Wonder what the issue is. I'll keep tinkering Smile

Code:
// Start scanning the Video Library for changes...
  // g_application.StartVideoScan("");
  // Run xbmc
  while (!g_application.m_bStop)
  {
     //-----------------------------------------
    // Animate and render a frame
    //-----------------------------------------
    lastFrameTime = XbmcThreads::SystemClockMillis();
    g_application.Process();

    // Frame move the scene
    if (!g_application.m_bStop) g_application.FrameMove(true, false);
      // If scanning the Video Library has finished then ask XBMC to quit...
      //if (!g_application.IsVideoScanning())
      //{
      //   CApplicationMessenger::Get().Quit();
      //} else {
      // printf(".");

      frameTime = XbmcThreads::SystemClockMillis() - lastFrameTime;
      if(frameTime < noRenderFrameTime)
         Sleep(noRenderFrameTime - frameTime);
      // }

  } // while (!m_bStop)
Reply
Hey all, ive been following this thread for quite a while.

Thanks to the advancedsettings.xml fixup for backgroundupdate, i was finally able to get the scanner to work on my testbed. Thanks for all the pointers and code! Smile

The only other thing i haven't been able to clarify yet is where do i set the scrapers for source.xml directories? Or should i just import all the ~/.xbmc/ folders and settings
from a working client xbmc onto the server?

Cheers,
Reply
Personally as my laptop is a Mac I just ssh into the linux 'server', set the term to XTERM and run xbmc and it'll open the session using X11 on my OSX desktop. Allows easy configuration of the settings Smile If it weren't for that I'd just setup all the configuration as you like it on a Windows box then copy the userdata directory over to the server...

Reply
With some tinkering i got xbmc to run over ssh, and it already had all the scraper information saved for the sources. Maybe it is stored in part of the database?
Either way, its all working now. Stoked Smile
Thanks again everyone!
Reply
(2012-11-06, 01:38)booster72 Wrote: With some tinkering i got xbmc to run over ssh, and it already had all the scraper information saved for the sources. Maybe it is stored in part of the database?
Either way, its all working now. Stoked Smile
Thanks again everyone!

Thats exactly how it is :-D it's stored on the Db.. if i remember correctly in the path table.
Reply
Yeap, this is in DB so the easiest way is to us a XBMC client to configure sources.
Reply
Just a heads up...

One of the latest commits disables headless operation. (see here for further details).

I think that the fix should be relatively straight forward but I need to test and report back.
Reply
No difference - just don't call CreateGUI() - I'm sure you're already not calling that anyway, right?
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
Ha, I JUST ran into that problem and came here to figure out why I was having problems with the latest commit Smile

Thanks for the heads up vic!
Reply
(2012-11-07, 10:12)Odon Wrote: Yeap, this is in DB so the easiest way is to us a XBMC client to configure sources.

It would be great if webfrontends, like marashino, could be used to setup sources.
Reply
(2012-11-10, 04:19)Robotica Wrote:
(2012-11-07, 10:12)Odon Wrote: Yeap, this is in DB so the easiest way is to us a XBMC client to configure sources.

It would be great if webfrontends, like marashino, could be used to setup sources.

With the current JSON API this wouldn't be possible, But i would like to see a separated webserver version for all server specific tasks and make setup a breeze, It would also help with tweaking and minor changes. The only way to tackle this is issue though is by direct db manipulation, even then it seems xbmc has other methods in there source for scraper settings let alone polling available scrapers etc.
Reply
most setup can be done directly writing to files..
Reply
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 58

Logout Mark Read Team Forum Stats Members Help
xbmc minified as a server?9
This forum uses Lukasz Tkacz MyBB addons.