Thread Rating:
  • 0 Vote(s) - 0 Average
(XBMCubuntu) XBMCubuntu upgrade from nightly Builds
#1

Hi

I've done a lot of searching and I'm getting confused between updating XBMC for ubuntu and updating XBMCubuntu. I think I need to add a nightly build repositorie and then do the apt-get update apt-get upgrade.

I've added ppa:team-xbmc-svn/ppa but XBMC doesnt seem to update, What is the correct repositorie? Do I need to build it myself? What am I missing?

I would love to try the new HD audio with XBMCubuntu.

Thanks
Reply
#2
You can try the following:
Code:
sudo apt-add-repository ppa:nathan-renniewaldock/xbmc-nightly
sudo apt-get update
sudo apt-get install xbmc

I've tried this build on a couple of machines, and it's failed every time.

Your other option is to compile yourself. It's actually not that complicated.
Reply
#3
I tried that...It did do an upgrade but now I can't get past the login screen Sad Must have broke it. Should I just install Ubuntu fresh and then install XBMC on top or should I try to compile the XBMCbuntu version and save the setup I already haveHuh
Reply
#4
I can't really say. I only tried the repo on full Ubuntu systems where I had XBMC installed. I didn't try it on my HTPC with XBMCBuntu installed. If you're usingXBMCBuntu, you should be able to log into the window manager to a desktop. You can then look at the crashlog to see why XBMC is failing. My guess is that it's an pulse audio failure. If you want to reinstall, copy the /home/xbmc folder and all of its subdirectories. Perform a new install and then copy it back. All of your XBMC settings and addons should be there. If you made changes to other files e.g. /etc/fstab or /etc/network/interfaces, you'll need to copy them over too. Also, if you have any custom compiled drivers or software, that will need to be redone.
Reply
#5
With ppa:nathan-renniewaldock/xbmc-nightly I'm loosing sound over HDMI, using a GT210.
Can not select any option in the "Audio output device" and Passthrough" the only option available is HDA NVidia HDMI 0
Device 3,7,8 and 9 are un-muted

Everything else seems to be working OK.

Good part is that I discovered reading the forums on how to revert back to the stable build:

Code:
sudo apt-get install ppa-purge
sudo ppa-purge ppa:nathan-renniewaldock/xbmc-nightly
sudo apt-get update
sudo apt-get install xbmc

and then reboot.
Reply



(XBMCubuntu) XBMCubuntu upgrade from nightly Builds00