•   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 7
  •   
Linux [xbmcbuntu] [SOLVED] some buttons not working PHILIPS MCE USB IR Receiver-Spinel plus
#46
@Isulaiman

As said by Fermenta, your output is ok and you are using the good driver.

For your Home button to work (does it actually produces something ?) you have to adapt your config:

~/.xbmc/userdata/Lircmap.xml

And <start>KEY_MENU</start> instead of <display>KEY_MENU</display>

For pause to work, i don't know...

http://youresuchageek.blogspot.fr/2012/0...linux.html
go to step 13
Please support my Blog, XBMC and Linux related :-)
http://youresuchageek.blogspot.com
Reply
#47
Yeah I've followed your guide still with no luck. Could it have something to do with identifying it as Philips mce uSb ir receiver?

Cause once I enter that code In the remote stops working

I'm using the remote that came with my zotac zbox id80
Reply
#48
Without 10-evdev.conf the remote is recognized as a keyboard. That always works for some buttons but this not what you want. As already stated lirc works fine as you get the correct output from irw. Your problem is that XBMC does not see it.

Please post output of:
ls -la /dev/lircd

and your Lircmap.xml
Reply
#49
thanks for everyone'e helps.

ok so when i type is ls -la /dev/lircd i get:

lrwxrwxrwx 1 root root 19 2012-10-24 19:24 /dev/lircd -> /var/run/lirc/lircd

and my lircmap.xml file is:

<lircmap>
<remote device="zotac.conf">
<power>KEY_SLEEP</power>
<wake>KEY_WAKEUP</wake>
<record>KEY_RECORD</record>
<pause>KEY_PAUSE</pause>
<stop>KEY_STOP</stop>
<reverse>KEY_REWIND</reverse>
<play>KEY_PLAY</play>
<forward>KEY_FORWARD</forward>
<skipminus>KEY_LEFTSHIFT</skipminus>
<skipplus>KEY_RIGHTSHIFT</skipplus>
<back>KEY_BACK</back>
<info>KEY_INFO</info>
<start>KEY_MENU</start>
<up>KEY_UP</up>
<left>KEY_LEFT</left>
<right>KEY_RIGHT</right>
<down>KEY_DOWN</down>
<select>KEY_OK</select>
<volumeplus>KEY_VOLUMEUP</volumeplus>
<volumeminus>KEY_VOLUMEDOWN</volumeminus>
<mute>KEY_MUTE</mute>
<up>KEY_CHANNELUP</up>
<down>KEY_CHANNELDOWN</down>
<zero>KEY_0</zero>
<one>KEY_1</one>
<two>KEY_2</two>
<three>KEY_3</three>
<four>KEY_4</four>
<five>KEY_5</five>
<six>KEY_6</six>
<seven>KEY_7</seven>
<eight>KEY_8</eight>
<nine>KEY_9</nine>
<red>KEY_RED</red>
<green>KEY_GREEN</green>
<yellow>KEY_YELLOW</yellow>
<blue>KEY_BLUE</blue>
<star>KEY_NUMERIC_STAR</star>
<hash>KEY_NUMERIC_POUND</hash>
<subtitle>KEY_TEXT</subtitle>
<title>KEY_TITLE</title>
<clear>KEY_CLEAR</clear>
</remote>
</lircmap>
Reply
#50
Please enable debugging in advanced settings and post log.
Reply
#51
Sorry I'm pretty new to this. How do I do that?
Reply
#52
http://wiki.xbmc.org/index.php?title=Adv...oglevel.3E

Set log level to 1, then start XBMC. Post xbmc.log to xbmclogs.com
Reply
#53
Hey thanks for the reply
Here's my debug log

http://xbmclogs.com/show.php?id=11459
Reply
#54
Well, this is no debug log but enough to identify your problem:

Code:
23:35:33 T:3017332496   ERROR: special://profile/Lircmap.xml, Line 45
                                            Error reading end tag.

Reply
#55
btw, where did you put in the logging level in advanced settings I have asked you to do?

Code:
23:35:32 T:3017332496  NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
23:35:32 T:3017332496  NOTICE: Loaded settings file from special://profile/advancedsettings.xml
23:35:32 T:3017332496  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <advancedsettings>
                                              <useddsfanart>true</useddsfanart>
                                              <cputempcommand>cputemp</cputempcommand>
                                              <gputempcommand>gputemp</gputempcommand>
                                              <samba>
                                                <clienttimeout>30</clienttimeout>
                                              </samba>
                                              <network>
                                                <disableipv6>true</disableipv6>
                                              </network>
                                            </advancedsettings>
Reply
#56
I downloaded an add-on for xbmc that copies your debug log. Is that not a debug log? Sorry I assumed that's what it was?

So you think just fixing my Lircmap file should solve the issue?

Also any idea what this is:

23:35:33 T:3017332496   ERROR: GLX: Same window as before, refreshing context

Thanks
Reply
#57
Yeah. That worked! Thanks so much.
Now I have to figure out why xbmc doesn't shut down properly!
Reply
#58
I just installed a new zotac nano AD-10 but I't get the process for the remote control to work. I get the following error:

FernetMenta-lirc-c336b00/drivers/lirc_serial/lirc_serial.c:69:24: fatal error: asm/system.h: No such file or directory
compilation terminated.

Any ideas or help will be greatly appreciated.

Thanks guys.
Reply
#59
Hi,

Are you sure you installed requirements ?

sudo apt-get install automake dialog libtool

See my XBMC guide:
http://youresuchageek.blogspot.fr/2012/0...linux.html

Step Step 13: Configure Remote Control
Please support my Blog, XBMC and Linux related :-)
http://youresuchageek.blogspot.com
Reply
#60
I followed step by step. No joy.
Reply
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 7
  •   



Logout Mark Read Team Forum Stats Members Help
[xbmcbuntu] [SOLVED] some buttons not working PHILIPS MCE USB IR Receiver-Spinel plus0
This forum uses Lukasz Tkacz MyBB addons.