XBMC from GIT - DTS/DTS-HD/DTS-MA not works
#1
Hi,

I have XBMCbuntu 11.10 wich it was upgraded to 12.04. XBMC it downloaded from git and compiled with options:
./configure --prefix=/path/to/xbmc --disable-pulse. When I try play all movies which has DTS soundtrack it doesn't work. I can't hear anything.
Movie with DTS-HD/DTS-MA I hear only a noise. In XBMC menu I have a good sound.
Anybody had a similar problems?
Reply
#2
(2012-06-08, 01:01)forall Wrote: Hi,

I have XBMCbuntu 11.10 wich it was upgraded to 12.04. XBMC it downloaded from git and compiled with options:
./configure --prefix=/path/to/xbmc --disable-pulse. When I try play all movies which has DTS soundtrack it doesn't work. I can't hear anything.
Movie with DTS-HD/DTS-MA I hear only a noise. In XBMC menu I have a good sound.
Anybody had a similar problems?

It's really weird, because if movies has soundtrack in AC3 format works, if audio in DTS format I don't hear.

Somebody have any ideas?
Reply
#3
What are you using for audio output? Do you have passthrough enabled? What is you speaker configuration set to?

To be safe I'd disable passthrough and set speak configuration to 2.0
Reply
#4
Hi,

@drivesoslow - I checked configuration on 2.0 with disable passtrough and if I disable it I don't have any sound.
In first option I have set to only speaker from TV.
In second options when I connected onkyo receiver TX-SR608 DTS is working but DTS-HD or DTS-MA not, I hear a noise...
Now I want to have a DTS if I have only TV connected to my player.
Reply
#5
Hi,

I have problem with movies uses DTS soundtrack. My player is connect for TV with hdmi, so I have speaker in 2.0 mode.

Second problem is DTS-HD/DTS-MA if I connect my receiver SR-608 I hear only a badly noise..

Anyone have any ideas what's wrong?
Reply
#6
Hi,

audio settings have to be

audio output XBMC = HDMI output >>> do you have also connected your receiver via HDMI?
are the receiver (SR-608) settings for the input device is also setted to HDMI Audio?

speaker configuration XBMC = 5.1 or 7.1

device settings XBMC >>> have look through your selectable devices there...there should be one like
Audio HD HDMI

Reply
#7
@Bladerunner1962 - I have TV and receiver connect with different HDMI cable.

My tested scenario:

1) XBMC player -> HDMI -> TV - DTS it doesn't work, it's works only AC3

2) XBMC player -> HDMI -> SR-608 -> TV - DTS works, DTS-HD/DTS-MA doesn't work , I tested speaker configuration 5.1 and 7.1, in both options I hear only a noise

device settings XBMC in audio option I check HDMI device (TV Samsung or SR-608)

Reply
#8
(2012-06-10, 19:50)forall Wrote: @Bladerunner1962 - I have TV and receiver connect with different HDMI cable.

My tested scenario:

1) XBMC player -> HDMI -> TV - DTS it doesn't work, it's works only AC3

2) XBMC player -> HDMI -> SR-608 -> TV - DTS works, DTS-HD/DTS-MA doesn't work , I tested speaker configuration 5.1 and 7.1, in both options I hear only a noise

device settings XBMC in audio option I check HDMI device (TV Samsung or SR-608)

I cant speak for item 2 in regards to the DTS-MA etc, but for item 1 you might find that your TV doesnt support passing raw bitstreams back to the AV receiver of a certain kind.

My Sony TV wont bitstream DTS back to my receiver due to some licensing thing with the TV whereas my LG will. I thought samsungs did though, but maybe it varies model to model.

Either way that might only be part of your problem...
Reply
#9
@abeeson

you're right!
in order too check problem in the equipment chain I have my fall back solution e.g.
PS3, there I exactly know, that it has to work. So I can find very fast, if the problem
depends on my HTPC or the equipment chain (receiver, Flat, Beamer, speakers and
so on).
If I would only have my HTPC to check all things...I had really difficults to find the
problem

@forall
do you absolutly know, that "the things" normally works with other devices (e.g. blu ray player)?
or is it the first time to try that with your HTPC?
Reply
#10
Hi there
(2012-06-10, 19:50)forall Wrote: 2) XBMC player -> HDMI -> SR-608 -> TV - DTS works, DTS-HD/DTS-MA doesn't work , I tested speaker configuration 5.1 and 7.1, in both options I hear only a noise

Same config here and the same problem. only crackling noise.

THX
Chaos
Reply
#11
@Chaos_666

does it works with other devices; e.g. blu ray player?
Reply
#12
(2012-06-11, 12:29)Bladerunner1962 Wrote: @abeeson

you're right!
in order too check problem in the equipment chain I have my fall back solution e.g.
PS3, there I exactly know, that it has to work. So I can find very fast, if the problem
depends on my HTPC or the equipment chain (receiver, Flat, Beamer, speakers and
so on).
If I would only have my HTPC to check all things...I had really difficults to find the
problem

@forall
do you absolutly know, that "the things" normally works with other devices (e.g. blu ray player)?
or is it the first time to try that with your HTPC?

@Bladerunner1962 - I don't have any problem with DTS if I have a xbmc 11.0 and XBMCbuntu 11.10. In friday I upgrade XBMCbuntu to 12.04 and now I had a problem with DTS soundtrack.
With xbmc 11.0 in audio settings I put a custom device plughw:0,3 and it's works correct.
On the current xbmc version in xbmc audio settings I can choose alsa digital or hdmi samsung tv. On the second optins I have a sound but only AC-3, DTS isn't work.
I don't have a blu ray player...
Reply
#13
Hi
(2012-06-11, 12:47)Bladerunner1962 Wrote: @Chaos_666

does it works with other devices; e.g. blu ray player?
sorry no other devices here :-(

THX
Chaos
Reply
#14
I have still problem with DTS soundtrack and DTS-HD/DTS-MA.

In 1st case I have xbmc is connected

1) XBMC player -> HDMI -> TV - DTS it doesn't work, it's works only AC3

On current xbmc version from git I cat choose audio device like: plughw,hw,card e.g, but in passtrough I can only have one options (my tv name). In xbmc 11.0 in both options I can choose the same custom device.

2) XBMC player -> HDMI -> SR-608 -> TV - DTS works, DTS-HD/DTS-MA doesn't work , I tested speaker configuration 5.1 and 7.1, in both options I hear only a noise
Reply
#15
TVs almost never support dts bitstreaming. uncheck dts capable receiver and it will be transcoded to ac3 on the fly.

what video card are you using?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC from GIT - DTS/DTS-HD/DTS-MA not works00
This forum uses Lukasz Tkacz MyBB addons.