Thread Rating:
  • 0 Vote(s) - 0 Average
iPad - & [iPhone] Can't play files shared on Windows 7 machine
#1
Hi guys. I've been having problems accessing my video files stored on my WIndows 7 desktop from all my iOS devices (iPad 1 & 2, iPhone 3GS and 4S). I can see the files listed (albeit taking much longer to display folders now), but when I select a file, it would show the "WORKING" rotating dials for quite a long time, it would then look as if it's playing with the top left saying "Now Playing "filename", but the video doesn't show on the screen. Sometimes a file would start to play, but it would keep buffering and eventually stop. All the files on my LG NAS play fine. Can anyone advise what could be causing this? I recall making some Windows 7 updates a few days ago, but not sure whether that caused this problem?

Huh

Any help appreciated!!! Many thanks!!
Reply
#2
iOS XBMC.log (wiki) file would be the first port of call, though it sounds like a networking issue.
Reply
#3
Thanks Ned.

Here's the log file from my iPad. I suspect it's a networking issue too. But I can't recall whether I made any changes to the Windows 7 PC. Sad

http://xbmclogs.com/show.php?id=3536
Reply
#4
Bump please. Sad
Reply
#5
From the debug log I see that your video DB is corrupted. I'm not sure if that would cause this, but resetting that would be worth a shot. Use something like iFile from Cydia and delete the following file

/private/var/mobile/Library/Preferences/XBMC/userdata/Database/MyVideos60.db
Reply
#6
(2012-06-20, 03:29)Ned Scott Wrote: From the debug log I see that your video DB is corrupted. I'm not sure if that would cause this, but resetting that would be worth a shot. Use something like iFile from Cydia and delete the following file

/private/var/mobile/Library/Preferences/XBMC/userdata/Database/MyVideos60.db

Cool. Thanks for that. I'll give that a try tonight.
Reply
#7
(2012-06-20, 03:29)Ned Scott Wrote: From the debug log I see that your video DB is corrupted. I'm not sure if that would cause this, but resetting that would be worth a shot. Use something like iFile from Cydia and delete the following file

/private/var/mobile/Library/Preferences/XBMC/userdata/Database/MyVideos60.db

Still getting the same error. Also tried deleting the whole XBMC folder from Preferences and re-installed on iOS. Still the same problem. I'm starting to think it's a problem on the Windows side. Could there be some sort of file permissions conflict or something? Sad

I've already tried the fix on thread SMB share issue only on ATV2 running nightly:

(2012-06-08, 15:31)atv2jber Wrote: @maans88

1) Open Notepad.
2) Cut and Paste the following into Notepad:
—————————————
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters]
“Size”=dword:00000003

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
“LargeSystemCache”=dword:00000001
—————————————
3) Save as smbfix.reg (the .reg is important) to your Desktop
4) Exit Notepad
5) Double click on smbfix.reg, answer Yes to any questions.
6) Reboot Windows.

You are done.

It did work for a day or so, but today. The same problem again. Sad
Reply
#8
Not sure at this point. I'd bet on it being a configuration issue on the Windows side, but I haven't configured shares with Windows 7 before, just XP.
Reply
#9
have you tried the 'Everyone' user? .. it only worked for me when I did the following below in Win7:

a) On the shared directory, make sure you have appropriate file permissions (right click Properties->Security tab->'Edit' button.. add 'Everyone' user with read permissions)

b) On the shared directory, make sure you have appropriate share permissions (right click Properties->Sharing tab->'Advanced Sharing'->'Permissions'->'Add'.. add 'Everyone' user with read permissions.

Well I had to do these steps for my setup. Hope this works for anyone out there.
Reply
#10
(2012-06-23, 05:19)toshiba1 Wrote: have you tried the 'Everyone' user? .. it only worked for me when I did the following below in Win7:

a) On the shared directory, make sure you have appropriate file permissions (right click Properties->Security tab->'Edit' button.. add 'Everyone' user with read permissions)

b) On the shared directory, make sure you have appropriate share permissions (right click Properties->Sharing tab->'Advanced Sharing'->'Permissions'->'Add'.. add 'Everyone' user with read permissions.

Well I had to do these steps for my setup. Hope this works for anyone out there.

Thanks for that. Double checked all those settings and they were in fact as you said. Just totally baffled why it's not liking it. Sad Was playing fine previously. I'm pretty sure a recent Windows update has done this, but I just can't remember when and which one caused this.
Reply
#11
I've started to try again to get this to work after leaving it for a month. Noticed that music files play fine (although it takes quite a while for a song to play ~ 1 minute).

this is only a problem for all non Windows systems. I have two other laptops (one running Windows XP and the other running Windows 8) and there are no problems at all. All my iOS devices have this problem. I'm able to see all the shares/folders/files, but videos just don't play. Files running on my NAS play fine. So I'm pretty sure that it's a permission issue of some sort with iOS and Windows 7 shares.

Is it worth me uninstalling Windows 7 and re-installing?

Thanks!
Reply
#12
The only other thing I can think of to try is to make sure the sources are using IP addresses instead of NetBIOS names. Sometimes the lookup on NetBIOS names can cause a delay like that.
Reply
#13
(2012-08-03, 02:09)Ned Scott Wrote: The only other thing I can think of to try is to make sure the sources are using IP addresses instead of NetBIOS names. Sometimes the lookup on NetBIOS names can cause a delay like that.

Thanks. I'm pretty sure it's using IP addresses, but how do I check that?
Reply
#14
If you bring up the contextual menu and select "edit source" it should then show you what you entered for that source.
Reply
#15
(2012-08-04, 01:05)Ned Scott Wrote: If you bring up the contextual menu and select "edit source" it should then show you what you entered for that source.

Thanks Ned, but mine is saying:

smb://192.168.1.21/files

This is the Windows 7 PC where I have my files, but still having problem playing. It lists all the files very quickly, even showing the poster images, but the files just won't play. Sad

Any ideas? Cheers!
Reply



& [iPhone] Can't play files shared on Windows 7 machine00