Nvidia Geforce 8400 GS
#1
Hello all,

I am looking to upgrade my htpc to eden on ubuntu (but not xbmcbuntu as I have been experiencing some difficulties on another box). Here are the specs from my build in progress:

Case: Foxconn Case
CPU: Intel Pentium Wolfdale E5700
GPU: Nvidia GeForce 8400GS
RAM: GSkill 2Gb

The real point of my question is how can I ascertain if my GPU supports 24p playback. After every install of XBMC, I only see the option for 60hz available and even after checking the "sync refresh rate" for my content, the video codec info always shows only 60hz. I am fairly sure I have been updating to the latest Nvidia drivers. Is there something I am missing here?

Thanks,
Rob
Reply
#2
It does support it but your config might be off. Try the manuel method to fix it laid out in this post:

http://forum.xbmc.org/showthread.php?tid=70068

That is how I get 24p to work on one of my TVs.
Reply
#3
poofy,

I gave that a shot but just recently upgraded to Eden on Ubuntu 12.04 and when trying to follow the instructions after loading in the new Xorg file and restarting lightdm (not gdm as I found out), my system hangs at a black screen and will not boot. I don't believe this guide is current for builds on 12.04.

When trying to match refresh rate to content now, I show 55hz to a 24fps film giving obvious jutter. I know my television is capable of displaying 24hz and my content is 24fps so the only missing link is getting my Nvidia 8400 to output the appropriate refresh. Am I outta luck?

Thanks,
Rob
Reply
#4
I will be honest I have only tried that on XBMCbuntu which is 11.10, but it works perfectly there and every previous release. Xorg hasn't changed in years so unless something new is messing it up (like wayland) then it should work.

Try the script. You have to edit it first (change the four instances of XBMClive to lightdm as you discovered). I would love to know if that fails.

It can't be the card. It is some EDID nonsense.
Reply
#5
Interestingly enough, I WAS able to get this to run and now my codec info reports 24hz with content at 23.97fps. Only problem is, the judder is now worse than it was at 60 hz. Any idea what I may have done wrong?
Reply
#6
Actually it sounds like it is working correctly! Judder is a side effect of 24p.

http://www.projectorcentral.com/judder_24p.htm
Reply
#7
I have a hard time believing that the countless people who are striving for perfectly synched 24fps playback are doing so to watch what I'm watching...

I have another xbmc eden build on a revo 1600 that had multiple refresh rates out of the box and switched the display with ease. It has buttery smooth playback. I'm not sure if I'm buying it poofy.

The big difference I'm seeing between the two builds is that my Revo will switch my LCD TV to 24 hz while this current build leaves it in 60 while displaying 24 in the codec info. Thoughts?
Reply
#8
Well definitely don't buy it if you have another box that performs differently. 24p is 24p- it should work the same on all clients. I just posted that link because more than once on the forum someone has gotten 24p to work only to discover the flaws of using it. What you have is beyond that apparently.

The TV is what tells the truth. It sounds like the TV is staying at 60 hz but the box is changing to 24p, which would explain the terrible judder- nothing is correctly doing 3:2 pulldown. It must be rough.

What that tells me is that the TV is still having trouble identifying that the content is being sent at 24p. But the system thinks that is what is happening or it wouldn't play in 24p.

I have gone too long without asking- what model is the TV? Maybe I can hunt down a custom Xorg for you.
Reply
#9
Poofy,

I have a Samsung LN46A LCD TV and as I mentioned, it is fully capable of displaying 24. Here's my current Xorg.0.log file:

http://pastebin.com/bL4VqjKN

and my current Xorg.conf

http://pastebin.com/EvCBB6Tc

I truly appreciate your attention. How exactly can I tell if XBMC or the GPU is sending a command to the TV to change modes?

Rob
Reply
#10
Sorry for the delay.

Looking at the log the TV rejected the modes you had. I would nuke your Xorg.conf and run the script again.
Reply
#11
As in simply run it again or restore it to the original xorg file that I have backed up then run the script again?
Reply
#12
Restore the original and run it again. Good question.
Reply
#13
Ok,

Reloaded the original Xorg.conf and then reran the nvidia script. Same exact symptoms as before. Codec reports 24hz but again the TV is not switching to 24hz. Where exactly in the log can you tell that the TV is being told (or not told) to change modes?

This is interesting, here's my debug log of trying to play 300 with the display sync to 24hz option "on". You can see toward the end all the discontinuities that are causing the visible judder. Thoughts?

http://pastebin.com/EKTsJFgN
Reply
#14
Thanks for that log. From the looks of it I would swear you have an audio problem. But the way your TV is acting and the fact that file is a non-standard resolution (800h) and the 8400 gs is a Feature Set B decoder makes me also wonder if that is an issue.

Will you try something else? Will you find a file in your collection that is completely standard (so height exactly 1080 or 720) and play it and shoot over the log. Also how is your audio configured?
Reply
#15
Here's another log while playing a file with height 720. Still appears to have the same judder. My audio setup is HDMI 2.1 with custom audio devices for my GPU (plughw:1,7). I have tried several combinations of audio config and there are a few that work "analog" with Custom, "hdmi" with custom, etc. None of them seem to have any effect on the judder at 24hz that I am currently seeing.

http://pastebin.com/Gtj0VKzr

Thanks.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Nvidia Geforce 8400 GS00