•   
  • 1
  • 33
  • 34
  • 35(current)
  • 36
  • 37
  • 62
  •   
[RELEASE] Twitch.tv
(2016-04-28, 23:43)akajod Wrote: I am having a problem with Full HD Quality a while now. After a while watching twitch in 1080p the video and the audio arent synced anymore.
This problem doesnt cause if i play the stream in 720p. Anyone can help me to get a solution?
Having the same problem...
It's so weird, I can't find the correct audio offset for the delay, no matter how much I fiddle with it.

Did you find a solution?
Reply
(2016-09-30, 22:07)Crowly Wrote: If you wan to watch some of the TwitchCon streams you need to add (at least) '1080p60 - source' and '720p30 - source' to QUALITY_LIST_STREAM and/or QUALITY_LIST_VIDEO (i did both just to be sure) in .kodi/addons/plugin.video.twitch/resources/lib/twitch/constants.py to be able to watch

Code:
QUALITY_LIST_STREAM = ['Source', '1080p60 - source', '1080p60', '1080p30', '720p60', '720p30 - source', '720p30', '540p30', '480p30', '360p30', '240p30','144p30']
QUALITY_LIST_VIDEO = ['live', '1080p60 - source', '1080p60', '1080p30', '720p30 - source', '720p60', '720p30', '540p30', '480p30', '360p30', '240p30','144p30']

Thanks for this, I was wondering why I was getting errors.
Reply
(2016-09-30, 22:07)Crowly Wrote: If you wan to watch some of the TwitchCon streams you need to add (at least) '1080p60 - source' and '720p30 - source' to QUALITY_LIST_STREAM and/or QUALITY_LIST_VIDEO (i did both just to be sure) in .kodi/addons/plugin.video.twitch/resources/lib/twitch/constants.py to be able to watch

Code:
QUALITY_LIST_STREAM = ['Source', '1080p60 - source', '1080p60', '1080p30', '720p60', '720p30 - source', '720p30', '540p30', '480p30', '360p30', '240p30','144p30']
QUALITY_LIST_VIDEO = ['live', '1080p60 - source', '1080p60', '1080p30', '720p30 - source', '720p60', '720p30', '540p30', '480p30', '360p30', '240p30','144p30']

Thanks Crowly Nod
Reply
Hey guys, first time posting here.
My Twitch.tv addon worked correctly on Kodi 15, although i didn't use it that much on the last few months.
A few weeks ago i upgraded to Kodi 16 but didn't try to use Twitch addon.
With the LoL Worlds being played right now I was trying to watch it with Twitch addon but it doesn't load any stream.

Here is the part of the log I think refers to the error:


18:54:37 T:8632 NOTICE: [xbmcswift2] Request for "/playLive/hanjarolol/-2/" matches rule for function "playLive"
18:54:40 T:7304 NOTICE: DVDPlayer: Opening: https://video-edge-c686f0.cdg02.hls.ttvn...c1633b09af
18:54:40 T:7304 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
18:54:40 T:2260 NOTICE: Creating InputStream
18:54:40 T:2260 NOTICE: Creating Demuxer
18:54:53 T:2260 ERROR: CDVDPlayer::OpenDemuxStream - Error creating demuxer
18:54:53 T:2260 NOTICE: CDVDPlayer::OnExit()
18:54:53 T:7304 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.twitch/playLive/hanjarolol/-2/]
18:54:53 T:7304 NOTICE: CDVDPlayer::CloseFile()
18:54:53 T:7304 NOTICE: DVDPlayer: waiting for threads to exit
18:54:53 T:7304 NOTICE: DVDPlayer: finished waiting
18:54:53 T:7304 NOTICE: CDVDPlayer::CloseFile()
18:54:53 T:7304 NOTICE: DVDPlayer: waiting for threads to exit
18:54:53 T:7304 NOTICE: DVDPlayer: finished waiting

In between those lines, there's a lot of these ones:
18:54:40 T:2260 ERROR: CCurlFile::GetCookies - invalid cookie:

If any of you guys could manage to help me, thanks in advance.
Reply
(2016-10-07, 20:12)Barushkas Wrote: Hey guys, first time posting here.
My Twitch.tv addon worked correctly on Kodi 15, although i didn't use it that much on the last few months.
A few weeks ago i upgraded to Kodi 16 but didn't try to use Twitch addon.
With the LoL Worlds being played right now I was trying to watch it with Twitch addon but it doesn't load any stream.

Here is the part of the log I think refers to the error:


18:54:37 T:8632 NOTICE: [xbmcswift2] Request for "/playLive/hanjarolol/-2/" matches rule for function "playLive"
18:54:40 T:7304 NOTICE: DVDPlayer: Opening: https://video-edge-c686f0.cdg02.hls.ttvn...c1633b09af
18:54:40 T:7304 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
18:54:40 T:2260 NOTICE: Creating InputStream
18:54:40 T:2260 NOTICE: Creating Demuxer
18:54:53 T:2260 ERROR: CDVDPlayer::OpenDemuxStream - Error creating demuxer
18:54:53 T:2260 NOTICE: CDVDPlayer::OnExit()
18:54:53 T:7304 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.twitch/playLive/hanjarolol/-2/]
18:54:53 T:7304 NOTICE: CDVDPlayer::CloseFile()
18:54:53 T:7304 NOTICE: DVDPlayer: waiting for threads to exit
18:54:53 T:7304 NOTICE: DVDPlayer: finished waiting
18:54:53 T:7304 NOTICE: CDVDPlayer::CloseFile()
18:54:53 T:7304 NOTICE: DVDPlayer: waiting for threads to exit
18:54:53 T:7304 NOTICE: DVDPlayer: finished waiting

In between those lines, there's a lot of these ones:
18:54:40 T:2260 ERROR: CCurlFile::GetCookies - invalid cookie:

If any of you guys could manage to help me, thanks in advance.

I have the same probelm only the World Championship stream is broken for me other lol streams work fine.....everything was working last week I also tried fully unistalling the addon and nope doesn't work so its most likely a twitch problem.
Reply
Current version on github has fixed this issue. Will be updated on official repository soon.

https://github.com/MrSprigster/Twitch-on...master.zip

Sprig
Reply
Thanks for trying to help, but I'm still having the same issue.
Correct me if I'm wrong but that zip is supposed to overwrite what's on "[...]AppData\Roaming\Kodi\addons\plugin.video.twitch\", right?
If I'm doing that the right way the issue still remains:

14:09:12 T:10140 NOTICE: [xbmcswift2] Request for "/playLive/edwardlol/-1/" matches rule for function "playLive"
14:09:17 T:6984 NOTICE: DVDPlayer: Opening: https://video-edge-c55a8c.cdg02.hls.ttvn...93458c1197
14:09:17 T:6984 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
14:09:17 T:9828 NOTICE: Creating InputStream
14:09:17 T:9828 NOTICE: Creating Demuxer
14:09:29 T:9828 ERROR: CDVDPlayer::OpenDemuxStream - Error creating demuxer
14:09:29 T:9828 NOTICE: CDVDPlayer::OnExit()
14:09:29 T:6984 NOTICE: CDVDPlayer::CloseFile()
14:09:29 T:6984 NOTICE: DVDPlayer: waiting for threads to exit
14:09:29 T:6984 NOTICE: DVDPlayer: finished waiting
14:09:29 T:6984 NOTICE: CDVDPlayer::CloseFile()
14:09:29 T:6984 NOTICE: DVDPlayer: waiting for threads to exit
14:09:29 T:6984 NOTICE: DVDPlayer: finished waiting
Reply
Yep, that's how you install it manually.

I've just tried that same streamer with the latest Git version and it worked great @1080p so your issue is being caused by something else. Possibly the known ffmpeg https problem on some Linux systems.

What platform are you on and what version of Kodi?

Sprig
Reply
Just as a note: log snippets are in general totally useless as they do not contain all the info needed.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
Thanks again for the reply.
I'm running Kodi 16.1 on Win 7.
Don't know if it helps but if I try to watch livestreams on youtube, via the youtube addon, I get a similar error.
Reply
(2016-10-09, 16:28)Barushkas Wrote: Thanks again for the reply.
I'm running Kodi 16.1 on Win 7.
Don't know if it helps but if I try to watch livestreams on youtube, via the youtube addon, I get a similar error.
Ah well i think that only got "fixed" in v17 as more streams changed. For me Twitch works in V17 at least.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
Just upgraded to Kodi v17 latest beta and the streams are working, thanks Martijn.
And also thanks MrSprigster for taking the time to try and help me.
Reply
@MrSprigster maybe a good idea to put this in your OP?

Do all streams fail or only certain quality? If you know which you could detect Kodi version and then only add stream that you know work. Is the original author still active btw? Can't recall who send us the last update. (seems like last one was from ccaspers who has a fork of yours).

If you took over it's best to create a new thread and we will close this one with a reference to the new one.


edit:
right it seems Gotham also had a version while Isengard has a newer one and i see you did the last update. Thx Smile
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
For me all the streams I tried (about 5 or 6) failed on 16.1, and I tried at different qualities with the same result.
Reply
(2016-10-09, 17:12)Barushkas Wrote: For me all the streams I tried (about 5 or 6) failed on 16.1, and I tried at different qualities with the same result.

If that is the case it might be better to mark it broken in our repo (everything below v16) and that the working one is only put in v17 repo.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
  •   
  • 1
  • 33
  • 34
  • 35(current)
  • 36
  • 37
  • 62
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Twitch.tv8
This forum uses Lukasz Tkacz MyBB addons.