Allwinner A10: Android support
Let's continue the android discussion started in the other Allwinner A10 thread here.
I received my Mele A1000 today but I have some issues playing media. I tried the following players:
1) BSplayer: HW mode doesn't work when streaming media over the network.
2) MX Player: No sound (HDMI) when playing .mkv
3) Pre-installed player: Same as MX Player.
4) Moboplayer: Doesn't start playing at all.
5) mvideoplayer: Same as MX Player

Live TV streams from TVHeadend doesn't seem to work either (audio out of sync or no playback at all).

Anyone knows a fix for the HDMI audio and/or a good player for Allwinner A10?
going to move this to off-topic as it has nothing to do with xbmc-general-discussion
(2012-06-22, 21:57)Snippo Wrote: 2) MX Player: No sound (HDMI) when playing .mkv

Try software decoding. I had no sound on one video and had to s/w decode the sound track.
Thats odd, works for me (the hdmi audio) with mx player. Did you install the Mx player armv7 codec? You'll find it on Gplay

EDIT: here you got it running
Looks like only AC3 audio works under android (MX player). Movies with DTS audio won't give me sound over HDMI. Also HTTP streams (TVHeadend) have a lot of problems with lag and out of sync audio.
I found some more info about AC3/DTS on cnx-software:

Apparently it will be fixed in the official Android ICS firmware. Hope they will release it soon because like this the only way to play a movie is with MX player's audio software decoding.
Using android will this box mount and play DVD ISO files located on a shared network drive?

Can it display the DVD menu?
(2012-06-29, 20:37)0level Wrote: just for any one intrested official ICS 4 is available @

but download speed is very sloooooooooooooooooooooooow.

did any one got it ?
I downloaded the version mentioned here. I'm not sure if that is the official release but it's horrible:
1) AC3/DTS still doesn't work.
2) The launcher isn't remote friendly.
3) If HDMI 720p is selected you won't be able to play any videos. It just gives a black screen. It does work on 1080p...

Imo the unofficial(?) release was better...
I can't get this to work for the life of me for my Mini X, despite finding what someone else has confirmed as a Mini X friendly Android 4.0 image. I image the card, put it in, and it boots up like normal with no FW update. I suspect that it might be my microSD card, but I read a lot of people having issues regardless of microSD card used, and the same microSD cards being able to install linux.

I did notice there seems to be some other method of updating, as there is an "Update" app on the unit, but it's all in Chinese. There are some buttons, including online update and local update, with local update leading to two more buttons called "OTA update" and something about selecting an image. Does anyone know what is up with that? None of the buttons seem to do anything. I've tried various combinations of things, like using OTA update, online update, local image, having the img file on a FAT formatted mSD card, having the img file "burned" to the mSD card, etc.

I can't select any of the instruction text to put into google translate, but it seems parts of it talk about img files and SD cards. Might be an alternative update method.

@Ned_scott I used the image from the CNX site linked above, and everything but the remote control works great. As mentioned in another thread I need to get the hardware decocding working, but otherwise the install process was 100% painless. Try a different card (specifically try regular SD as opposed to SDHC) I am going to try the official release (the one from CNX is unofficial) right now and report back if it works or not.
There's another flash method through the livesuite which is what the mk802 uses, you hook it up to your PC via USB though I don't know if it works this way with the Mini X.

There are some mirrors of the official mele Android ICS firmware in the comments on the bottom of the cnx-software page Snippo linked to, it seems to run well enough I noticed the same problems that Snippo mentioned. MX Player Pro seems the best option after the stock media player but the audio for AC3 is out of sync slightly with software decoding. The Mele guys did release a patch which enables AC3 + DTS but only for older firmware, maybe they will release one for this too.
I found an audio patch for ICS on the mele forum (the forum is down right now so here's the direct link):

Seems to be working for me Smile. I hope the 720p HDMI bug will also be fixed soon because the setting seems to reset itself to 720p sometimes.

Seems the Mini X does have a USB port that will connect to a computer. Both are female ports and will normally work as USB host, but when unplugged from power, and using a male to male USB cable, pluging into the one labeled "USB OTG" connects the Mini X. I'll try that other method in a bit. Thanks for the tip!.
Ned Scott: are you using Android 4 or 2.3 right now? Now that you mention the USB OTG port I realized that it too does not function properly using the currently available Mele android 4.0 image (this in addition to the IR not working). I am currently await reply to an email I sent to Pineriver to see if they have an ICS image that we can use. As I said before everything seems to work well, but my heat issue might be related to to using the mele img.
still on 2.3 right now
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Allwinner A10: Android support00