•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 10
  •   
How To: Easy synchronised multiroom audio (inc. Spotify!) using XSqueeze in XBMC
#61
Just pushed new version 0.8 which disables the new AudioEngine while XSqueeze runs so you could go back to wasapi now if you want.
Sorry, no help w/out a *full debug log*
Reply
#62
That is good news, I couldn't live with the sometimes distorted sounds coming out of the direct sound setup, so I was ready to give up using XSqueeze. Now I will turn it on again :-)

Spotify is supported by some of Logitech's own physical products - http://www.spotify.com/dk/squeezebox/
Is it an XBMC limitation or a Logitech restriction that makes Spotify unplayable ("Problem: Unable to play file type for") through Squeezebox over iPhone and XBMC?
Reply
#63
It's a DRM issue - spotify don't want their stuff streamed to software players, basically.

There is some hope on the linux horizon via a player squeezelite which I will maybe look at embedding as an alternative to squeezeslave, but I don't think there are any windows options.

Should be fine with Wasapi and XSqueeze 0.8+
Sorry, no help w/out a *full debug log*
Reply
#64
Xsqueeze is hanging and locking up XBMC upon exit. i saw your warning about the disable screensaver setting in the addon, but I don't have that option? i see there are some screensaver settings under the Player tab of my LMS server...should I adjust those?

LMS is installed on an Ubuntu server I use as my NAS/Mythtv server
XSqueeze is on a W7 x64 machine running Eden with AEON MQ3 skin
XSqueeze is launced from a shortcut on my bar
Reply
#65
Yep exiting is a bit screwed up at the moment. I am trying to fix it but it was hard until recently as the logging for addons was so crappy for a while. I hope ot have a new version in the next few days that solves the issue...I am basically doing some cleanup and bug fixing, remving a few experimental things to make sure the day to day works better....but as always fitting it in around job/kids/life etc!
Sorry, no help w/out a *full debug log*
Reply
#66
ahhh....ok. glad to hear it's a known bug and i'm not just doing it wrong. works great otherwise playing local radio stations (nice!) and my own mp3 library


couple last things:
1) am i supposed to see the xsqueeze/squeezeslave player in the mysqueezebox.com "Player" tab? i only get an "oops..." message there
2) should apps work? like slacker, pandora, etc? i have free accounts on both. i'm guessing this is too much to hope for w/ software only
Reply
#67
On 2) unfortunately no - although there is some possibility of a solution on linux I may look into later....linux only so far puts me off, though, as my main client in Windows. But I will check it out when I have time.

1) Haven't actually looked - I would have thought squeezeslave could register on mysqueezebox.com as a player but being software only, I don't know really. I don't really use mysqueezebox.com, just do it all through he players themselves.
Sorry, no help w/out a *full debug log*
Reply
#68
Released 0.8.2 - this should hopefully solve the crash on exit issues. (I restored the previous slow-but-safe behaviour).

Sorry, no help w/out a *full debug log*
Reply
#69
I am in the mix of planning my own AV multi zone, multi-source system, wanting to originally use a passive/active system using ATV2 with and XBMC. I have setup a Niam/Netstream AV System with the help of being given the dealership software, but as good as it is, it very overpriced!

As squeezebox doesn't work on ATV2, I have had to adjust my parameters.

So, I have a few Raspberry PI's so this is the route I’m looking to now take.

This brings me to a few questions...

1. I really want to use the ATV2, as I have a few. How hard would it be to create the binaries?

2. If I have to truly abandon the ATV2, is squeezebox (XBMC) really able to play multiple track to different zones, IE if I had 5 zones, but I wanted to play 1 track in Zone1, Zone2 and Zone3. And play another track from the same source to Zone4 and Zone5?

3. If Squeezebox can't do the above, when what is the difference between squeezebox and ITunes airplay?
Reply
#70
1. No idea bout this - but the squeezeslave developer said 'no chance' when I asked. But that may have been 'no chance I am going to do it'

2. Yep, no problems. This works fine.

3. N/a

Sorry, no help w/out a *full debug log*
Reply
#71
Many thanks for the reply... In the mean time, I have been trying to get Xsqueeze to work on two different images of OpenELEC, but TNA.

I have set up the LMS on WinTel7 - Runs fine. On the same box, ran XBMC with your plugin. Used the online remote and the IOS App Squeezebox, all well and good.
Added a second machine - Wintel XP. Changed the xSqueeze Mac address on XBMC. All working, bar user error and some odds and sods.

Problems occurred with the Raspberry PI's. Grr... Both Pi's are Model B's. Running different versions of OpenELEC.

I understand that you want little involvement with the distro's, and I have also notice the comments on page5 which you answered to jcoh. Q. Is it my understanding that you believe that xSqueeze will only work on the Xbian distro for RPI?

Background to my OpenELEC issues...
---------------------------------------------------
One Version of OpenELEC is via Berryboot, R11273 (I think) - This comes up with processor errors (Same as what you see if you try running on ATV2)
The second OpenELEC image is the latest one R12796, and everthing look like its going to work, "Looking for LMS, it will take 10 seconds... etc" then XBMC Craps out. Black Screen, then starts back up, stating that it has just added "pulse eight cec adapter".

I know I should see if xSqueeze can work work via terminal first, but can anyone else confirm if they have managed to get xSqueeze to work via OpenELEC. If so, which image?

Many thanks
Reply
#72
I believe the latest OE has updated alsa drivers I think for Rpi (....but I find it crashy as hell on my Shuttle).

I'd go ask the OE people, really, and have a look in your debug log to see what might be happening.

I have a major Python crash going on in OE (only) with another addon, and have submitted a bug, but I think OE/Python is a bit shakey right now...



Sorry, no help w/out a *full debug log*
Reply
#73
(2012-12-30, 18:52)meanmeech Wrote: I know I should see if xSqueeze can work work via terminal first, but can anyone else confirm if they have managed to get xSqueeze to work via OpenELEC. If so, which image?

I for one gave up on the combination of xSqueeze and OpenELEC on rasPI. I first went for raspbian wheezy+squeezeslave, which worked all right. The lack of airplay turned me to an install of raspbmc (which support USB-sound) - but without xSpqueeze (couldn't connect to server).
Reply
#74
great work bossanova! this is fantastic. installation and setup following your instructions was pretty straightforward, took a bit of head scratching to figure out what you meant by "2 lines at the bottom"

Right now I have LMS on OSX and the following players
- Eden on OSX (same computer as server)
- Frodo RC2 on Win7 laptop
- Frodo RC2 on Win7 desktop
- Eden on Xbmcbuntu laptop

entire network is wifi

Only issue is they are all out of sync, not surprised considering the range of platforms, hardware competency etc and I haven't attempted to tweak the sync delays or using Ethernet as yet.

I also tried with the LMS on Win7 to no avail.

Wondering if you had any advice on how to approach getting them sync'd up.

Thanks again!
Reply
#75
Basically you want to look at the squeezeslave wiki (and LMS wiki) - and add the appropriate parameters but I think you'll find it hard to get them all syncing really well with such a mix of systems. Also - the latencies often vary, so you can tweak it and get it right, but then it will drift. The idea is for acceptable sync (room to room level sync) more so than perfect sync (for in one room - needs hardware players really).

I am doing a new version with the option on a new player (squeezelite) which has a more modern playback engine, which may (or may not!) help. I hope to release that within a few weeks but it's a fair bit of work/testing due to multiple platforms. If you follow this thread http://forum.xbmc.org/showthread.php?tid...&page=last you can get a preview...although don't use the one I have posted there so far as it's already well out of date....

Sorry, no help w/out a *full debug log*
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 10
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
How To: Easy synchronised multiroom audio (inc. Spotify!) using XSqueeze in XBMC52
This forum uses Lukasz Tkacz MyBB addons.