[Release] TheAudioDb.com Artists and Albums scrapers
#1
Image
Scrapers are available in the official repo.

See more about theaudiodb.com in this thread:
http://forum.xbmc.org/showthread.php?tid=134260

...and on http://www.theaudiodb.com

source
https://github.com/xbmc/xbmc/tree/master...udiodb.com
Reply
#2
Thanks olympia, I've tested both and they work well I think.

I'll try to improve the matching logic a little but the best thing most people can do is start adding data, artwork, music videos and "loves" to the site. Then everyone will benefit from these scrapers.
Reply
#3
Any idea why:

U2 - The Best of 1980-1990

Isn't scraping properly?

I checked the API and it returns a result. Maybe something to do with the - hyphen?
Reply
#4
Also I noticed "Tiësto" does not match correctly.

The API appears to show the result fine, any idea why its not working?
Reply
#5
"Tiësto" scrapes for me fine. Do you still have a problem with it?

Also, what exactly is wrong with "U2 - The Best of 1980-1990"?
Reply
#6
(2012-08-26, 16:52)olympia Wrote: "Tiësto" scrapes for me fine. Do you still have a problem with it?

Also, what exactly is wrong with "U2 - The Best of 1980-1990"?

Thanks for looking but neither scraper for me.

- No Album matches with a hyphen in it.
- "ë" special characters (and others) don't match either.

I've added Alternate names to the site and soon to the API but it would be good to get the special characters working also.
Reply
#7
I've added an Alternate name search to the API so searches for "Tiesto" should now work. "Tiësto" still wont work with this scraper though.

Still having problems with the hyphen in album searches though.
Reply
#8
maybe the problem is with caps in the case of U2, having the same problem with scraping LEN... not a problem with the scraper.. the api isn't returning results for LEN
Reply
#9
Still having a problem with hyphens in the album name. Another example is

Kraftwork - Trans-Europe Express

Doesn't return any results.
Reply
#10
(2012-10-07, 20:52)zag Wrote: Still having a problem with hyphens in the album name. Another example is

Kraftwork - Trans-Europe Express

Doesn't return any results.
This might just be because that album is listed as Trans-Europa Express on theaudiodb.com.

Compare a search for Trans-Europe Express with a search for Trans-Europa Express
Reply
#11
(2012-10-07, 21:17)scudlee Wrote:
(2012-10-07, 20:52)zag Wrote: Still having a problem with hyphens in the album name. Another example is

Kraftwork - Trans-Europe Express

Doesn't return any results.
This might just be because that album is listed as Trans-Europa Express on theaudiodb.com.

Compare a search for Trans-Europe Express with a search for Trans-Europa Express

Awesome spot! You were right, "Europa" was the German translation.

I've corrected it on TheAudioDB now and its scraping fine Smile

I think I will enforce the rule of only English naming for albums (even from awesome german bands)
Reply
#12
Found another one.

Tiesto - Just Be

Api is working fine, but in XBMC for some reason it is not

Code:
http://www.theaudiodb.com/api/v1/json/1/searchalbum.php?s=tiesto&a=just%20be

The API returns a different string "Tiësto" but the "Tiesto" will search fine also.
Reply
#13
Correctly matched 1 of 24 music videos to its artist. Doesn't like dashes, searching "B.o.B." results in an "unable to connect to remote server" error.
Reply
#14
@ legoman666, this is the artist scraper thread, not the music video thread.
Reply
#15
API - 401 unauthorized image errors have now been fixed.

Sorry if it broke anything in the last week.

All API thumbs are now 700x700 and fanart is 720p. The bandwidth was getting waaaaaay out of control Smile
Reply
 
Thread Rating:
  • 3 Vote(s) - 3.67 Average



Logout Mark Read Team Forum Stats Members Help
[Release] TheAudioDb.com Artists and Albums scrapers3.673