Live 10.0 rc2 vs 11.0 power on (USB) from suspend problem

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
cruiserandmax Offline
Junior Member
Posts: 7
Joined: Nov 2010
Reputation: 0
Post: #1
I have two identical hardware setups (based on Acer Aspire Revo 3610's)- same bios version/settings, same MCE remote & dongle/mouse/keyboard all plugged into same ports, same everything.

One has XBMC Live 10.0 rc2 installed and the other has XBMC Live 11.0 installed.

Both XBMC installs have the system settings power option to go into suspend (as opposed to hibernate or power off). The problem is that when the 11.0 system suspends it appears power to the USB ports is cut off since they keyboard/mouse/MCE remote will not wake the machine. Indeed the red blinky light on the IR dongle for the MCE remote won't flash in this state. However the 10.0 rc2 install will suspend and then wake fine from any of the USB devices. Initially I suspected this was bios related, but I confirmed that wake on USB is enabled identically on both machines. I even tried installing XBMC Live 10.0 rc2 onto the machine that was failing to wake-up from USB and then it was able suspend/wake-up from USB without a problem. So in my estimation this means software is the culprit. I couldn't find any other setting via the XBMC GUI in 11.0 that might help. Is there something I can look into at the OS level that could be related to the power state the hardware is being put into when the machine suspends?

This is driving my nuts... My only solution now would be to run 10.0 rc2 on both of these machines...

Thanks for any ideas.
(This post was last modified: 2012-07-18 06:35 by cruiserandmax.)
find quote
artrafael Offline
Team-XBMC Forum Moderator
Posts: 6,339
Joined: Jul 2010
Reputation: 114
Location: USA
Post: #2
You may need to tell the OS to keep the specific USB port(s) powered-up during suspend so the connected device (keyboard, mouse, remote) is able to send a signal to resume the system. I had to do that for both Dharma and Eden so my remote control can take my system out of suspend. See this wiki page for instructions (the key is the echo **** > /proc/acpi/wakeup command).
find quote
vbat99 Offline
Posting Freak
Posts: 2,127
Joined: Aug 2009
Reputation: 53
Location: New Zealand
Post: #3
This might help is getting power to usb when in sleep. Note the edit to grub. This is where making the system keep power to USB is set.

Hope it helps. (from this post: http://forum.xbmc.org/showthread.php?tid...pid1135997)

(2012-06-27 15:48)d_hero Wrote:  I followed this instructions:


On my Mythbuntu and MCE remote setup:

Created a new rule:


Code:
sudo gedit /etc/udev/rules.d/90-mcewakeup.rules

Entered this in with the correct product and vendor id's (with the help of lsusb):

Code:
SUBSYSTEM=="usb", ATTRS{idVendor}=="0471", ATTRS{idProduct}=="0815" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"

Edited one line in my grub (added "usbcore.autosuspend=-1 acpi_enforce_resources=lax"):

Code:
sudo gedit /etc/default/grub

Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 acpi_enforce_resources=lax"

Then:

Code:
sudo update-grub

Then after a reboot tested it and it worked.

The problem is that it relies on the vendor id and product id for each different usb receiver

Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
(This post was last modified: 2012-07-18 23:33 by vbat99.)
find quote
bilbonvidia Offline
Fan
Posts: 516
Joined: Jun 2011
Reputation: 2
Location: Great Britain
Post: #4
Is this the current definitive way in xbmcbuntu updated to 12.04 to enable resume via the remote? There seem to be one or two ways after googling.

Also in XBMCbuntu where is it that I can set it so the machine sleeps when the power button on my mce remote is pressed?
find quote
coolblue2000 Offline
Member
Posts: 56
Joined: Apr 2010
Reputation: 0
Post: #5
vbat99,

thanks for finding this. It has solved my issue perfectly. No idea why xbmc 11 buggered up my remote wakeup but it did.

Please note through that using the gedit command through putty just returned "command not found" so I edited the files directly using winscp.
find quote
vbat99 Offline
Posting Freak
Posts: 2,127
Joined: Aug 2009
Reputation: 53
Location: New Zealand
Post: #6
@coolblue2000
personally I use nano not gedit, but this was a quote from another very recent thread.

Glad it helped.

@bilbonvidia
I don't think there is only one way of doing this. I've seen ways of editing the power policy.

But, I've used the above sequence and found it worked for me many times. Well, except for one time, but that unit didn't allow for resume from sleep by remote, no matter what i tried.

Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
find quote