AppleTV 1 (silver) - Synergy remote keyboard setup
I'd love to get a remote keyboard solution working with ATV1.

I've read several people refer to Synergy. I followed the steps here:

To actually kick off the client on the ATV, I ran this (I can't figure out how to create the Application menu items -- but that's a separate issue):
./synergyc --restart -f mac.local

Where mac.local is my laptop name (the remote keyboard).

I get the same error that the guy on the wiki reports:
bash-2.05b# ./ dyld: Library not loaded: /System/Library/Frameworks/ScreenSaver.framework/Versions/A/ScreenSaver Referenced from: /mnt/Scratch/Users/frontrow/Applications/./ Reason: image not found Trace/BPT trap

Does anyone have any idea how to fix this? You'd be a life-saver. My thumbs are developing arthritis from having to repeatedly type usernames and passwords. (Fine, a thumb-saver.)

Alternately, does anyone have any other ways of using a keyboard remotely on the ATV1?

Thank you!
I gave up getting it to work on the Mac OS, but finally got it to work on Crystalbuntu.

For anyone else struggling with this, here's what I did. General instructions have been provided by someone else here. I've just outlined steps below to help get synergyc working on Crystalbuntu:

  1. Downloaded Synergy for your server (the controlling machine) from here:

    In my case, that was Mac OS X 10.7. It's a very easy install. There are a lot of FAQs on the configuration so I won't cover that.

  2. Downloaded the 32-bit Ubuntu/Debian package on the same page to the Crystalbuntu box. File name will be *.deb ('synergy-1.4.9-Linux-i686.deb' in my case).

  3. SSH to Crystalbuntu and installed the .deb package by running the following:
    sudo dpkg -i package_file.deb

    This should install to /usr/bin. Basically just the synergys and synergyc files are now in that directory.

    At this point, running synergyc gave me the following error:
    Quote:/usr/lib/ version `GLIBCXX_3.4.11' not found

  4. To fix that, I downloaded a working package from here:

    Extracted the package by running this:
    sudo dpkg-deb -x libstdc++6_4.4.5-8_i386.deb ./tmp

    Manually copied the library files to /usr/lib:
    sudo cp ./tmp/usr/lib/* /usr/lib/

    You should now be able to execute synergyc without errors.

  5. I got a segmentation fault error when running synergys on the server (the controlling machine).

    To fix that, I created an alias section in my synergy.conf file and mapped EXACT hostnames (basically, whatever 'hostname' returns in terminal on your server and Crystalbuntu client: in my case, they were 'macbook.local' and 'Crystalbuntu') to respective IP addresses, and then used the IP addresses in the rest of the conf file.

And that's it. The mouse doesn't seem to move anything on XBMC, but the keyboard works perfectly, and that's frankly all I care about. You can navigate easily using arrows, Enter and Escape.

I searched lots of forums to find this information, but these two threads were most helpful:

The *.deb file URL in the link above doesn't work, which is why I used the one in this link:
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Synergy remote keyboard setup00